Fire TV Stick 4K [SOLVED]



  • @lhw455 ,

    Yes. That was the ‘silver bullet’.



  • @lhw455

    Yes, the Monocle Gateway is required for the new FireTV 4K Stick. (as with most FireTV 4K devices). Monocle Gateway can help solve other problems such as compatibility between Reolink and Foscam cameras with Alexa as well. Most Amcrest cameras we have tested don’t require the Monocle Gateway for Amazon Echo devices or older FireTV devices. Hikvision can be hit or miss depending on model.

    More details as to why its requires is included here:
    https://forum.monoclecam.com/topic/9/firetv-4k-3rd-generation

    Thanks, Robert



  • FYI, I just posted a new entry under Alexa devices to reflect the requirements for this new device:

    https://forum.monoclecam.com/topic/112/fire-tv-stick-4k-3rd-generation-2018



  • @vmsman I have several older hikvision cameras and they work great without gateway. Just purchased the DS-2CD2342WD-I and can not get it to work. I enabled ONVIF and used the same admin user and password. VLC and Blue iris can see it. I even installed the gateway with @tunnel and no luck. Any suggestions? Thanks



  • @cmjanus If you can see the camera with VLC, my guess is that the ONVIF auto-configuration is not working as expected. Instead, try defining the camera explicitly in the Monocle gateway using the RTSP pathway. Also, Hikvision might be using their stream encyption, which Amazon won’t know how to handle. Be sure it is turned off.

    In general, for all Hikvision cameras, refer to the following for RTSP settings.

    Live View URL

    rtsp://<address>:<port>/Streaming/Channels/<id>/
    rtsp://<username>:<password>@<address>:<port>/Streaming/Channels/<id>/

    Where <address> is the IP address of your camera, <port> is the RTSP port of the camera, and <username> and <password> refer to the login credentials of your camera.

    Using the first format, you will be asked to login and verify your credentials before being allowed to view the stream.
    Using the second format, you will automatically login when requesting the stream

    <id> refers to the channel number and stream type of the camera. For example, an <id> of 101 refers to channel #1 (first digit, 1xx) using the main stream (second and third digits, x01).

    Typically, you’ll use a program such as VLC Media Player to decode the RTSP stream.

    Examples below.

    Main Stream
    rtsp://192.168.1.100:554/Streaming/Channels/101/
    rtsp://admin:examplepass123!@192.168.1.100:554/Streaming/Channels/101/

    Sub Stream
    rtsp://192.168.1.100:554/Streaming/Channels/102/
    rtsp://admin:examplepass123!@192.168.1.100:554/Streaming/Channels/102



  • @vmsman if I disable ONVIF I can only see the stream in vlc by the up address only. What do you mean define it explicitly in Monocle? Do you know how to turn off the stream encryption? This is the rtsp url I’m using with digest and @tunnel.
    rtsp://10.0.1.xxx:554/Streaming/Channels/101?transportmode=unicast&profile=Profile_1

    Do I need to do anything with ports? Thanks for the help.



  • @vmsman said in Fire TV Stick 4K:

    rtsp://admin:examplepass123!@192.168.1.100:554/Streaming/Channels/101/

    Try defining it like this without @tunnel and then with @tunnel if that does not work>

    eb5f664a-416a-473d-97b6-d3e91caaa22a-image.png



  • @vmsman I already tried that and it didn’t work. Any other ideas. Thanks.



  • @cmjanus Do you get any errors? Are you trying to display on an Echo Show or a Fire TV?



  • @vmsman On a firetv (non 4K). I ask to see camera, the home screen changes and says waiting for camera… and after a about 15 seconds reverts to the home screen again. Nothing happens and no errors on fire tv



  • @cmjanus What is the difference in behavior with @tunnel and without @tunnel for this camera when you “show on the Fire TV”?



  • @vmsman absolutely nothing on fire tv same thing for both



  • @cmjanus and yet other cameras are working through Monocle, but not this one?



  • @vmsman I have three hikvision and three trendnet cameras older 2015ish work with no gateway. A D link that I have since took down but needed to Gateway. I was also having problems with a reo link But return it thinking the hikvision would work. But the new one doesn’t.



  • @cmjanus I have three reolink cameras and one GW Security camera. They are all configured thru the gateway and work on echo show and fire tv 4k for me.



  • @vmsman I see on the gateway the IP of 10.0.1.70. That is not the computer IP nor the camera. I see the camera has IP filtering to allow or block. Wondering if I allow it to the specific addresses? Did u need to do anything to the router for ports?



  • @cmjanus

    The Monocle Gateway on startup will auto-detect the IP address of the host machine its running on. However it can get this wrong on some computers that may have more complex networking configs.

    On startup, you should see something like this:

    -------------------------------------------------
    MONOCLE RTSP SERVICE - INITIALIZED
    -------------------------------------------------
    FQDN = f065fdn6-2e66-433d-axa8-6g3aau7132aae.mproxy.io
    HOST = 10.1.1.56
    PORT = 443
    -------------------------------------------------
    

    If that IP address is wrong, then the Monocle Gateway won’t work. The FQDN is also a DNS entry that points to this IP, if that is resolving incorrectly or to the wrong IP address, then the Monocle Gateway won’t work.

    Please see this post for details on how to override the auto-detection settings:
    https://forum.monoclecam.com/topic/99/monocle-gateway-custom-properties

    Thanks, Robert



  • @vmsman said in Fire TV Stick 4K:

    @cmjanus What is the difference in behavior with @tunnel and without @tunnel for this camera when you “show on the Fire TV”?

    Technically speaking the @tunnel tag handles the stream between the IP camera and Alexa devices in a lightweight network tunneling approach where the stream is mostly just passed thru unmodified between the Alexa device and IP camera.

    @proxy on the other hand uses the Live555 RTSP proxy server under the hood to actually proxy the camera stream. Proxying the stream helps some incompatible cameras get past some of the Alexa issues and allows them to work. Especially cameras that may only support UDP connectivity and not TCP interleaved communication which Alexa devices require. By default, @proxy uses UDP connectivity to the camera’s streaming.

    As for the FireTV, that really does not matter – the Monocle Gateway handles the Amazon security requirements before the RTSP layer is ever handed off to the @tunnel or @proxy implementation.

    We typically suggest using @tunnel first since its lighter-weight and only use @proxy if that’s the only option your camera will work with.



  • This post is deleted!


  • @cmjanus said in Fire TV Stick 4K:

    rtsp://10.0.1.113:554/Streaming/Channels/101?transportmode=unicast&profile=Profile_1

    Based on the log, the Monocle Gateway looks like its working correctly.

    Try changing

    rtsp://10.0.1.113:554/Streaming/Channels/101?transportmode=unicast&profile=Profile_1
    

    to

    rtsp://10.0.1.113:554/Streaming/Channels/101
    

    You don’t want to specify the transport mode, you want to allow the RTSP layer to determine the appropriate transport and protocol to use.

    No, you do not need to open up any ports thru your firewall to the Internet.
    Post 443 must be accessible to the Alexa devices on your network, but based on the log data, that is working.


Log in to reply