Unable (so far) to Echo Show connect Hikvision NVR [SOLVED]



  • Hi. Have been unsuccessful in getting my existing Hikvision DS-7604NI NVR working with my Echo Show. I keep getting an Alexa message of “Unable to connect to camera.” I’ve tried a number of connectivity options via gateway, proxy server, @tunnel tags, changing video resolution, etc. All work with VLC but somehow do not work with Alexa.

    I have posted details of my Monocle configuration in the Devices/HikVision section of this forum. Would appreciate any insights in case I’m missing something obvious. I’d really like not to have to replace this existing camera set up to connect to the Echo Show.

    Thanks



  • @gargary said in Unable (so far) to Echo Show connect Hikvision NVR:

    DS-7604NI

    So, it looks like Hikvision uses an RTSP stream of the form:

    rtsp://admin:12345@192.168.0.64/Streaming/Channels/201

    In order to help you, can you take a screen shot of your camera in the Monocle gateway? Here is a camera of mine, for example:

    1b0518af-7b09-4274-a8c3-13244c1420bc-image.png



  • I had problems with my newer Hikvions showing on Fire TV. If it’s newer make sure ONVIF is enabled and create a user with same user/password as the camera log in. I also had to use stream 2. I am thinking the 1440 resolution was was too much for Fire TV (older version). I did all 720 streams and had no problem, so that my be the issue.



  • @vmsman Thanks for responding. Here is the current set up for the NVR

    34bf294b-9e6a-4f7d-a0d3-ebcdb63da0fb-image.png

    As mentioned, I’d also tried using the gateway/@tunnel method but removed it from the configuration after it did not work either.

    Please let me know if anything jumps out.

    Thanks



  • @cmjanus Thanks. I will see if I can play with the items you suggest.



  • @cmjanus Thanks for your suggestions.

    I tried reducing the resolution – and in fact the Echo Show seems to only handle up to 720, according to Amazon, so that change made sense. I also made sure the camera-specific ID/PW matches that of the NVR. Unfortunately, while these new settings work fine on VLC, I am still not yet able to get the Show to view the NVR stream.

    Hopefully there is a solution somewhere, as I’m hoping not t have to replace this existing system with new cameras.



  • @gargary I don’t know if this matters or if you already did this, but on the Monocle Portal in the camera settings, I kept the resolution to 192x192. Also did you try turning off your anti virus and firewall to see if the problem is there?



  • @gargary Try making the channel 102 and see if that works. The resolution setting in the Monocle interface doesn’t really do anything. Changing to your lower resolution RTSP profile which I believe is channel 102 might work though.



  • @vmsman Thanks for the reply and suggestion.

    I’ve tried what you suggest and unfortunately using 102 doesn’t seem to work on either the Echo Show nor on VLC.

    I also tried lowering the video resolution on the both the NVR itself and on Monocle portal to 1280 x 720 but still can not get it to work with the Show.

    My current profile looks as follows:

    06da9125-15fa-4934-b50b-2b8389991624-image.png

    8554795c-e56e-4655-8eb8-e9a58e54c191-image.png

    Please let me know if anything else jumps out.

    I’ve also emailed Hikvision about potentially applying a firmware update.



  • @gargary

    A few users have reported similar issues with newer Hikvision cameras. In these cases, modifying the camera’s internal H.264 profile settings and/or H.264+ option seemed to help. Sorry I don’t have more details on what exactly to change, but you might try playing with those settings to see if they make any difference. Some newer cameras are stating to come with H.265 enabled as the default video codec, Alexa devices do not yet support H.265. If you camera offers the ability to disable the audio stream (if equipped) try that too.

    The camera resolution should not matter, the Echo Show can display up to 4K I believe. The Echo Spot and certain FireTV devices are limited to 1080P and lower.

    Thanks, Robert



  • I have a new Hikvision camera and NVR that was installed a couple of weeks ago. I copied the rstp TV setting that you had into my configuration. The only difference between your configuration and mine is the video resolution which I left at 192x192. It worked on my echo show. I am new to all this and don’t have a clue what I’m doing but just provide this in maybe that it will help somehow.



  • @Monkeycam thanks for posting this, and very interesting that your Hikvision set up worked without a problem.

    I have an older Hikvision model – we installed the system about 6 or 7 years ago – so perhaps there is something different in the newer units that enables them to work better with the Echo Show.



  • I’m sure there are differences. When I did searches for help on different aspects of configuring the system, most of the stuff I found didn’t work. It applied only to older systems. Finding help that applies to current systems proved to be challenging and sometimes nonexistent. For what it is worth, I did not modify any parameters on Hikvision equipment.



  • I finally can report success in getting this NVR to work with my Alexa Show.

    I ended up making two changes:

    (a) I updated the firmware (the NVR as well as the camera firmware). Hikvision USA customer support was very helpful in ensuring I had the correct firmware files and that I applied them in the right sequence.

    (b) I changed the settings for the Monocle gateway as shown below. I modified the parameters to use port 64001 instead of 554. The IP address is that of the NVR, and port 64001 is used by the NVR for direct routing to camera #1.

    34435fdb-542b-4ae0-a66f-5a440229cb7f-image.png

    The firmware changes also forced my to strengthen the password for both the NVR and the camera. I made these identical, though it’s not clear whether that made a difference or not.

    I now have to upgrade firmware on the other cameras, but I believe these will use ports 64002, 64003, etc.

    Thanks to everyone for the advice given.



  • I am having similar issues.

    HikVision NVR (actually LUMA branded), newer 510 model.

    Have done ALL of the troubleshooting mentioned above and within the site. What makes this more perplexing is that I had it working on my Echo Spot, and then also on my Echo Show (2nd Gen 10") with a single camera through the NVR. When I started to go and add more camera feeds everything broke and I cannot even get the original one to work again.

    I even deleted my entire Monocle user account and disabled the Alexa skill and started from scratch to no avail.

    The fact that it works without issue in VLC makes this even more confusing.

    Any help or advise appreciated.



  • I had this same issue with my hikvision and none of the solutions here fixed it.

    Curiously I only had this problem with channel 101, all my other cameras worked, and camera 1 worked on channel 102.

    I moved my camera 1 to camera 7 and it works there, so if you have an empty input in your nvr this is something you might try to see if it works for you.



  • @anon2828 said in Unable (so far) to Echo Show connect Hikvision NVR [SOLVED]:

    I am having similar issues.

    HikVision NVR (actually LUMA branded), newer 510 model.

    Have done ALL of the troubleshooting mentioned above and within the site. What makes this more perplexing is that I had it working on my Echo Spot, and then also on my Echo Show (2nd Gen 10") with a single camera through the NVR. When I started to go and add more camera feeds everything broke and I cannot even get the original one to work again.

    I even deleted my entire Monocle user account and disabled the Alexa skill and started from scratch to no avail.

    The fact that it works without issue in VLC makes this even more confusing.

    Any help or advise appreciated.

    Are you running a local copy of the Monocle Gateway? If so, can you provide a log that includes a single request and failure.

    Thanks, Robert



  • @Monocle

    Are you guys still supporting this Alexa skill? You are responding to a post that I made in September of 2019. I cannot get your skill to work at all with an Echo Show 10" version. It had worked previously, but only with one camera. Now cannot get it to work at all. If the solution is that you must now have the Gateway installed for it to work, then it is a non-starter for me and I would be sure many others.

    Please advise as to the current status of the Skill and necessity for the Gateway.

    Would be interested to hear if anyone has this currently (March 2020) working with Hikvision IP cameras and NVR.



  • @anon2828

    Yes we are still supporting this skill. I try my best to respond to request via this forum but I do miss some threads. If the thread get bumped or new activity posted, them there is a greater chance I’ll see it and be able to respond.

    I have a single Hikvision camera working with Monocle and I’m sure there are a number of users who are using Hikvision products with Monocle. However, you say that using the Monocle Gateway is a “non-starter” — well I’m afraid that is only a problem that will continue to get worse. Amazon has changed their devices (especially all newer Alexa devices) to only connect to endpoints using valid/real domain names and valid SSL certificates. The Monocle Gateway handles these requirements for users who which to maintain all camera streaming privately inside their network. You could get away without the need for the gateway if you register a public DNS hostname that points to your NVR and you have the ability to setup a valid/real SSL certificate for that hostname on the NVR. (I know some Hikvision products can support this) . Oh and one more gotcha, Amazon Alexa will only connect on port 443, so the secure (SSL) connection to the NVR must be on port 443.

    Thanks, Robert



  • Great info here…was able to get my Hikvision NVR (DS-7604NI 4P 4T) connected and working through Alexa/Echo-Show. Many setting configuration changes, but can confirm that following is RTSP URL. RTSP://<NVR IP Adress>:<554>/Streaming/Channels/101 (for camera 1) and same with 201 for camera 2. I used Monocle and there is a warning that having special characters in your Admin/Password may cause problems - and it DID. I deleted a # out of the password and it connected right away. Had to downloand and use VLC Media Player to confirm RSTP URL, but once that was verified, it was a simple fix. Thanks for all the help. Also found this site very helpful (Monocle has a note in their FAQ on this topic that led me to this site) - https://www.use-ip.co.uk/forum/threads/hikvision-rtsp-stream-urls.890/ There’s tons of info there, too! Thanks again (yes, that’s the 3rd thank you!!!).


Log in to reply