Hiseeu HSY-FH1C 1080P Cam



  • Da stehen keine Tipps.
    Bei Audio kann man 3 Sachen auswählen.
    Es bringt mir nichts, wenn ich nicht weiß wie eure Software funktioniert.
    Tocken= Es ist nirgends beschrieben wie man es richtig einrichtet.
    Tagging = es ist nirgend beschreiben was man eingeben muss für ein gateway.
    Was ich überhaupt nicht verstehe…
    Please see the Tagging Cameras for Monocle Gateway topic for the interim solution.
    geht nur 1x @… oder mehrer?
    Wenn Audio nicht passt… Und man in euren Einstellungen es deaktiviert… geht das überhaupt?
    Oder ist “ohne Audio” eine Kamera die kein Audio hat?
    Wenn ich euren erstellten “link” anpinge… funzt das nicht. der link ist tot… rtsp://proxy.monoclecam.com:443



  • beim editor… Password… muss man das jedesmal neu eingeben wenn man editieren muss? es steht jedesmal nichts drin



  • @Elzershark

    Our web server has some issues that should be resolved now. That may have been why certain pages like the tips page was not available. Please try again and see if you are now able to access all of the necessary pages/information:

    Tips
    https://monoclecam.com/troubleshoot/tips

    Monocle Token
    https://monoclecam.com/monocle-gateway/api-token

    To configure the token on your system running the Monocle Gateway software, please see the instruction page for your specific operating system. For example. here is the page for Windows:
    https://monoclecam.com/monocle-gateway/install/windows

    Monocle Gateway Tagging:
    https://monoclecam.com/monocle-gateway/tagging

    Each internal tag only requires a single @ character; example: “@tunnel”. You can have multiple tags such as “@tunnel, @noaudio”. However, some tags such as @tunnel and @proxy are mutually exclusive.

    Camera Audio:
    Setting the audio codec field in the Monocle Web Portal for your camera stream is just telling the Alexa device what to expect in terms of an audio channel in the stream. It does not control the stream’s audio channel. If using the Monocle Gateway, the tag @noaudio will filter out the audio stream from the camera.

    Password Issue:
    As for the password issue, it should remember your existing password. It won’t show it to you, you will only see a fixed number of “******” characters in the password field when you edit an existing camera stream. If this is not working for you now, please let me know. This too could have been impacted by our recent server issue.

    RTSP Proxy URL
    The link you are seeing: rtsp://proxy.monoclecam.com:443 is used to help satisfy some of the secure connectivity requirements by Amazon. However, the stream is redirected back to your network locally to the RTSP URL that you provide for each camera.

    Thanks, Robert



  • @Monocle said in Hiseeu HSY-FH1C 1080P Cam:

    Monocle Gateway

    Monocle Gateway…
    the camera has a very different ip … how should a getway work from an ip out of the camera has nothing to do?



  • as I see it, all this does not work, because the camera has a different audio codec. I do not understand why that does not work for your skill. if I create a costum skill, and indicate the link of the camera, that works as it should be. think this will not work with your skill



  • -------------------------------------------------
    RTSP STREAM MODIFIED:  test
      Any existing RTSP steams will be shut down
      and a new stream instance will be registered.
    -------------------------------------------------
    
    2019-06-06T07:40:56.078Z [DEBUG] <RTSP-PROXY> [REQUEST]  --> [DEREGISTER] rtsp://192.168.188.55:554/onvif1/
    2019-06-06T07:40:56.078Z [TRACE] <RTSP-PROXY> [REQUEST]  --> [HEADERS] {
      "cseq": "1",
      "transport": "reuse_connection=0;preferred_delivery_protocol=udp;proxy_url_suffix=STREAM:8c8b80a2-f8f7-4d60-89ba-f3b3bc3d2c49"
    }
    2019-06-06T07:40:56.082Z [DEBUG] <RTSP-PROXY> [RESPONSE] <-- [451 (Invalid parameter)] <cseq=1> (session=undefined)
    2019-06-06T07:40:56.082Z [TRACE] <RTSP-PROXY> [RESPONSE] <-- [HEADERS] {
      "cseq": "1",
      "date": "Thu, Jun 06 2019 07:40:56 GMT"
    }
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM:  test
    -------------------------------------------------
     - NAME  : test
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.188.55:554/onvif1/
     - UUID  : STREAM:8c8b80a2-f8f7-4d60-89ba-f3b3bc3d2c49
     - SESS  : e4551cdd-784f-428f-bd7c-1f9c49924b9f
     - MODIF : Thu Jun 06 2019 09:40:42 GMT+0200 (Mitteleuropäische Sommerzeit)
     - TAGS  : @noaudio,@tunnel
    -------------------------------------------------
    
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM:  test
    -------------------------------------------------
     - NAME  : test
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.188.55:554/onvif1/
     - UUID  : STREAM:8c8b80a2-f8f7-4d60-89ba-f3b3bc3d2c49
     - SESS  : 1774f20a-a62f-4062-a712-df96dacacfaa
     - MODIF : Thu Jun 06 2019 09:40:42 GMT+0200 (Mitteleuropäische Sommerzeit)
     - TAGS  : @noaudio,@tunnel
    -------------------------------------------------
    

    Da wird nirgends das Passwort angezeigt. Wie soll die Kamera angesteuert werden ohne Passwort? auf der Webseite ist das Passwort drin.
    Wo kann ich im Gateway das Passwort eingeben???
    Ein rtsp url ohne passwort funktioniert mit dieser kamera nicht.



  • @Elzershark

    We try not display the password in the console to avoid that as a security vulnerability. However if using BASIC authentication the Base64 version of the password may be displayed as one of the headers.

    In the log file you provided, it looks like the Monocle Gateway is receiving the camera stream request from the Monocle servers, but its not getting any requests from the Alexa device (Echo Show/ FireTV, etc.) locally in your network. We would expect to see more log data immediately following the “INITIALIZE RTSP STREAM” message. What you should see is a TCP inbound connection from the Alexa device followed by an outbound connection to the IP camera.

    Is the Monocle Gateway running on a host that is accessible from the Alexa device? Some users put devices like Alexa on a private/isolated VLAN or on a Guest network that often do not have access to other nodes on the local network.

    It could also be a DNS REBINDING issue. (Especially if using a Fritzbox or PFSense as your Internet gateway/router.). Please see: https://monoclecam.com/monocle-gateway/troubleshooting/dns-rebinding

    Thanks, Robert



  • es gibt kein Router wo man ein dns-rebind-schutz umgehen kann mit “*”. Wird’s auch nie geben.



  • @Elzershark

    We did find a DNS issue on our end this evening … so feel free to try testing it again now.

    Instead of the wildcard domain for DNS rebinding; you technically only need to allow the single DNS hostname that is displayed (FQDN) when you first start the Monocle Gateway service:

    Example:

    -------------------------------------------------
    MONOCLE RTSP SERVICE - INITIALIZED
    -------------------------------------------------
    FQDN = ef231161-9698-486f-8686-19d565749c09.mproxy.io
    HOST = 10.1.1.21
    PORT = 443
    -------------------------------------------------
    

    Or course, if you move your Monocle Gateway or generate a new monocle.token, you may also have to update your DNS rebinding options in the future.

    PS: If you can’t allow or don’t want to allow DNS rebinding, you could alternatively override the host entry in your router’s DNS server for this DNS host to always point to the internal IP address of your Monocle Gateway server.

    Thanks. Robert.



  • i think, this is wrong…

    "authorization": "Digest username=\"admin\", realm=\"HIipCamera\", nonce=\"f6258fa656a146ac03c926f7c1b2be8c\", uri=\"rtsp://192.168.188.55:554/onvif1/\", response=\"07021fa854ae6958640d7db4446cd9c4\""
    
    uri=\"rtsp://192.168.188.55:554/onvif1/\ <-- this... \
    


  • und, wie gesagt… mproxy.io ist nicht anpingbar. weder lokal noch aus dem internet…
    Weder über dsl, G3, G4, G5, kabel, Satellit internet…



  • Here… you can test my cam…

    rtsp://admin:Administrator@gwipc-17780721.​r1cwmfe0usjdikdc.​myfritz.​net:554/onvif1

    this stream is live

    when you put it in Camera Feed/Stream URL (RTSP):… then is a error…

    open the setting again and remove the wrong characters

    rtsp://gwipc-17780721.​r1cwmfe0usjdikdc.​myfritz.​net:554/onvif1



  • @Elzershark

    I am not able to resolve that DNS host.

    > ping gwipc-17780721.​r1cwmfe0usjdikdc.​myfritz.​net
    ping: cannot resolve gwipc-17780721.​r1cwmfe0usjdikdc.​myfritz.​net: Unknown host
    
    > nslookup gwipc-17780721.​r1cwmfe0usjdikdc.​myfritz.​net
    Server:		1.1.1.1
    Address:	1.1.1.1#53
    
    ** server can't find gwipc-17780721.\226\128\139r1cwmfe0usjdikdc.\226\128\139myfritz.\226\128\139net: NXDOMAIN
    
    


  • @Elzershark said in Hiseeu HSY-FH1C 1080P Cam:

    rtsp://admin:Administrator@gwipc-17780721.​r1cwmfe0usjdikdc.​myfritz.​net:554/onvif1

    enter this in vlc player and you see the camera…
    rtsp://admin:Administrator@gwipc-17780721.​r1cwmfe0usjdikdc.​myfritz.​net:554/onvif1



  • you can not ping such links. that works only in its own network … see proxy.monoclecam.com
    Or
    mproxy.io

    Such addresses can never be pinged.
    unless they are in their own network



  • @Elzershark

    I understand that PING may not work, but NSLOOKUP is not working either to resolve the DNS host.

    I did also try it in VLC and FFMEPG:

    > ffmpeg -rtsp_transport tcp -i "rtsp://admin:Administrator@gwipc-17780721.​r1cwmfe0usjdikdc.​myfritz.​net:554/onvif1"
    
    ffmpeg version 4.1.2 Copyright (c) 2000-2019 the FFmpeg developers
      built with Apple LLVM version 10.0.0 (clang-1000.11.45.5)
      configuration: --prefix=/usr/local/Cellar/ffmpeg/4.1.2 --enable-shared --enable-pthreads --enable-version3 --enable-hardcoded-tables --enable-avresample --cc=clang --host-cflags='-I/Library/Java/JavaVirtualMachines/openjdk-11.0.2.jdk/Contents/Home/include -I/Library/Java/JavaVirtualMachines/openjdk-11.0.2.jdk/Contents/Home/include/darwin' --host-ldflags= --enable-ffplay --enable-gnutls --enable-gpl --enable-libaom --enable-libbluray --enable-libmp3lame --enable-libopus --enable-librubberband --enable-libsnappy --enable-libtesseract --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libx265 --enable-libxvid --enable-lzma --enable-libfontconfig --enable-libfreetype --enable-frei0r --enable-libass --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-librtmp --enable-libspeex --enable-videotoolbox --disable-libjack --disable-indev=jack --enable-libaom --enable-libsoxr
      libavutil      56. 22.100 / 56. 22.100
      libavcodec     58. 35.100 / 58. 35.100
      libavformat    58. 20.100 / 58. 20.100
      libavdevice    58.  5.100 / 58.  5.100
      libavfilter     7. 40.101 /  7. 40.101
      libavresample   4.  0.  0 /  4.  0.  0
      libswscale      5.  3.100 /  5.  3.100
      libswresample   3.  3.100 /  3.  3.100
      libpostproc    55.  3.100 / 55.  3.100
    [tcp @ 0x7f8074e008c0] Failed to resolve hostname gwipc-17780721.​r1cwmfe0usjdikdc.​myfritz.​net: nodename nor servname provided, or not known
    rtsp://admin:Administrator@gwipc-17780721.​r1cwmfe0usjdikdc.​myfritz.​net:554/onvif1: Input/output error
    

Log in to reply