Unknowed brand IPcam



  • @Tueftler

    If you restart the monocle gateway, does it still have the port 443 error?

    I can also use this command to verify the attribute exits on the file:

    > sudo getcap /usr/local/bin/monocle-gateway
    
    /usr/local/bin/monocle-gateway = cap_net_bind_service+ep
    


  • @Monocle

    Another thing you can try is editing this file:
    /etc/systemd/system/monocle-gateway.service

    Add the line AmbientCapabilities=CAP_NET_BIND_SERVICE under the [Service] section so that the file looks like this:

    # *********************************************************************
    #              __  __  ___  _  _  ___   ___ _    ___
    #             |  \/  |/ _ \| \| |/ _ \ / __| |  | __|
    #             | |\/| | (_) | .` | (_) | (__| |__| _|
    #             |_|  |_|\___/|_|\_|\___/ \___|____|___|
    #
    #  -------------------------------------------------------------------
    #               MONOCLE GATEWAY SYSTEMD INIT SCRIPT
    #       COPYRIGHT SHADEBLUE, LLC @ 2018, ALL RIGHTS RESERVED
    #  -------------------------------------------------------------------
    #
    # *********************************************************************
    
    [Unit]
    Description=Monocle Gateway Service
    After=network.target
    ConditionPathExists=/usr/local/bin/monocle-gateway
    ConditionPathExists=/usr/local/bin/monocle-proxy
    ConditionFileIsExecutable=/usr/local/bin/monocle-gateway
    ConditionFileIsExecutable=/usr/local/bin/monocle-proxy
    ConditionPathExists=/etc/monocle/monocle.token
    ConditionFileNotEmpty=/etc/monocle/monocle.token
    
    [Service]
    AmbientCapabilities=CAP_NET_BIND_SERVICE
    ExecStart=/usr/local/bin/monocle-gateway
    WorkingDirectory=/home/monocle/
    StandardOutput=inherit
    StandardError=inherit
    Restart=always
    RestartSec=120
    StartLimitInterval=5
    StartLimitBurst=10
    User=monocle
    
    [Install]
    WantedBy=multi-user.target
    

    Next, run this command to RELAOD the service config:

    sudo systemctl daemon-reload

    Now restart the monocle gateway and check to log to see if that helped.

    Thanks, Robert



  • Hi newbie here, I’ve just started using monocle on a Victure IP camera from Amazon. I had very similar problems to you (although I’ve not read all your threads). My problem was solved when I switched to a new Pi install. I think the problem was Apache running on my main Pi which I use for Domoticz. It was using port 443. I have the stream running on a show 5, Fire & Fire HD. Now all I have to solve is the buffering!



  • Now after this command

    > sudo getcap /usr/local/bin/monocle-gateway
    

    It looks like good. I have made a restart from Raspberry Pi and Alexa can show me the Cam.
    And there is no brake I test it some times and give them again feedback.



  • @Tueftler

    Success?



  • Yes it works now, the stream runns with audio. And it did not stop from self. Is there also a way to use IP cams without RTSP viedeo streams? I have one more IP Cam but they did not have a RTSP it is a URL in this format http://ipaddress/videostream.cgi



  • @Tueftler

    I have one more IP Cam but they did not have a RTSP it is a URL in this format http://ipaddress/videostream.cgi

    At this time no. At least not with Monocle and Alexa. Alexa only supports RTSP (and WebRTC) streams. You would have to setup some external media server that can accept the camera stream and convert it into a H.264 RTSP stream.



  • So
    I will say thank you for your support and the time you have spend.
    I have ordered one more cam like this for 23€ with shipping is it very good.

    Thanks a lot



  • @Tueftler

    You are welcome. Enjoy!



  • Here have the same camera board as the first post and using an Alexa Show 5. (new).

    I am hoping to update my very old Optex security cameras with these camera boards.

    I can see two channels using VLC and the command:

    1 - rtsp://192.168.244.151/user=admin_password=xxx_channel=0_stream=1.sdp
    Which provides me with a 352X240 video resolution.

    2 - rtsp://192.168.244.151/user=admin_password=xxx_channel=0_stream=0.sdp
    which provides me with a 1920X1080 resolution.

    I am using a PFSense firewall here. I have disabled sound on the camera.

    I also have a Ring Doorbell which works fine with the Amazon Alexa Show. Looked to change over to the HikVision OEM doorbell in the next few weeks.

    camerafeeds.jpg

    Also installed the Monocle Gateway here, made above modifications and have tried all of the tags.

    See this:
    monocle-g 27697 monocle 12u IPv4 109131 0t0 TCP *:8555 (LISTEN)
    monocle-g 27697 monocle 14u IPv4 109132 0t0 TCP *:443 (LISTEN)
    monocle-p 27725 monocle 3u IPv4 109748 0t0 TCP *:8554 (LISTEN)

    OK so adjusted my PFSense DNS Resolver adding custom options.

    server:
    private-domain: “xxx.mproxy.io

    Tested it by pinging xxx.mproxy.io and get a response.

    Now when I ask Alexa to show test cam it appears to try for about a minute then quits. Beforehand it would quit right away…so I am getting close.

    Got it working fine now changing @tunnel to @proxy.

    Great stuff.



  • @petec

    Glad you found a way to get it working for your cameras!



  • @Monocle
    Great application.

    Today purchased my Echo Show #2.
    This is actually an IP HD camera board. Way long time ago had gone to using Grandstream cameras and boards for modded cameras. These boards came with an SDK for development. Looking to retrofit my Optex combo camera/PIRs with these camera boards.



  • @petec

    Sounds like an interesting project … I’ve modded lots of hardware in the past, but never an IP cam 🙂


Log in to reply