Errors When trying to install Monocle-Gateway.exe



  • Monocle-Gateway.exe runs and looks like it installs ok but then when Monocle-Proxy.exe starts to install it starts giving all sorts of errors.
    Capture.JPG
    Any Ideas??



  • @pedenfield

    It’s saying that something else (some other running process) is already using port 443.

    On Windows, if you followed the installation instructions, the Monocle Gateway should be running as a system service (NT service). So if the service is running in the background and you also launch the EXE, this would mean that there are two copied actively running and only only can listen on port 443. If you are not running Monocle Gateway as a background service and only running the EXE, then some other application on the system must be using port 443.

    Thanks, Robert



  • When i go to Task Mgr and look at services I don’t see Monocle as a service?



  • @pedenfield said in Errors When trying to install Monocle-Gateway.exe:

    When i go to Task Mgr and look at services I don’t see Monocle as a service?

    Something other than Monocle is listening on port 443 from this device. Likely culprit is a web service of some kind waiting for incoming https requests. You’re running an EXE. Is this a Windows Server? If so, you will have to stop the IIS Web service. If it is not that, start looking for the culprit. It’s there somewhere



  • @pedenfield

    There is a Windows GUI tool that may help:

    See: https://stackoverflow.com/a/23718720/7254956

    65f4c428-2031-422d-a8d7-9104ac68798f-image.png

    Look under the “Listening Ports” and sort by Port number. Look for anything using 443.

    Thanks, Robert



  • @spicymikey It is not a Win server. It is desktop running win 10 Pro. I will try to find what ever is on 443. You keep saying I am running .exe, is there another way to do it? Also, I am trying to get this to work on Fire HD 8 inch 8th gen with latest O S. Thanks for help.



  • @pedenfield

    Yes, if installed as a service, it can run in the background as a NT System Service. Basically it’s just running the same EXE in the background under a service account and started automatically when the machine reboots.

    It easier to test with when just running the standalone EXE, but once its all working for your system, you would probably prefer it run as a service.

    Thanks, Robert



  • @pedenfield said in Errors When trying to install Monocle-Gateway.exe:

    @spicymikey It is not a Win server. It is desktop running win 10 Pro. I will try to find what ever is on 443. You keep saying I am running .exe, is there another way to do it? Also, I am trying to get this to work on Fire HD 8 inch 8th gen with latest O S. Thanks for help.

    Yes Monocle makes several executables for various platforms. I was just referring to the fact that it seemed you were doing this on Windows when you mentioned “Task Manager” and “exe” files.

    Did you find what was using 443? If not, if you have another pc to use, try that. But it should not be hard to find what has a hold on 443. Take a screenshot of all the programs in your “Program List” and share it here. I bet we can spot the likely culprit.



  • Yes It showed to be Chrome. Stopped service and install worked with no errors. I don’t know if I should have but I added the TAG @tunnel to the setup of the cameras. Monocle then showed a popup where it added the cameras. I removed the devices from Alexa and added back after the change. The kicker is that Alexa Echo Spot and Fire HD 8 inch 8th gen in show mode, neither will show the cameras.



  • @pedenfield

    Yes It showed to be Chrome. Stopped service and install worked with no errors.

    Chrome! ?? What? Chrome should not be listening on port 443? Maybe you have some extension installed that is doing this?
    Glad that solved it though.

    I don’t know if I should have but I added the TAG @tunnel to the setup of the cameras. Monocle then showed a popup where it added the cameras.

    Yes, @tunnel by default, but it may depend on your specific cameras. Which cameras are you trying to get working? (make/model) Some cameras may require @proxy or @proxy-tcp instead of @tunnel.

    I removed the devices from Alexa and added back after the change.

    That’s fine, but for future reference, you don’t have to do this step in the future for tag changes.

    The kicker is that Alexa Echo Spot and Fire HD 8 inch 8th gen in show mode, neither will show the cameras.

    Were they working at any point in the past? I know the spot is limited to showing streams of 1080P and lower resolutions, so if you camera is configured to stream a higher resolution, the Spot won’t display it. You would have to change the settings on the camera itself (not in Monocle).

    You might need to post the contents of the Monocle Gateway log to better see what’s going on.

    Thanks, Robert



  • Yes it worked several months ago on the Spot. I just bought the tablet. I am trying Hikvision Microseven and some noname ip cameras. This time I do not see Monocle running as a service?

    7471d22e-7bdb-46c1-9854-e59f1b112d26-image.png



  • I have checked the URL’s that I am using and I am able to pull up a stream using VLC on all of them.



  • @pedenfield

    OK, the startup looks good in the log.
    Capture the log while asking “Alexa, show me the XXX camera” and let’s see what happens.

    Thanks, Robert



  • 7f55b3eb-b50f-4c10-b8fb-b3c1e0633f03-image.png



  • @pedenfield

    OK, so immediately after the “INITIALIZE RTSP” section, you should see incoming TCP requests from the Alexa devices. In this log they are missing, which means the Alexa devices are not able to connect/communicate with the Monocle Gateway.

    1.) Are the Alexa devices on the same network as the Monocle Gateway. (not on a separate VLAN or on a Guest Wifi, etc)
    2.) Check (or disable) the Windows Firewall to make sure it’s allowing port 443 to be used by Monocle Gateway.
    3.) What type of router are you using? Some routers will block DNS resolution of public DNS hostnames that resolve to internal/private IP addresses. (See DNS REBINDING)
    4.) Is the auto-detected IP address of 192.168.0.110 correct for the Monocle Gateway. The Alexa device will use this to connect.

    Thanks, Robert



    1. Same network.
      2, Disabled my Trend Micro firewall
    2. Router is a TP-Link Wireless Router Touch-P5
    3. Yes. That is the Pc Monocle is installed on.


  • @pedenfield

    Are you using PiHole or any other DNS server on your network?

    Thanks, Robert



  • No. I am using NoIP because I can’t get static IP.



  • @pedenfield

    In the startup of the log file look for the “FQDN” entry. This is the unique hostname that is assigned to your gateway instance and registered as a publicly resolvable DNS entry.
    Open a command prompt on your Windows machine and enter the following command:

    nslookup xxx.mproxy.io
    

    (where xxx.mproxy.io is your FQDN.)

    It should return a result with your gateway’s local IP address. 192.168.0.110

    If you don’t get this IP address, then something is blocking the DNS resolution of that domain name. Most likely your router or DNS server is blocking resolutions to local IP addresses (DNS REBIND).

    Make sure to try this nslookup test on the gateway machine as well as another computer on the same network if possible. Basically we are trying to make sure that the Alexa devices on the network would also be able to resolve this hostname by simulating the DNS resolution from another device attached to the network.

    Let’s start with this test and see what happens.

    Thanks, Robert



  • I think I have the FQDN number right.

    321a18ee-f0ba-45da-9327-5a22cdda849a-image.png

    e69ecc05-f57d-43f9-a0bd-39396fde2842-image.png


Log in to reply