Banner is Persistent / Does Not Fade



  • I have a new issue with a Fire TV Stick 4K where the banner overlay never clears. That is, when I say “Alexa show the <camera name>”, Fire connects to that camera and then dims the screen with a dark overlay that has the camera’s Monocle/Alexa name shown in upper left.

    This is a fairly recent problem. When I initially set everything up, the banner would display for a few seconds and then fade away. As things currently stand, the banner leaves a dark shadow over most of the top and bottom of the screen that would make you think the TV’s backlight is failing, and it never goes away. There is no such overlay when displaying content from any other Fire TV app.

    I’m not sure where the banner comes from in the first place: Fire, Monocle, or something else. I have an Echo Spot connected to this same system and it does not display a banner at all. I also have an Echo Show 2nd Gen on another system, and it displays the banner only momentarily like my Fire TV originally did. So 3 different Alexa devices, 3 different behaviors.

    Here’s more info on the Fire setup:

    • IP Camera/NVR Make and Model:
      Ubiquiti Unifi Cloud Key Gen2+ with NVR running UniFi Protect v1.13.0~beta.16
      Various UniFi camera models connected, but all RTSP streams are via the NVR.

    • Alexa Device:
      Fire TV Stick 4K running FireOS v6.2.6.8 and FireTV Home v6200198.1
      It’s linked to an Echo Plus for hands-free voice control.

    • Steps already attempted and results/outcome:
      1.) Searched for a setting somewhere controlling the banner feature, to no avail.
      2.) Removed the Monocle skill and cameras from Alexa and reset everything up, but no change.
      3.) Updated Monocle Gateway (x64) from v0.0.3-beta to v.0.0.4-beta, no change.



  • I think it is a Alexa problem as originally I had no banner, then banner started to appear and disappear. It then was leaving the banner like your issue for a while and then all of a sudden I got banner then it fades out. All on the same device. I have the original Alexa Show Gen1. I have been running Monocle since it first came out no gateway.



  • @pridsdale Thanks for that info. It helps validate that there is a problem, and not just on my setup.

    I called Amazon Support for Echo Devices today and spent over 2 hours on the phone with them, but to no avail. They had me disable/re-enable skills, unpair/repair devices, factory reset everything and set it all back up, etc. I actually can’t believe I invested that much time and trouble, but they kept trying so I stayed on the line.

    Through it all, they never could tell me for sure where the banner comes from: if it is generated by Alexa or is external. We did notice that if you rename the camera in the Alexa app the Echo/Fire will respond to voice commands for the new name but the banner continues to show the name as defined in Monocle. Amazon Support suggested that this means it is Monocle that is generating the banner.

    The problem remains.



  • @GreggC I understand Greg. I commend you for trying but i don’t think all that work was going to solve it because it as it happened to me it was gone without any intervention from me. You could ask Monocle more about it and ask if you can turn off the banner somehow.



  • Thanks again.

    @Monocle any ideas?



  • @GreggC ,

    I too have seen this banner in the past on some Alexa devices (I think it was in fact a FireTV) and like @pridsdale it seemed to go away eventually without any modifications on the Monocle side.

    Just to be clear, this banner is entirely part of the Alexa/FireTV operating system/system software. Monocle is not an APP and thus nothing from Monocle gets installed on your Alexa enabled devices. Monocle only coordinates behind the scenes with the Alexa web APIs to implement the existing smart home camera features supported directly by the Alexa devices (Echo Show/FireTV). Enabling the Monocle skill is not installing anything either – it just connects the backend cloud/web services from Alexa and Monocle together and provides an account linking and grants access authentication.

    I’ll re-check my FireTVs and see if I’m getting any lingering banners today. You might also hard-power-reset (unplug, wait 30 seconds, plug back in) your FireTV just in case.

    Thanks, Robert



  • @Monocle Thanks for the explanation, Robert. I just cycled power on the FireTV Stick again, but the banner’s still there. Hopefully Amazon will realize the problem and eventually correct it. In the end, users should be able to set a preference as to whether or not they want the banner at all.



  • I am also getting this same thing and it has annoyed me enough to go looking for a solution as well. I hope they get this corrected!



  • @dkbishop It pretty much ruins the experience, doesn’t it? I hope you have better luck than me finding a solution.

    Now that we understand from Robert that the banner is being generated on the Alexa side of things, it seems the key in getting a solution will be getting traction within the Amazon support/development organization. I don’t think I got that traction in my call with them the other day, as they volleyed the issue back towards Monocle.

    Anyone got any ideas on how to get an incident opened directly with the Alexa development team?



  • The following is somewhat subjective and partially a theory, but I think this banner is lingering because something in the Alexa RTSP player is struggling with the stream decoding. When I leave the stream running for a long time the banner does fade VERY gradually. So things you could try (again, maybe a shot in the dark) would be to change various settings on the camera such as resolution, bit-rate, frame-rate, audio codec, etc. Just to see if you can find a combination that Alexa seems to like better.

    You could also try adding the “@noaudio” tag to your camera’s config in Monocle web portal if you are using Monocle Gateway. This would remove the audio stream — Alexa often has trouble with various audio streams from a wide range of cameras.

    Thanks, Robert



  • @Monocle Thanks for the additional ideas, I checked them out:

    • My wife sometimes likes the stream running a full day at a time, to the point where it even lags a whole minute or more (is that a clue?), but the banner never fades a bit.
    • No luck with @noaudio or @fixaudio. Of course we want the audio, and it does work by default.
    • No luck experimenting with various RTSP resolutions 1920x1080, 1280x720, 1024x526, 640x360 (all 16:9).
    • I did not adjust any bit and frame rates, but if anyone has a recommendation I’ll be happy to try it.


  • @GreggC

    Thanks for at least trying some of these. It was a shot in the dark.

    The eventual lagging you describe, I have seen with select older Amcrest cameras when using the G.711 audio codec. I believe I was able to resolve this by either switching to AAC audio or lowering the audio bit rate (on the camera itself). So you might try that and see if it makes any difference on the lagging issue.

    Thanks, Robert



  • @Monocle With the Ubiquiti cameras, I don’t have any control over the codecs used for audio or video. However, I do have some control over video frame and bit rates. In particular, frame rates are interesting in respect to the Fire TV Stick 4K’s “Match Original Frame Rate” feature. Alas, I’ve tested a few combinations with no improvement.

    My cameras were at default 15 fps and 3000 Kbps. I haven’t messed with bitrate, but I did try a few different frame rates, both with the “match” feature on and off. Here’s what hasn’t worked in respect to eliminating the never-fading banner: 15, 18, 20, 24.


Log in to reply