Banner is Persistent / Does Not Fade



  • The following is somewhat subjective and partially a theory, but I think this banner is lingering because something in the Alexa RTSP player is struggling with the stream decoding. When I leave the stream running for a long time the banner does fade VERY gradually. So things you could try (again, maybe a shot in the dark) would be to change various settings on the camera such as resolution, bit-rate, frame-rate, audio codec, etc. Just to see if you can find a combination that Alexa seems to like better.

    You could also try adding the “@noaudio” tag to your camera’s config in Monocle web portal if you are using Monocle Gateway. This would remove the audio stream — Alexa often has trouble with various audio streams from a wide range of cameras.

    Thanks, Robert



  • @Monocle Thanks for the additional ideas, I checked them out:

    • My wife sometimes likes the stream running a full day at a time, to the point where it even lags a whole minute or more (is that a clue?), but the banner never fades a bit.
    • No luck with @noaudio or @fixaudio. Of course we want the audio, and it does work by default.
    • No luck experimenting with various RTSP resolutions 1920x1080, 1280x720, 1024x526, 640x360 (all 16:9).
    • I did not adjust any bit and frame rates, but if anyone has a recommendation I’ll be happy to try it.


  • @GreggC

    Thanks for at least trying some of these. It was a shot in the dark.

    The eventual lagging you describe, I have seen with select older Amcrest cameras when using the G.711 audio codec. I believe I was able to resolve this by either switching to AAC audio or lowering the audio bit rate (on the camera itself). So you might try that and see if it makes any difference on the lagging issue.

    Thanks, Robert



  • @Monocle With the Ubiquiti cameras, I don’t have any control over the codecs used for audio or video. However, I do have some control over video frame and bit rates. In particular, frame rates are interesting in respect to the Fire TV Stick 4K’s “Match Original Frame Rate” feature. Alas, I’ve tested a few combinations with no improvement.

    My cameras were at default 15 fps and 3000 Kbps. I haven’t messed with bitrate, but I did try a few different frame rates, both with the “match” feature on and off. Here’s what hasn’t worked in respect to eliminating the never-fading banner: 15, 18, 20, 24.



  • @GreggC

    I’m not exactly sure what’s going on with this banner. I have seen banners that fade slowly over time in the past but none of my devices are currently exhibiting that behavior. If it’s not too much trouble – maybe a factory reset of the Alexa device would help? At this point we are just reaching … its entirely an Alexa software/firmware issue.

    Thanks, Robert



  • @Monocle Hi Robert. I actually already tried the factory reset and it didn’t help.



  • is there anything we can do to get rid of this annoying banner yet?



  • @dkbishop

    Unfortunately not on our side. This is an Amazon bug of some sort.

    Thanks, Robert



  • I wonder if they even know about this



  • @dkbishop said in Banner is Persistent / Does Not Fade:

    I wonder if they even know about this

    @dkbishop See above, I spent hours on phone w/ Amazon support. However, I’m not really sure it registered with them. We need someone with a more direct line to Amazon development that can speak their language.


Log in to reply