Blue Iris RTSP



  • @RonnBlack
    Did you tell Alexa to discover devices, then check it recognises the BI streams as devices?

    It takes about 10s for streaming to commence on my Echo devices, the sequence being: I say “Alexa, show [device]”; Alexa immediately replies “OK”; the screen then displays “Waiting for [device]” for about 10s; then streaming occurs.



  • Are you going through the monocle gateway or directly to Blue Iris?



  • @RonnBlack
    Monocle gateway with DIGEST and @proxy-tcp as the tag.



  • @RonnBlack I wish it would work but I have been unsuccessful as well. It sure would solve some problems if it would.
    The url works fine in VLC player but Monocle appears to be rejecting it. Perhaps the Monocle author can take a look at this.



  • @MRE I spent quite a lot of time trying to get this to work and I’m getting same results as you.

    I think there may be a problem with the Monocle gateway connectivity (I’m using docker version on Synology NAS) but I haven’t had a time to dig into it.

    Does anyone know if there is way to test the output stream from the Monocle gateway to see if it is working correctly?



  • I just got it to work. In BI camera settings for the camera, under the record tab, select Video file format and compression. Set this for direct-to-disk (H264…).

    Apparently Monocle can’t handle the compression that BI is outputting when it re-encodes… I will study this some more but I wanted to post it as it appears to be the key to the problem.



  • @MRE WOOHOO!!! Thankyou… That was the solution!!!



  • For anyone wanting to experiment with the Blue Iris RTSP feed to Monocle. Blue Iris needs to be set to Direct-to-Disk under the Recording tab/Video file format and compression button. This is found under camera settings for the individual camera you want to stream.

    Below is a screenshot of Monocle settings. Note that for me the Proxy-tcp tag is the only thing that works.

    BI_Setup.jpg



  • I just installed Monocle and have it working with my Blue Iris server. So far it is working well on my Echo Show 5. I also have a Facebook Portal that I have not got it working on even this the Portal show my Ring Doorbell camera.



  • @a0174741 I’m having the same problem with a Unifi Video server. Ring doorbell works on both the Show 5 and the two Facebook Portals I just got (10" and TV). UVC thru Monocle (using @tunnel) works fine on the Show 5, but the Portals just show “Waiting for camera…” for a bit, then say “Camera doesn’t support that”.

    I’ve tried with Tunnel, Proxy and Proxy-TCP, and with NoAudio in case it’s the audio codec it’s not liking. No luck. I’m a bit stumped.



  • I’m trying to get this set up, got a couple of questions.

    1. Am I using my dynamic IP and port from my ISP for Monocle, and what happens if that changes. Can I use my noip.com address somehow? I’m no good with HTML
    2. My BI5 camera setting have no URL in the Main stream or sub stream. Some just have a /, others have /live/main or something. How is everyone getting that address?
    3. I did get this set up in TinyCam Pro much easier. I just chose “Blue Iris” as the type of camera, and changed the port for setting up each camera. Is this not an option in Monocle, and could it be?

    Thanks for any help anyone can give!



  • Can’t find how to edit my previous post. I meant I change the “channel” for adding each camera in TinyCam Pro. I was thinking about running an old phone with TC Pro web server running. Maybe it provides an easier way to set this up with Monocle. But then I’ve got a feed going out the camera, through BI, through TCPro, then to Alexa, then to my TV. Seems like a lot of hops…



  • @hockeyfreak Monocle needs the IP address of the camera (inside your network). I would recommend static IP addresses.

    If you are trying to tap into the Blue Iris feed of the same camera then it needs the internal IP address of your Blue Iris server and the name of the Camera from Blue Iris.

    Check the first message in this thread for the URL syntax.
    Username and Password would the login for Blue Iris.

    Also note the post from @MRE about the Blue Iris Video file format and compression.
    Good Luck



  • @RonnBlack said in Blue Iris RTSP:

    @hockeyfreak Monocle needs the IP address of the camera (inside your network). I would recommend static IP addresses.

    I have all my cameras assigned static IP addresses

    If you are trying to tap into the Blue Iris feed of the same camera then it needs the internal IP address of your Blue Iris server and the name of the Camera from Blue Iris.

    Should I forget BI and just set up each camera IP? I have pfSense running preventing all internet access to the cameras. They communicate with BI only.

    Check the first message in this thread for the URL syntax.
    Username and Password would the login for Blue Iris.

    I’ve tried many variations of URLs for this on Firestick and VLC, none of them work yet. I’ll keep plugging away. I tried ActionTiles a while back and kind of got the Mjpeg stream working, I’ll look up those URLs and see if it would be similar. Would the BI Webserver Advanced section on Authentication have any bearing on the failure? I have mine set on Non-LAN, top three boxes are checked. That was an issue with ActionTiles.
    I am confused about how Monocle, an external service outside my firewall, can resolve an internal IP address on people’s networks without a client running inside that network. I guess that shows my lack of knowledge on networking though.

    Also note the post from @MRE about the Blue Iris Video file format and compression.

    I have BI set at H264 and no compression everywhere already.

    Good Luck

    Thank you so much for your response. I’ve looked at the threads on IPcamtalk also.



  • @RonnBlack I’ve tried everything in this thread. At one point I got logs in the camera feed history, and everything looked right, my ISP IP was in there, and all the other stuff. But Alexa still reported the camera not responding. Now it’s not accessing at all. I’m stumped. Maybe something in pfSense?



  • Hi hockeyfreak,
    Best build your understanding step-by-step, and step 1 is to confirm BI is stream RTSP to VLC on your LAN. So check as follows:
    Confirm you see your individual cameras in BI.
    Then, ensure you are using BI 5.3.1.3 or later, as only then will BI be automatically generating RTSP streams for the cameras.
    Then check you can see the each and all BI RTSP streams with VLC on your LAN using the URL: rtsp:/[BI user]:[BI username]@[BI IP]:[BI HTTP Port]/[BI camera or group name]&w=1280&h=720.
    Does that work?



  • @majones said in Blue Iris RTSP:

    Hi hockeyfreak,
    Best build your understanding step-by-step, and step 1 is to confirm BI is stream RTSP to VLC on your LAN. So check as follows:
    Confirm you see your individual cameras in BI.

    BI cameras.jpg

    Then, ensure you are using BI 5.3.1.3 or later, as only then will BI be automatically generating RTSP streams for the cameras.

    BI version.jpg

    Then check you can see the each and all BI RTSP streams with VLC on your LAN using the URL: rtsp:/[BI user]:[BI username]@[BI IP]:[BI HTTP Port]/[BI camera or group name]&w=1280&h=720.

    No, the pics below show the settings for one particular camera. I tried it as both rtsp:/ (as you’re showing above) and rtsp:// (which I think is correct), I tried it as HTTP://, I tried it as the BI IP and port as above, and I tried it as the raw camera feed as shown in pic with the actual camera login (as both HTTP and rtsp). I included the pic below of VLC because that’s the only one that kept the play button on the player as playing (showing the pause symbol) instead of playing for only a second and then showing the play triangle, meaning I think something is playing there and just not showing up.

    east cam settings.jpg
    Played only a second, then stopped

    VLC Fail.jpg
    Kept playing but nothing showed up? I expanded the VLC window, it didn’t auto-expand.

    Raw camera feed as HTTP.jpg

    Does that work?

    Nope. Still plugging. Again, I really appreciate your time with advice.



  • @majones And when I say “played only a second then stopped” I mean VLC just showed the pause symbol briefly, then showed the play symbol. There was no camera feed or anything. Nothing showed up. That’s my desktop picture in the pic.



  • Yes, it should be rtsp://…… Sorry for the typo.
    The screenshots are really helpful. I’m wondering whether the cameras being on 192.168.20.x and BI on 192.168.50.x is a problem. Assuming not, let’s try to get VLC working.
    Try streaming your camera directly to VLC, without BI playing a part, using rtsp://Roger:[camera-password]@192.168.20.104:554/live/main. It works for me in VLC when I use Media > Open Network Stream > [rtsp URL], and I’m not sure whether MLR is causing a problem.
    If that works, try streaming the camera to VLC from BI, using rtsp://admin:[BI-user-password]@192.168.50.200:81/ESideCam&w=1280&h=720. Again, it works for me in VLC when I use Media > Open Network Stream > [rtsp URL].



  • @majones I tried both ways. The actual password of the camera is admin, I caught that after the screenshot and tried it that way and no go. I also logged into my Camera network wifi on my laptop and tried running all those from from BI and the raw camera feed. I can access the camera web interface from my Unfiltered network (the adult network that has no content and malware restrictions) and my Camera network, so I should be able to run the feed I would think. I’ve disabled Norton on the plex/BI server for all these tests so that’s not the issue. Below is the screenshot of my Camera.net rules, and I don’t think any of them are interfering. I’ve disabled all one at a time and no luck. I enabled the all access rule and nothing either. The only thing left is PiHole running as the DNS server. I don’t think that it but I’m far from an expert. I’m about to go nuts.

    pfsense camera rules.jpg


Log in to reply