LG TV with built in Alexa - Hikvision cameras



  • @Robsterno1
    Hey, ahh you can’t up the substream to 16:9 720p?
    Maybe you do need the gateway. Trove through the support area and you may find some info about your TV and if it requires the gateway… does the NAS support docker?



  • @FineSir

    I can view all of my cameras on my my Alexa shows using the excellent Monocle skill which works perfectly.

    I have just purchased a Samsung Smart TV and can use Alexa to turn it on and off. I can also say things like “Alexa, Kitchen TV volume 50” and the volume increases accordingly.

    I would be super interested to find out how I could show my Hikvision cameras on my Samsung TV.

    For additional information, I did not have to install the Alexa app onto the TV because the new Samsung Galaxy TVs are Alexa ready. I just installed the Samsung SmartThings app onto my Smartphone and then added the Samsung SmartThings skill to to Alexa.

    So has anyone managed to view their NRV IP cameras on their Smart TV?



  • @Esso

    I should have said “the new Samsung Smart TVs are Alexa ready”.



  • @Esso it sounds like the TV Alexa integration is just command based from what you say there. Can you directly talk to the TV stand-alone of the Echo/Show device? The OP here has a TV with fully fledged Alexa by the sounds of it and the TV hosts the skills and handles the voice commands. OP is able to view their doorbell through the TV and had no mention of a Show device.



  • @FineSir

    I understand what you mean. You are saying his television is just one giant Alexa. I didn’t know you could get TVs with microphones built in so they can double up as a completely standalone Alexa devices.

    I have found the best way to show my 4 IP cameras on my Smart TV is to screen cast from my mobile phone. It looks fantastic on my 43-inch 4K telly. I just leave my phone on the bench plugged in so I can easily see what’s happening around the house and the gardens.

    The monocle skill on the Alexa’s is still useful so I can quickly check a camera without having to switch the TV on and then screencast my phone, but obviously I can only view one camera at a time on the Alexa show. I did try to show the Channel zero feed from my nvr so I could see all 4 images on the Alexa show. If you check my previous posts you can read all about it. I could view the channel zero feed using VLC on my laptop when I put those parameters into the monocle app I could not view the channel zero feed on my Alexa. It was strange because the rtp urls for my IP cameras work on VLC and also on Alexa but the channel zero did not.



  • @FineSir Good morning

    No that is the maximum resolution for the sub stream, i could use the main stream as the cameras are 4MP so the 4k screen woudl support it but it would mean turning off H265 for the main stream which i dont want to do as this is a better compression format in terms of how much storage it uses on my NVR.

    I believe to get docker installed on Qnap you need container station which doesnt appear in the available apps when i search so unless there is another way to run docker that i’m not aware of thats not an option.

    I’m guessing as its a 2019 TV and looking at the FAQ’s it seems alexa changed the security measures in 2019 and anything after that needs the gateway so i’m assuming that will be the case unless i hear otherwise from another LG user.

    To clarify with the others users questions the TV is alexa (and google) enabled and comes with a voice remote, i press and hold the amazon button and the alexa blue listen bar appears at the bottom of the screen and i then ask it to “show front door” and the door bell appears. The TV can also be seen in my devices list on the alexa app. If this is the same for your Samsung then i can see no reason why it wouldnt work although it will probably need the gateway.

    @Esso With channel zero did you reboot the NVR after enabling it and are you sure the path is correct (camera 001)



  • Hi again,

    I don’t know if anyone can assist me further with trying to get this working please! There’s been no response from support?

    I have now installed monocle gateway on one of my old Pi’s and when I look at the tail string it says it’s initialised and if I ask the tv to call up a camera I get the below which says to me there’s some communication from the tv but from what I’ve seen on other posts there should then be some information under the camera details to show that it’s communicated and connected which I’m not getting? Any ideas why? Is there a way to test port 443 is working, and would I need to change anything on a VM super hub 3 to allow this traffic?

    alt text

    alt text

    Thanks



  • Can anyone tell me how to amend my above post please, as it doesn’t look like the photos links are correct? And I cannot find an option anywhere.

    Thanks



  • I think it’s your Google Drive settings. You need to give public access to those files or the folder that contains them.



  • @G3ZDM hi thank you for the reply, I’ve changed the settings in google drive for those files to ‘link sharing on’ hopefully they can be seen now, without access to my full google drive!

    Thanks



  • Evening all

    Is anyone able to please assist me further with getting this working?

    I have changed the tag from @tunnel to @proxy and can now see activity on the gateway, but I don’t really know what it should be saying / what I should be looking for? To diagnose where it’s failing the connection as still getting the same on the TV?

    I’m tempted to purchase a show 5 as there on offer, but don’t want to waste money if it’s still not going to work.

    Any further help would be really appreciated. Does @Monocle no longer participate in support?

    Thanks


Log in to reply