Specifications for the RTSP supported



  • I have a Hive camera where the RTSP steam works fine on VLC. Using the proxy server with verbose option, the SDP offer looks like,

    v=0
    o=- 361124738 1 IN IP4 192.168.1.2
    s=Streamd by "RTSP Server"
    i=session information
    t=0 0
    a=tool:RTSP Server:Nov 23 2018 - 19:29:58
    a=type:broadcast
    a=control:

    a=range:npt=0-
    m=video 0 RTP/AVP 96
    c=IN IP4 192.168.1.6
    a=sendonly
    a=rtpmap:96 H264/90000
    a=fmtp:96 packetization-mode=1; profile-level-id=4D401F; sprop-parameter-sets=Z01AH5pmAoAt/4C3AQEBQAAA+gAAOpg6GAfMAANWfrvLjQwD5gABqz9d5cKA,aO44gA==;
    a=cliprect:0,0,720,1280
    a=control:rtsp://192.168.1.6/video=video1
    m=audio 0 RTP/AVP 99
    c=IN IP4 192.168.1.6
    a=rtpmap:99 mpeg4-generic/16000/1
    a=fmtp:99 streamtype=5; profile-level-id=41; mode=AAC-hbr; config=1408; SizeLength=13; IndexLength=3; IndexDeltaLength=3; Profile=1;
    a=control:rtsp://192.168.1.6/audio=aac-16k*

    With the proxy I get 'Buffering".
    With the gateway using @tunnel option it does not work
    With the gateway using @tunnel and @noaudio option it does not work
    With @proxy and @noaudio it works
    On VLC playing stream works well with both video and audio.

    I can change the camera application, is there any specification that we could follow to ensure the camera will work with Echo Show without a local gateway running?



  • @spahwa

    Sorry, we don’t have the full details as to what Amazon requires in the SDP. We just seem to find out by trial and error for most cameras. They don’t publish any details requirements specification for this. I suspect that their implementation is just buggy and that’t why it fails with a n umber of cameras.

    One thing we do know is that if an audio channel is defined, it must use a specifically defined mapping and include the “a=rtpmap” line that explicitly defined the codec details.

    m=audio 0 RTP/AVP 99
    a=rtpmap:99 mpeg4-generic/16000/1
    

    For example, while the example below is perfectly legal, Amazon devices refuse to accept it:

    m=audio 0 RTP/AVP 0
    


  • Thanks. The audio in the sdp offer for my camera does have the definition as suggested by yourself. Is it possible that the “mode=AAC-hbr” is not supported by Amazon?



  • @spahwa

    I think mode=AAC-hbr us ok … I’ll have to look at a few cameras that are using AAC audio and see if they include this “HBR” mode.



  • @spahwa

    Just an update to this thread … we have a number of cameras that include mode=AAC-hbr in the SDP with no issues at all.

    Example:

    a=fmtp:97 streamtype=5;profile-level-id=1;mode=AAC-hbr;sizelength=13;indexlength=3;indexdeltalength=3;config=1588