toUpperCase error with new server



  • Hi All,

    I am trying to stream my UniFi cameras locally to my Alexa devices and I have installed Ubuntu Server on a VM in QNAP and setup the RTSP devices on Monocle.

    The device is discovered by Alex but when I ask to show it nothing happens and I see the following from the monocle log on the server:

    Mar 26 15:08:08 monocle monocle-gateway[899]: 2021-03-26T15:08:08.005Z [ERROR] Uncaught Exception Cannot read property 'toUpperCase' of undefined
    Mar 26 15:08:08 monocle monocle-gateway[899]: [ 'Uncaught Exception',
    Mar 26 15:08:08 monocle monocle-gateway[899]:   'Cannot read property \'toUpperCase\' of undefined' ]
    Mar 26 15:08:08 monocle monocle-gateway[899]: 2021-03-26T15:08:08.007Z [ERROR] TypeError: Cannot read property 'toUpperCase' of undefined
    Mar 26 15:08:08 monocle monocle-gateway[899]: [ TypeError: Cannot read property 'toUpperCase' of undefined
    Mar 26 15:08:08 monocle monocle-gateway[899]:     at TLSSocket.events_1.EventEmitter.constructor.e.once.o (/snapshot/monocle-gateway/lib/monocle/MonocleRtspClient.js:1:1287)
    Mar 26 15:08:08 monocle monocle-gateway[899]:     at Object.onceWrapper (events.js:254:19)
    Mar 26 15:08:08 monocle monocle-gateway[899]:     at TLSSocket.emit (events.js:159:13)
    Mar 26 15:08:08 monocle monocle-gateway[899]:     at addChunk (_stream_readable.js:265:12)
    Mar 26 15:08:08 monocle monocle-gateway[899]:     at readableAddChunk (_stream_readable.js:252:11)
    Mar 26 15:08:08 monocle monocle-gateway[899]:     at TLSSocket.Readable.push (_stream_readable.js:209:10)
    Mar 26 15:08:08 monocle monocle-gateway[899]:     at TLSWrap.onread (net.js:598:20) ]
    
    

    Can someone please help?

    Thanks



  • Hey

    Have you tried to view the streams in VLC? Made sure they are H264 and of an acceptable resolution for the Alexa?
    Might need to try a tag as well. There are a few posts of people troubleshooting unifi devices here so I’d suggest have a quick search!
    Let me know how you go. Just on my phone so it’s hard to link info.



  • @FineSir Yes the stream seems to work fine on VLC and I have used the @tunnel tag too. Not sure what this error is referring to though



  • I’m not too sure either.
    Make sure all your ports are open on your gateway server. I did have issues when running PiHole DNS and a firewall on my gateway.
    I’d troubleshoot the basic stuff, make sure you use the sub or third stream and set the encoding on the NVR or camera if it is standalone.
    Might best best to directly RTSP from the camera to the Alexa, in that case set your encoding on the camera itself.


Log in to reply