Can't get alexa to connect to the gateway



  • I’m new to Monocle and trying to setup unifi with alexa show (2019 edition).
    I was able to setup the account, skill and discover the camera(s), furthermore I’ve setup gateway via docker image running on a macvlan network with a dedicated IP.
    I’ve saved the API key to appropriate file and gateway can talk to API server, here is my network info:

    -------------------------------------------------
    MONOCLE RTSP SERVICE - INITIALIZED
    -------------------------------------------------
    FQDN = 4437c479-857d-407c-9c37-69d1be94333f.mproxy.io
    HOST = 10.0.0.91
    PORT = 443
    

    I’ve verified that DNS returns a private address on my network:

    C:\Users\Gene>ping 4437c479-857d-407c-9c37-69d1be94333f.mproxy.io
    
    Pinging 4437c479-857d-407c-9c37-69d1be94333f.mproxy.io [10.0.0.91] with 32 bytes of data:
    Reply from 10.0.0.91: bytes=32 time<1ms TTL=64
    ...
    

    And I can even request the URL via chrome, which shows up on the logs:

    2021-06-20T00:25:40.378Z [INFO]  [10.0.0.194:64254 <H13-o-3ju>] RTSP CLIENT SOCKET CONNECTED
    2021-06-20T00:25:40.379Z [WARN]  [10.0.0.194:64254 <H13-o-3ju>] RTSP CLIENT INVALID REQUEST: GET / HTTP/1.1
    2021-06-20T00:25:40.381Z [INFO]  [10.0.0.194:64254 <H13-o-3ju>] RTSP CLIENT SOCKET CLOSED
    

    Issue is when I try to start a stream from Alexa, I see that API server sends an initialization request, but gateway never sees any traffic from Alexa, here is my setup:

    setup.PNG

    I’ve also run the same setup with @proxy in lieu of @tunnel and @proxy-tcp, though I was not successful in getting Alexa to work.

    For the record, I’ve tried the 2019 8" echo show & the windows alexa app, both of which provided a same result (camera is unresponsive).

    I’ve run the packet capture on the gateway and didn’t see any traffic besides the API server, when I get a chance I’ll see if I can find anything useful by capturing traffic from Alexas themselves.

    What could be going wrong? Anything in the troubleshooting steps I may be overlooking?

    Appreciate your time,
    Gene



  • Correction: integration works with 2019 Alexa show 8", it continues not to work with windows Alexa app.
    Originally neither have worked, but I’ve fixed the show Alexa by fixing the DNS lookups (allowing return of private addresses), while fixing I was testing the setup with the windows app, but it continued to fail, leading me to think the show was failing as well.
    Windows app integration is not a deal breaker, but still curious as to why it would fail, whereas standalone Alexa would not.



  • @monome

    I have not tested using Alexa Windows app. Honestly I did not know a Windows Alexa App existed 🙂
    I’ll take a look at it when I have some free time, but I suspect its an issue with the Windows App either not resolving the DNS record or failing to play the stream with the camera’s codec. What type of log data do you get in the Monocle Gateway when attempting to connect from Windows App?

    Thanks,



  • @Monocle Nothing on the logs, windows app simply fails to ever start a connection. I’ve tested the DNS on the same computer as the app, but have not done packet capture to confirm that Alexa app is using the same DNS / results.



  • @monome

    If there’s nothing in the log when requesting a camera from the windows app then that would suggest that the windows app is never attempting to establish contact with the camera RTSP address provided by Monocle to Alexa. So it’s not able to resolve the FQDN address or it’s not even trying.


Log in to reply