Can't seem to get Unifi Protect streams working



  • Hi

    I am new to Monocle and am trying to setup a Unifi G3 Flex with an Echo show 5 to test things out. I have set up the the camera on my Monocle account, added the Alexa skill and installed the Monocle gateway. However, it seems Alexa tries to display the live feed from the camera but times out. In the Monocle gateway logs, I see the following:

    2021-09-19T18:05:19.947Z [INFO]  [127.0.0.1:57584 <Sku1ngrQY>] RTSP CLIENT SOCKET CONNECTED
    
    2021-09-19T18:05:19.950Z [ERROR] [127.0.0.1:57584 <Sku1ngrQY>] RTSP CLIENT SOCKET ERROR: Error: 8629829120:error:14094412:SSL routines:ssl3_read_bytes:sslv3 alert bad certificate:../deps/openssl/openssl/ssl/s3_pkt.c:1500:SSL alert number 42
    
    
    [ '[127.0.0.1:57584 <Sku1ngrQY>]',
      'RTSP CLIENT SOCKET ERROR:',
      Error: 8629829120:error:14094412:SSL routines:ssl3_read_bytes:sslv3 alert bad certificate:../deps/openssl/openssl/ssl/s3_pkt.c:1500:SSL alert number 42
     ]
    
    2021-09-19T18:05:19.952Z [INFO]  [127.0.0.1:57584 <Sku1ngrQY>] RTSP CLIENT SOCKET CLOSED
    
    
    -------------------------------------------------
    
    INITIALIZE RTSP STREAM:  Garage Camera
    -------------------------------------------------
     - NAME  : Garage Camera
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.1.68:7447/mRQiuIogCoUuVMFz
     - UUID  : STREAM:531d8696-60d9-4df1-9ffa-aae07119b29e
    
     - SESS  : e08de8a1-48b1-4b83-a063-5005280b2c20
    
     - MODIF : Sun Sep 19 2021 11:00:37 GMT-0700 (PDT)
    
     - TAGS  : @fakefmtp,@noaudio,@tunnel
    
    -------------------------------------------------
    

    I have tried with @proxy as well

    -------------------------------------------------
    
    INITIALIZE RTSP STREAM:  Garage Camera
    -------------------------------------------------
     - NAME  : Garage Camera
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.1.68:7447/mRQiuIogCoUuVMFz
     - UUID  : STREAM:531d8696-60d9-4df1-9ffa-aae07119b29e
     - SESS  : 54acfb35-2726-41d7-984d-f23f62c4886e
    
     - MODIF : Sun Sep 19 2021 11:06:47 GMT-0700 (PDT)
    
     - TAGS  : @fakefmtp,@noaudio,@proxy
    
    -------------------------------------------------
    
    
    
    
    -------------------------------------------------
    
    RTSP STREAM MODIFIED:  Garage Camera
    
      Any existing RTSP steams will be shut down
      and a new stream instance will be registered.
    
    -------------------------------------------------
    
    
    2021-09-19T18:06:53.969Z [DEBUG] <RTSP-PROXY> [REQUEST]  --> [DEREGISTER] rtsp://192.168.1.68:7447/mRQiuIogCoUuVMFz
    2021-09-19T18:06:53.969Z [TRACE] <RTSP-PROXY> [REQUEST]  --> [HEADERS] {
      "cseq": "1",
      "transport": "reuse_connection=0;preferred_delivery_protocol=udp;proxy_url_suffix=STREAM:531d8696-60d9-4df1-9ffa-aae07119b29e"
    }
    
    2021-09-19T18:06:53.969Z [DEBUG] <RTSP-PROXY> [RESPONSE] <-- [451 (Invalid parameter)] <cseq=1> (session=undefined)
    2021-09-19T18:06:53.969Z [TRACE] <RTSP-PROXY> [RESPONSE] <-- [HEADERS] {
      "cseq": "1",
      "date": "Sun, Sep 19 2021 18:06:53 GMT"
    }
    
    2021-09-19T18:06:53.969Z [INFO]  [RTSP PROXY] REGISTERING STREAM [Garage Camera/PRIMARY]; (STREAM:531d8696-60d9-4df1-9ffa-aae07119b29e)
    
    2021-09-19T18:06:53.971Z [DEBUG] <RTSP-PROXY> [REQUEST]  --> [REGISTER] rtsp://192.168.1.68:7447/mRQiuIogCoUuVMFz
    
    2021-09-19T18:06:53.971Z [TRACE] <RTSP-PROXY> [REQUEST]  --> [HEADERS] {
      "cseq": "1",
      "transport": "reuse_connection=0;preferred_delivery_protocol=udp;proxy_url_suffix=STREAM:531d8696-60d9-4df1-9ffa-aae07119b29e"
    }
    2021-09-19T18:06:53.972Z [DEBUG] <RTSP-PROXY> [RESPONSE] <-- [200 (OK)] <cseq=1> (session=undefined)
    2021-09-19T18:06:53.972Z [TRACE] <RTSP-PROXY> [RESPONSE] <-- [HEADERS] {
      "cseq": "1",
      "date": "Sun, Sep 19 2021 18:06:53 GMT"
    }
    

    Not sure how to proceed, would appreciate any help.

    Thanks!
    Abhishek



  • @adeydas said in Can't seem to get Unifi Protect streams working:

    have set up the the camera on my Monocle account, added the

    I initially had issues with my Unifi cameras, try adding the @tunnel tag to your cameras in your account.


Log in to reply