Unable to get Amcrest UltraHD 4K to work on Echo Show



  • I am once again attempting to use Monocle to get my IP security cameras to display on an Echo Show 5. I set it all up about 2 years ago, got it working briefly, but then it failed. I gave up. Fast-forward to now and I’m trying again, with new IP cameras.

    I have an Amcrest UltraHD 4K camera, model IP8M-T2499EW-40MM. Love the camera. Have it working in Blue Iris and have used the rtsp stream in VLC media player to get it to work just fine. But no luck with Monocle and the Echo Show 5.

    I have the camera setup with the following information:

    be429a5c-f4c7-452c-a86a-5d922d7ff296-image.png

    In the Monocle Gateway I’ll see the

    MONOCLE RTSP SERVICE - INITIALIZED
    

    When I ask Alexa to “Show Barn Cam New” the Echo Show 5 will start and she’ll say “OK” and then she’ll say “Hmmm camera is not responding”.

    In the monocle-gateway app console there will be 4 new entries for:

    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Barn Cam New
    -------------------------------------------------
     - NAME  : Barn Cam New
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.1.56:554/cam/realmonitor?channel=1&subtype=2&unicast=true&proto=Onvif
    

    At the end will be this:

    2021-10-05T23:58:07.436Z [INFO]  [RTSP PROXY] STREAM [Barn Cam New/PRIMARY] WILL BE DE-REGISTERED IN 4 MINUTES
    

    This will countdown every minute and then it looks like it de-registers the stream.

    If I copy that rtsp stream URL into VLC media player, it will ask me for my username and password. I’ll give it exactly what I gave in the Monocle camera feed setup. And it will display nicely.

    I have tried @tunnel and @proxy tags. I’ve tried BASIC and DIGEST Authentication methods.

    So what else could be going wrong here? What should I change?

    Thanks,



  • Here’s my working version. I don’t seem to have any problems.ce5dccad-9a33-49e5-9ba1-53d85d9278fb-image.png



  • So I figured it out thanks to this troubleshooting guide on DNS Rebinding. No idea what that is, but that was the problem!

    On my router, which is an Asus RT-AC68R/U and uses the Advanced Tomato firmware, I had to add this to the Advanced Settings->DHCP/DNS Server (LAN)->Dnsmasq custom configuration field:

    address=/<FQDN value>.mproxy.io/192.168.1.8
    

    where the FQDN value was found in the monocle console window.

    I couldn’t figure out how to add a wilcard *.mproxy.io. If anyone knows how to do that, that would be appreciated!


Log in to reply