Amcrest AD410 Video Doorbell & Echo Show



  • Has anyone had success getting this video doorbell to work with Monocle? No matter what I try I cannot get it to work. I tired the regular way, I tired the gateway, nothing works. My RTSP works fine in all other programs, but will not come up on the echo show.



  • Also running into issues with getting Monocle to work. Set authentication to basic but still not working. Currently trying to use the “Amcrest Smart Home” skill to see if it will work but so far no luck. I don’t pay for cloud storage through Amcrest but they say streaming works for free so don’t see why it isn’t working.



  • I’ve sent Amcrest an email to see if they can get just their skill to work as it’s supposed to because I can’t get this Monocle skill to work at all. I’ve tried for different types of cameras I have and none will show on the echo.



  • Please update with what they say. Feel like it should not be this hard. At this point I am thinking of buying a raspberry pi and set up home assistant. What I am thinking is that home assistant can recognize that the doorbell is pressed and then push the feed to the echo show some how. This step of pushing the feed to the echo show is still a missing piece that I am unsure how easy is to do. There is a video by Make It Work on youtube “Amcrest AD410 Integration in Home Assistant” which looks promising for at least recognizing the doorbell being pressed.



  • @tammymfreeman I have had an open ticket with Amcrest for months about their AD410 doorbell and my Echo Show 8. I finally just changed the name of my doorbell, and it worked for weeks. Then one day it quite again. Hasn’t displayed on my Show since. I just gave up for the time being. Alexa announces correctly, just doesn’t display on my Show. As for Amcrest… no one ever replies on my ticket.

    However, on a different subject, I have a couple of Dahua cameras working fine in Monocle, so it does work!



  • Was able to get a stream going on the echo show (for clarity I have the show 8). I downloaded the Monocle Gateway and follow the steps here https://monoclecam.com/monocle-gateway and currently just running from my mac for testing. Could NOT get this working without the Monocle Gateway. I can’t find the post I saw before but this seems to be a limitation on the echo show and not the amcrest feed. (probably need to do more research on the exact reason why you need the Monocle Gateway) Some key points for setting things up.

    Camera Feed/Stream URL (RTSP) use the following template rtsp://{ip address of camera}:554/cam/realmonitor?channel=1&subtype=1 NOTE that this is different from what amcrest says to use from their docs on rtsp. Notice the subtype is =1 instead of =0 like it is in the docs. This makes the stream be of lower quality. (Maybe there is a way to set things up for high quality but hey, good enough as a start).

    For authentication use DIGEST.

    Set video resolution to “1920*1080 (16:9) [FHD] <1080P>”

    Set tag to @tunnel

    Set video and audio to H264 and AAC

    Download the Monocle Alexa skill and link your accounts.

    This is what worked for me. Let me know if you are still having troubles and maybe I can help. For me, next is to figure out how the echo show can detect someone ringing the doorbell.



  • @justdo71

    I was able to get my AD410 showing on my Echo Show 8 with your rtsp string, with one difference. Here is mine:

    rtsp://{camip}:554/cam/realmonitor?channel=1&subtype=1&unicast=true&proto=Onvif

    Mine would not work without the extra info at the end. However, I’m running Monocle gateway on a WIndows 10 PC and not my Mac if that make any difference.

    Appreciate the heads up about the subtype=1 !!!



  • @bill

    Running Monocle Gateway on OSX vs Windows vs Linux … in theory … should not make any difference 🙂



  • @justdo71

    Many of the older Amcrest cameras work without the need for the Monocle Gateway; however if I recall correctly some Amazon devices like the Amazon FireTV Edition always seem to require the Monocle Gateway to work.

    It seems like the video player or codecs in each of the Amazon devices/families vary and can be very picky about the video/audio streams. Additionally, it seems like certain Amazon devices (especially newer) are more picky about the security of the connection and require connecting to camera streams only on port 443 using TLS secure connections with a valid SSL certificate and a public DNS URL. This is where the Monocle Gateway steps in and provides/meets this additional security layer/requirements. If you are using only @tunnel then the Monocle Gateway does not modify the RTSP communication between the camera and Alexa device in any way — except for the HTTPS/SSL/TLS security wrapper layer.

    Thanks, Robert



  • I will give the suggestions a try. I have an echo show 5. It announces just fine when the doorbell is pressed based on the amcrest home skill, just no video.

    I have been so frustrated that I ordered a new doorbell that arrives today so if this doesn’t work I’ll try the new one.



  • @tammymfreeman

    Well, Monocle does not support any announcements/notifications for Doorbells … so it may not meet your needs anyway?



  • So I tried the new suggestions, still no video, just times out. I did notice though that in the gateway that 1. I don’t get all the other stuff after initialization and also the host ip that i circled below is not the same as my network, maybe that’s the problem?

    305425f8-d30f-488b-8263-42631fb25983-image.png



  • @tammymfreeman

    That is the IP address that is automatically getting detected by the Monocle Gateway on startup. Are you running it inside a virtual machine or in a Docker container? Or just directly on your Windows workstation?

    Thanks, Robert



  • directly from my windows 10 machine. then i prompt my alexa device and the next part shows up, but nothing else shows and the echo show just says waiting for camera then stops.



  • @tammymfreeman

    OK, it looks like we will need to override the default IP address by creating a monocle.properties file and explicitly setting the IP address using the rtsp.register.host=192.186.1.? property

    Take a look at this help page:
    https://monoclecam.com/monocle-gateway/custom-configuration

    Make sure the property rtsp.register.host in uncommented and is set to the IP address of your Windows machine. Based on your camera’s IP in the log, I’ll assume that your windows machine is 192.168.1.???

    Restart your Monocle Gateway. You might want to generate a new token after your new IP address is getting picked up to speed up the DNS resolution as the previous token is already tied to the incorrect 172 address and may take a little while to get updated and propagated.

    Thanks, Robert



  • Thanks for that. That made the full script run and all the other info came up…BUT, now the show goes “hmmm the camera isn’t responding”. That’s the response I get when using the native skill provided by the manufacturer 😞



  • @tammymfreeman

    Go ahead and post a log of what the Monocle Gateway is doing when your request the camera stream. I can take a look and see how far in the process it is getting and see if there is a clear reason why its not streaming.



  • @Monocle Agree fully. However mine (thus far) will only work with the string I posted above. But thanks for your input! 👍



  • Thanks for all the help. Here is the full output below (btw, it is still running, keeps trying something). I had to post a photo bc the actual code gets flagged as spam.

    5033d055-66b9-43a2-8220-995672841028-image.png



  • @tammymfreeman

    So it looks like its failing to authenticate with the camera.

    1.). The first DESCRIBE request fails and the camera’s response indicates (via 401 response) that its wants DIGEST authentication. This is all normal.
    2.). The Monocle Gateway then attempts DIGEST authentication but the camera rejects the auth request with a 401 response.
    3.). The Monocle Gateway then attempts BASIC authentication but the camera rejects the auth request with a 401 response.
    4.). Monocle Gateway then gives up because both methods of authentication have failed.

    This would typically indicate an invalid username/password. Some cameras may be picky about special characters in the password. I also recall a bug in the the Hikvision doorbell camera firmware truncating the password to 6 characters and thus the user would have to only specify the first 6 characters if the password were longer. I would try verifying the username and password and then maybe try some simpler/shorter password combinations just to see if you can get it working.

    Thanks, Robert


Log in to reply