Hikvision camera with Echo Show 10 issues



  • Hi all and Happy New Year!

    I have a number of Hikvision cameras set up and have just got an Echo Show 10 and wanted to set it up to show the feed from one of them initially to get it all up and running. It’s a DS-2CD2328G1, set to H.264, but I can’t seem to get it working. When asking Alexa to “Show driveway” it responds with “Ok” then about 1 or 2 seconds with “Hmmm, the camera isn’t responding”.

    Any help would be most appreciated! Apologies for the longish post - I’ve just tried to include any info I thought is relevant.

    I have an existing windows 10 server on the same local network that runs 24/7 that I put the monocle gateway on.

    I have followed the monocle gateway instructions, have verified the feed using VLC, have tried all the various tag combinations for the camera on the monocle portal, removing the camera from Alexa and doing a Discover Device again each time just to be sure and have tried both the main feed (at 1080P), the sub-stream at 480p (the highest resolution for that stream and lowest Echo supports) and also a 3rd stream (at 720p). Doing a Discover Devices finds the camera ok every time.

    My server running the gateway has only Windows firewall running but I’ve done a ping as per the instructions and this works ok, so gather there’s no issue with the firewall.

    Starting monocle gateway all seems to be good:

    -------------------------------------------------
    MONOCLE RUNTIME ENVIRONMENT
    -------------------------------------------------
    VERSION   = 0.0.4
    OS/ARCH   = win32\x64
    PROCESS   = monocle-gateway (PID=2228)
    TIMESTAMP = 2022-01-03T13:45:43.203Z
    
    -------------------------------------------------
    MONOCLE GATEWAY SERVICE         (Version: 0.0.4)
    -------------------------------------------------
    [Monocle Starting]
    [Monocle Connecting]
    [Monocle Started]
    [RTSP Server Starting]
    [RTSP Server Listening] 0.0.0.0:8555 (RTSP)
    [RTSP Server Listening] 0.0.0.0:443 (RTSP-TLS)
    [RTSP Proxy Started] (PID=9888)
    [RTSP Server Listening] 0.0.0.0:8554 (PROXY)
    [RTSP Server Started]
    [Monocle Connected]
    [RTSP Server Registered]
    
    -------------------------------------------------
    MONOCLE RTSP SERVICE - INITIALIZED
    -------------------------------------------------
    FQDN = 384a2836-cbf6-4f5c-bc07-ff5055d07354.mproxy.io
    HOST = 192.168.1.13
    PORT = 443
    

    After doing a device discovery once found, then asking Alexa to “Show Driveway” I see this in the gateway:

    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Driveway
    -------------------------------------------------
     - NAME  : Driveway
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.1.50:554/Streaming/Channels/103?transportmode=unicast&profile=Profile_3
     - UUID  : STREAM:b3ac3889-06ad-4f45-852e-fa0eb36c9728
     - SESS  : 5a7f37a8-8863-4cee-8e48-22418092e0e1
     - MODIF : Mon Jan 03 2022 13:46:07 GMT+0000 (GMT Standard Time)
     - TAGS  : @noaudio,@tunnel
    -------------------------------------------------
    

    In fact, this gets repeated 3 times, but no further info re connecting to the stream. I tried with just @tunnel, then with @noaudio as well, and have tried with proxy and even given @nptnow a try, but no luck.

    I note the RTSP string has “unicode” and “profile” after the channel No whereas others on this forum have noted just the feed string is just up to the channel No e.g. “101”. However if I remove those parts, it still doesn’t work and checking in VLC, I can no longer see the feeds, so it appears I need that full RTSP feed string.

    If I try the @proxy tag, I get this from the gateway:

    -------------------------------------------------
    RTSP STREAM MODIFIED:  Driveway
      Any existing RTSP steams will be shut down
      and a new stream instance will be registered.
    -------------------------------------------------
    
    2022-01-03T14:09:02.951Z [DEBUG] <RTSP-PROXY> [REQUEST]  --> [DEREGISTER] rtsp://192.168.1.50:554/Streaming/Channels/103?transportmode=unicast&profile=Profile_3
    2022-01-03T14:09:02.952Z [TRACE] <RTSP-PROXY> [REQUEST]  --> [HEADERS] {
      "cseq": "1",
      "transport": "reuse_connection=0;preferred_delivery_protocol=udp;proxy_url_suffix=STREAM:b3ac3889-06ad-4f45-852e-fa0eb36c9728"
    }
    2022-01-03T14:09:02.954Z [DEBUG] <RTSP-PROXY> [RESPONSE] <-- [451 (Invalid parameter)] <cseq=1> (session=undefined)
    2022-01-03T14:09:02.954Z [TRACE] <RTSP-PROXY> [RESPONSE] <-- [HEADERS] {
      "cseq": "1",
      "date": "Mon, Jan 03 2022 14:09:02 GMT"
    }
    2022-01-03T14:09:02.956Z [INFO]  [RTSP PROXY] REGISTERING STREAM [Driveway/PRIMARY]; (STREAM:b3ac3889-06ad-4f45-852e-fa0eb36c9728)
    2022-01-03T14:09:02.963Z [DEBUG] <RTSP-PROXY> [REQUEST]  --> [REGISTER] rtsp://192.168.1.50:554/Streaming/Channels/103?transportmode=unicast&profile=Profile_3
    2022-01-03T14:09:02.964Z [TRACE] <RTSP-PROXY> [REQUEST]  --> [HEADERS] {
      "cseq": "1",
      "transport": "reuse_connection=0;preferred_delivery_protocol=udp;proxy_url_suffix=STREAM:b3ac3889-06ad-4f45-852e-fa0eb36c9728;username=DrivewayCam-Alexa;password=W1bble!968"
    }
    2022-01-03T14:09:02.967Z [DEBUG] <RTSP-PROXY> [RESPONSE] <-- [200 (OK)] <cseq=1> (session=undefined)
    2022-01-03T14:09:02.968Z [TRACE] <RTSP-PROXY> [RESPONSE] <-- [HEADERS] {
      "cseq": "1",
      "date": "Mon, Jan 03 2022 14:09:02 GMT"
    }
    

    this followed by the “Initialize RTSP stream” entry as further above but with the @proxy tag listed.

    Everything I try where I can get the feed in VLC, the camera is discovered ok by Alexa, the monocle gateway shows “INITIALIZE RTSP STREAM” results but then not the “RTSP CLIENT SOCKET CONNECTED” entries that should follow and Alexa responds as above, with “Hmmm, the camera isn’t responding”.

    Anyone have any ideas?

    Thanks, Gareth


Log in to reply