----------WANSVIEW COMPATIBILITY README----------



  • Please note that some Wansview cameras are not directly compatible with Alexa devices including models K3 and Q3S.


    STATUS

    There is an incompatibility with Alexa devices in the audio channel on some Wansview camera models.

    ATTENTION
    As of July 2019, Wansview cameras are no longer working on FireTVs with FireOS 6.2.6.4. This includes FireTV 4K (Gen2), FireTV 4K Stick, FireTV Cube, Toshiba 4K Fire Edition. Wansview cameras are also confirmed not working on Echo Show 5 devices. At the time of this writing, Wansview cameras are working on older FireTV 4Ks running FireOS 5.2.7 and Echo Show (Gen1), Echo Show (Gen2) and Echo Spot. There is not currently a workaround available. We will be working with Amazon support to try and get these cameras working again.


    Current Solution/Workaround

    This can be resolved by disabling the audio channel in the stream via the camera’s web configuration pages. Set the Stream Type to Without Audio.

    If you prefer not to disable the audio in the stream, then you can optionally use the Monocle Gateway and tag your Wansview cameras with the @tunnel and @noaudio tags.

    Note: The FireTV 4K and newer devices all require using the Monocle Gateway service to allow them to function. Please see this page for more details: https://forum.monoclecam.com/topic/112/fire-tv-stick-4k-3rd-generation-2018

    dc4b4ebd-006e-477f-ae47-f73da87377a4-image.png



  • Hi,
    Have made all settings as described, but echo Show 2nd gen, said that camera isn’t reacting.

    Any ideal?



  • Hi,

    It seems like there is no workaround at the moment. I can’t get it to work either. Maybe someone can edit the post above to state “OLD SOLUTION/WORKAROUND” instead of “CURRENT…”



  • The wansview cameras do not work with the Echo Show 8 no matter what you install, tag or do. It’s a shame as I can see the log entries when I attempt the make the connection so I know it is close. But it does not display the video. Works in VLC and everywhere else.



  • I’ve managed to get my wanscam W2 to work by using ffmpeg to re-encapsulate the media stream and re-publishing there via rtsp-simple-server and monocle-gateway:

    1. Install rtsp-simple-server from
      https://github.com/aler9/rtsp-simple-server/releases/latest

    2. Make sure, ffmpeg is available on your system (https://ffmpeg.org)

    3. Configure rtsp-simple-server to serve the reencoded stream
      Here the relevant part of my rtsp-simple-server.yml

    [...]
    # port of the TCP/RTSP listener. This is used only if encryption is "no" or "optional".
    rtspPort: 8654
    # port of the TCP/TLS/RTSPS listener. This is used only if encryption is "yes" or "optional".
    rtspsPort: 8655
    # port of the UDP/RTP listener. This is used only if "udp" is in protocols.
    rtpPort: 8100
    # port of the UDP/RTCP listener. This is used only if "udp" is in protocols.
    rtcpPort: 8101
    [...]
    paths:
      cam:
        source: record
        publishIps: ["127.0.0.1"]
        runOnInit:  "ffmpeg -i 'rtsp://user:pass@IP_OF_CAMERA/live/ch0' -vcodec copy -acodec aac -f rtsp  rtsp://localhost:${RTSP_PORT}/${RTSP_PATH} -loglevel 8"
        runOnInitRestart: yes
        readUser: user
        readPass: pass
        readIps: ["YOURLOCALSUBNET"] #or let empty
    

    The runOnInit might be also replaced by a runOnDemand

    Now configure monocle to connect to the local rtsp server, e.g.:

    rtmp://IP_OF_HELPER_SERVER:8654/cam
    

    and use as tags @proxy

    Hope that helps!


Log in to reply