silent proxy fail on windows [SOLVED]



  • I found and fixed this problem so wanted to log for reference.

    I installed on a new Win10 install and was getting connection refused errors to :8554 and :8555 in the gateway logs and tried all kinds of loopback/network items and then decided to run monocle-proxy.exe directly.

    That revealed the issue. That exe requires Visual C++ 2010 runtime (you get a popup error about a VC dll when run interactively).

    The fix is to install the runtime from this download https://www.microsoft.com/en-us/download/details.aspx?id=5555.

    Hope this helps anyone else who runs into similar.



  • @lactose

    Thanks for the tip – I think there is a note on this dependency on the Windows install page, but its probably not very obvious. We are working on a Windows installer that will package this dependency into the installer.

    Thanks, Robert



  • Ha, you are right. It is in there. Something about it being the indented pull out text made me ignore it (that’s my bad), that and when I had previously installed it months ago on my main desktop for testing I didn’t run into that issue as the dependency was already installed.

    Thanks.


Log in to reply