Iseevy rtsp encoder support



  • Hello, I recently purchased an “Iseevy rtsp encoder” which i’m hoping to use to display a 1080P grid view of several cameras at once (from my DVR) to Firetv 4K devices (latest Gen) and Echo Spot and Show devices (all latest Gen). I have The gateway service up and running on a local machine which is successfully serving up 3 Hikvision cameras to all these devices. I have tried all of the different “tags” but can’t get the Iseevy stream to pull up on any of my devices. It works fine through VLC MP. Below is a link to the product I am reffering too

    https://www.ebay.com/itm/H-264-HDMI-Video-Encoder-IPTV-Encoder-with-Loopout-support-RTMP-RTSP-UDP-HTTP/183113016813?hash=item2aa262e5ed:g:8AoAAOSwa~JbMvZS

    Any suggestions?



  • @bigo93bronco

    The Alexa devices are VERY picky about the H.264 video and G711/AAC audio streams.

    I purchased and tested this encoder and could not get it to work either:
    http://amzn.to/2H3lPJF

    I have not tested it, but one user has reported that this encoder is working with Monocle and Alexa:
    https://amzn.to/2uJ0Yqd

    Another users also reported success with a FMUSER encoder, but I did get get which specific encoder model he was using.

    Thanks, Robert



  • Well crap, I passed on that 2nd one you listed in favor of this one lol. I don’t need or want audio for my application. What would be the ideal settings in your opinion to try and make my streamer as Alexa-friendly as I can? I’ve seen some people saying setting audio to “off” is not the way to go.



  • @bigo93bronco

    Unfortunately I don’t have any concrete answers here. I was never able to get my encoder working properly despite trying all kinds of settings. I did get the picture to show a couple of times but the latency and stability of the stream playback were so bad it was really unusable.

    Things to try would be to disable the audio stream. Use VLC to verify if the audio channel was actually removed when you disable the audio stream. Some cameras don’t actually remove the audio channel from the stream and this does cause issues with Alexa.
    https://monoclecam.com/troubleshoot/validate-codecs

    Next, try to use a lower resolution of 720 or lower for testing. Try using various H.264 profiles (high, baseline, standard) if your encoder offers those options. Try with both H.264+ enabled and disabled if your encoder offers that option.

    You can also try these tips, including using Monocle Gateway to see if it helps at all:
    https://monoclecam.com/troubleshoot/tips

    I may try to order the FMUSER encoder to see if that works and helps shed any light on the issue.

    Thanks, Robert



  • OK, minor update to this thread …

    I purchased this exact model:

    FMUSER FBE200
    https://amzn.to/2IyVHKb

    alt text

    I was able to get it working but it did require using the Monocle Gateway with the @proxy tag.

    ff84ffce-94a6-44b9-9611-d69c693e27b8-image.png

    Here are the encoder settings I am using with the “Main” stream:

    58af1011-b2ac-477f-89cb-740ad052c9c5-image.png


    I went back and re-tested my previous encoder:

    J-Tech Digital H.264 Encoder
    http://amzn.to/2H3lPJF

    alt text

    I was also able to finally get it working, but it also required using the Monocle Gateway with the @proxy tag. It also required setting the audio stream to “NONE

    626d5675-f5e4-4de6-9254-f1ce799e14ca-image.png

    And here are the encoder settings I’m using on the main stream:

    ee75f546-56d9-40d4-af9d-2667c0b5bcc7-image.png


Log in to reply