Reolink Camera wont show on Alexa TV [SOLVED]



  • Hi,

    Thanks for all the awesome install instructions. I got the Gateway up and running on my PI3B+ The service is running fine:

    c732e758-3e26-4a9e-8302-dbba1b5f7290-image.png

    I have updated the portal to have the tags needed.

    b4a7427b-e522-4037-84c2-58302039f02b-image.png

    And when i ask Alexa (Latest fireTV Stick) to show the camera i see it go via the gateway with the correct info:

    851c1fe7-8b81-4269-a63d-989efcbfb487-image.png

    The camera loads fine in VLC:

    a6ad19c0-0491-4f88-abf0-7088e9400843-image.png

    All Alexa will say is “humm the camera is not responding”. Not sure what else to try. (Note: wasnt sure if i needed to hide the UUIDs etc so did to be safe).

    Thanks again for all your effort on monocle.

    James



  • Had a chat with vmsman (Scott) and we ran over the settings between his and mine and all looked good. The only strange thing was that when it attempts to show the stream on the firetv, i get 3 Initialze RTSP streem requests all within 3 seconds.

    73ea3a7a-f6ce-4a95-bdd2-4974731983dd-image.png



  • So if Alexa is not able to connect to the IP camera stream, she will retry up to 3 times. So I think that’s what’s going on in this case … the Alexa device is (quickly) failing to connect and retrying up to three times before she finally gives up.

    This also coincides with the log file you have shown. There are no log entries for incoming connections to the Monocle Gateway from any Alexa devices.

    So let’s step back a minute and determine if the networking is working properly for your Monocle Gateway instance.

    First make sure that 443 is not being blocked by a firewall on the Monocle Gateway server.

    On startup the Monocle Gateway prints our the local IP address it detected for your gateway instance. Is this the correct IP address? (the auto-detection just finds the first network interface and assumes it is the correct one.). If the private IP is correct, then take a look at the unique FQDN DNS hostname. This is the host address that we provide to the Alexa system to access your cameras via your Monocle Gateway instance. Try performing a nslookup on this hostname record (ideally from another computer on your network) to make sure it’s resolving to your gateway’s private IP address. If nslookup returns the correct IP address, then try to ping that address to make sure you can resolve it locally on your network. If the address is not correct, then the issue could be DNS REBINDING. See this page for more details.

    Examples:

    Perform the DNS lookup locally on your network.
    (Use your actual FQDN instead of the example below)

    nslookup c5b4w3q2-bv4f-4sdf9-dsf-28a852ecae54.mproxy.io
    

    Perform the DNS lookup directly against a public DNS server (bypassing your local DNS server/router)
    (Use your actual FQDN instead of the example below)

    nslookup c5b4w3q2-bv4f-4sdf9-dsf-28a852ecae54.mproxy.io 8.8.8.8
    

    If the local DNS attempt fails but the public DNS server returns the correct address, then this is most likely a DNS REBINDING issue.



  • Hi,

    Looks like you are bang, sorry i missed that bit in the help docs) on the 8.8.8.8 lookup gives 10.10.1.11 (which is correct) the first nslooup gives the default gateway response of 10.10.1.1 (not correct).

    Wrong:
    bbf013c0-e30a-4045-ae97-c9c4066e368d-image.png

    Correct:
    14e4e1cd-db41-44e0-8e86-1efc2401d79e-image.png

    Now i just need to work out how to do the DNS REBINDING on a Unifi network. Will post the answer to help others.

    Thanks for the super quick advice.



  • @james123

    Great, glad we have narrowed it down. We hope to add additional tools in future versions of the Monocle Gateway to help diagnose these types of issues quickly and easily.

    Hopefully with the Unifi equipment they offer a simple means to whitelist a particular domain from DNS REBINDING. I use a PFSense router here and it was as simple as adding a custom option to the DNS Forwarder: rebind-domain-ok=/mproxy.io/

    Once you have the DNS rebind sorted on your router, you may also need to reboot the Alexa devices to clear any internal DNS caches.

    Thanks, Robert



  • Got this working now. For anyone using UniFi USG, you need to make a static entries on USG, by doing this:

    1. As a root on usg shh then create/edit file:
    vi /etc/dnsmasq.d/dnsmasq.static.conf
    
    1. Put the hosts in
    address=/FQDN.mproxy.io/10.10.1.10
    address=/FQDN2.mproxy.io/10.10.1.10
    
    1. Save it (:wq) and then run command
    /etc/init.d/dnsmasq force-reload
    

    Then check with an nslookup. Should be good to go.

    @Monocle Thanks for your help. Feel free to add this to your troubshoting page for other users with UniFi kit.



  • @james123 ,

    I would think that the Unifi USG would support DNS rebinding options as well. Although your static routing will work perfectly fine.

    DNSMasq file:
    rebind-domain-ok=/mproxy.io/

    I don’t have any USG devices, but maybe this example config may be applicable. https://community.ubnt.com/t5/UniFi-Routing-Switching/json-file-help/m-p/2463090/highlight/true#M104288

    {
      "service": {
        "dns": {
          "forwarding": {
            "options": [
              "rebind-domain-ok=/mproxy.io/"
            ]
          },
    

Log in to reply