Reolink Camera wont show on Alexa TV [SOLVED]

  • Hi,

    Thanks for all the awesome install instructions. I got the Gateway up and running on my PI3B+ The service is running fine:


    I have updated the portal to have the tags needed.


    And when i ask Alexa (Latest fireTV Stick) to show the camera i see it go via the gateway with the correct info:


    The camera loads fine in VLC:


    All Alexa will say is “humm the camera is not responding”. Not sure what else to try. (Note: wasnt sure if i needed to hide the UUIDs etc so did to be safe).

    Thanks again for all your effort on monocle.


  • Had a chat with vmsman (Scott) and we ran over the settings between his and mine and all looked good. The only strange thing was that when it attempts to show the stream on the firetv, i get 3 Initialze RTSP streem requests all within 3 seconds.


  • So if Alexa is not able to connect to the IP camera stream, she will retry up to 3 times. So I think that’s what’s going on in this case … the Alexa device is (quickly) failing to connect and retrying up to three times before she finally gives up.

    This also coincides with the log file you have shown. There are no log entries for incoming connections to the Monocle Gateway from any Alexa devices.

    So let’s step back a minute and determine if the networking is working properly for your Monocle Gateway instance.

    First make sure that 443 is not being blocked by a firewall on the Monocle Gateway server.

    On startup the Monocle Gateway prints our the local IP address it detected for your gateway instance. Is this the correct IP address? (the auto-detection just finds the first network interface and assumes it is the correct one.). If the private IP is correct, then take a look at the unique FQDN DNS hostname. This is the host address that we provide to the Alexa system to access your cameras via your Monocle Gateway instance. Try performing a nslookup on this hostname record (ideally from another computer on your network) to make sure it’s resolving to your gateway’s private IP address. If nslookup returns the correct IP address, then try to ping that address to make sure you can resolve it locally on your network. If the address is not correct, then the issue could be DNS REBINDING. See this page for more details.


    Perform the DNS lookup locally on your network.
    (Use your actual FQDN instead of the example below)


    Perform the DNS lookup directly against a public DNS server (bypassing your local DNS server/router)
    (Use your actual FQDN instead of the example below)


    If the local DNS attempt fails but the public DNS server returns the correct address, then this is most likely a DNS REBINDING issue.

  • Hi,

    Looks like you are bang, sorry i missed that bit in the help docs) on the lookup gives (which is correct) the first nslooup gives the default gateway response of (not correct).



    Now i just need to work out how to do the DNS REBINDING on a Unifi network. Will post the answer to help others.

    Thanks for the super quick advice.

  • @james123

    Great, glad we have narrowed it down. We hope to add additional tools in future versions of the Monocle Gateway to help diagnose these types of issues quickly and easily.

    Hopefully with the Unifi equipment they offer a simple means to whitelist a particular domain from DNS REBINDING. I use a PFSense router here and it was as simple as adding a custom option to the DNS Forwarder: rebind-domain-ok=/

    Once you have the DNS rebind sorted on your router, you may also need to reboot the Alexa devices to clear any internal DNS caches.

    Thanks, Robert

  • Got this working now. For anyone using UniFi USG, you need to make a static entries on USG, by doing this:

    1. As a root on usg shh then create/edit file:
    vi /etc/dnsmasq.d/dnsmasq.static.conf
    1. Put the hosts in
    1. Save it (:wq) and then run command
    /etc/init.d/dnsmasq force-reload

    Then check with an nslookup. Should be good to go.

    @Monocle Thanks for your help. Feel free to add this to your troubshoting page for other users with UniFi kit.

  • @james123 ,

    I would think that the Unifi USG would support DNS rebinding options as well. Although your static routing will work perfectly fine.

    DNSMasq file:

    I don’t have any USG devices, but maybe this example config may be applicable.

      "service": {
        "dns": {
          "forwarding": {
            "options": [

  • @james123 said in Reolink Camera wont show on Alexa TV [SOLVED]:

    /etc/init.d/dnsmasq force-reload

    Really interested in this post - i’ve got exactly the same problems with Reolink cameras, although i don’t have the same router as you. My router is a UK plusnet router, any ideas on how to get DNS binding active on that router?

    Thanks in advance,

  • I’ve been trying to set up my Hikvision cameras to be viewable from an Echo Show 8 over the past day or so and had been struggling.

    One of my cameras has audio which, whilst supposedly G711 compliant, reported a spurious codec when viewed using VLC and so I’ve resorted to using the gateway (installed as a Synology docker container) and using the @noaudio tag.

    I was still struggling though and turns out to be a DNS rebinding issue as described here. I’m running a Unifi network with USG as the router and DNS is not one of its strengths. After confirming via nslookup that it may be a rebinding issue, I’ve added a static config on the USG via SSH (set system static-host-mapping host-name <hostname> inet <ip address>) and which has solved my problem. It’s only temporary as the static config will be over-written on the next reboot/provisioning however I’ll figure out the permanent fix next.

    Video now working great via the Echo Show 8…really helpful forum post

Log in to reply