SWANN DVR RSTP feeds



  • I’ve got a Swann DVR that publishes a URL schema to view all 8 cameras on RSTP feeds. I’ve tested this all works just great with VNC etc.

    I tried hooking up Monocle and saw in the notes that the FireTV 4K stick (which is what I’m trying to view on) does not support the feed. That’s bore out with my own testing on the feeds directly as well as via the gateway.

    Looks like the video player tries to start up but does not like the data it’s getting for some reason.

    Anyone got any information on what the issue is here? It is after all a valid RSTP feed as VNC would not be able to play it. It’s all even H264 encoded, not a strage codec or anything. I’ve tried using the gateway tags to remove the audio stream too.

    Anyone got any ideas?



  • @renobrit

    Have you tried all the various tag options (including @proxy) listed on this tips page:
    https://monoclecam.com/tips

    Thanks, Robert



  • Yes, I tried all the combinations of tags and went through all the tips - with and without audio etc. The proxy works well, and the FireTV does try to connect; I see the screen initialize, but it looks like it fails when the stream starts.

    I’m a developer so can help debug it if you can point me at what to look for ? Any logs on the stick?



  • @renobrit

    Unfortunately … Alexa does not provide any logs or means to know why its failing. She is a “black box”.
    If you feel comfortable providing me temporary access to the RTSP stream over the Internet (view only), I can try a few more tricks here and see if we can find a way to make it work. You can PM (private “chat”) me here on the forum with the details.

    Thanks, Robert



  • OK great. WIll PM you.



  • any updates? ive also got a swann nvr-8000 and have been unsuccessful, i find it odd that hik nvr’s work ok, but no love for swann, i always though swann was just rebranded hik



  • @thelosticon

    No updates as of yet. I have not been able to connect to @renobrit’s stream for any further testing.

    Thanks, Robert



  • Thanks for the update. I’m sure you got your hands full but if you’re interested in troubleshooting the Swann compatibility issues any further, I have open ports on all equipment and I’d be willing to to give you admin access to nvr and rtsp feeds and even router if it’s worth pursuing.

    Also, I ran into a Reddit post from a few months back in which you were discussing the service and a user said he was successful in getting Swann to play, I was just wandering if you recall that thread and his setup

    This is the thread

    https://www.reddit.com/r/amazonecho/comments/90lygu/monocle_skill_is_the_most_amazing_echo_show/?utm_medium=android_app&utm_source=share

    Thanks again for your time,
    Edmond



  • @thelosticon

    I’d be happy to test out your streams and see if we can get a working combination going. Just PM (private chat) me the RTSP connectivity information via this forum and I should be able to take a look at it sometime next week. I should just need view only access to a stream. (public IP/hostname and port forwarded to RTSP, temporary username and password)

    In that post, (from what I remember) the user got it working with a single Swan camera, not a DVR. Now, I’m not saying that I know the technical difference and that user unfortunately did not provide the details of what he did to get it working.

    Thanks, Robert



  • I had a Swann NVR, but ditched it for a Synology and their Surveillance Station. Works with 10 SWANN cameras, including 815. cannot find the RSTP codes for them however.
    Anyone have the RSTP codes for Swann 815 and others?



  • @whalsey try the following

    rtsp://<ip>:554/h264Preview_01_main
    rtsp://<ip>:554/h264Preview_01_sub



  • By the way for anyone else running into this thread, I did eventually get the Swann nvr to show on fire stick 4k and fire tablet with @proxy gateway running, but only for sub stream, pretty low quality 640x360 but better than nothing, the 4k main feed just refuses to show up

    The URL for sub is

    rtsp://192.168.1.199:554/Streaming/Channels/402

    Obviously replace my .199 ip with your nvrs ip and whatever channels/xxx you want channels/401 would be my main feed in my example but like I said that’s the 4k resolution that won’t show for whatever reason



  • Just got my Echo Show 8, and already had a Swann DVR8-4980. I had some success after many trials, so I thought it may help others to briefly describe.

    I couldn’t get a direct connection to work at all, so I have installed Monocle Gateway to a Raspberry Pi (a version 2 model B Rev 1.1). Aside: In doing so I found that it was still on Raspbian Wheezy, which being well out of date was lacking quite a few necessaries, so I had to burn an image of Raspbian Buster to get the Monocle Gateway install to work for me.

    I tried the Tunnel tag first, but couldn’t get that to work.

    With the Proxy tag, I have the substreams working ok at 704x480. This is as high as the DVR will set the substream.

    I haven’t yet managed to get a mainstream working; I’ve set the DVR mainstream to 1920x1080 (lower resolution than my cameras), and can’t get the Echo Show to show it. Mainstream works fine in VLC.

    For this Swann device, the RTSP urls are:
    rtsp://<IP>:<Port>/ch<N>/<M>
    Where N is 1 to 8 for the camera number, and M is 0 for the mainstream or 1 for the substream
    e.g.
    rtsp://192.168.0.10:554/ch3/0

    Updated:
    I noted that the Echo Show was disconnecting after the client response for the describe, and the significant difference appeared to be the profile-level-id.
    Mainstream: profile-level-id=64001F
    Substream: profile-level-id=42001E

    Modifying the mainstream compression level and bit rate on the DVR did not change the profile-level-id. So I added the fakefmtp tag for the mainstream. This overrides the profile-level-id with 420029.

    This now has the mainstream working at fullHD.


Log in to reply