Trouble with Echo Show 2 (DE) und FireTV Stick 4K (DE), old FireTV works



  • Hello,

    thanks for this great piece of software.

    My Hardware:
    6* Wansview clone cam 1080p (rtsp://user:pass@192.168.0.20/live/ch0)
    1* Raspi 3b+ with running proxy
    2* Echo Show 2 (the new one in DE)
    2* FireTV Stick
    1* FireTV Stick 4k

    I have testet a lot of option (H264NONE1920*1080@hangup@noaudio@proxy-tcp@tunnel) with auth or not.

    the old FireTV Stick will work and the cam video start in 2seconds

    on the other device i see traffic (3Mby) and the login and the streaming request will be delivery but after a few seconds the Stick 4k and echo show 2 will without a message go to the main menu.

    the cams deliver an h264 stream with aac.

    the cams delivery only a tcp rtsp stream and when i use serviio (dlna server) i have wrote a small proxy that add a command line for “ffpmeg +tcp…” the default is udp than it works for serviio.

    now i check with wireshark the traffic between proxy on raspi and the webcam for the non working alexa devices.
    the cam will deliver the video stream and the echo abort the connection after 2,8Mby rtsp traffic.
    I have testet serveral resolution (640*360, FHD) but every time the same problem.

    using live555proxy:
    when i test with vlc i get in the log: “…/live/ch1/,MPEG4-GENERIC”
    with echo show2 log: “…/live/ch1/,X-KATA”

    thats strange. it looks like the new echo/firetv try to another codec.

    try/error in progress…
    greetings david



  • @Dave said in Trouble with Echo Show 2 (DE) und FireTV Stick 4K (DE), old FireTV works:

    I have testet serveral resolution (640*360, FHD) but every time the same problem.

    Only use one of these tags at any given time:

    • @proxy
    • @proxy-tcp
    • @tunnel

    I’m not sure what behavior will take affect if you have multiple defined. I think it will default to using @tunnel, but I’m not sure.

    Thanks, Robert



  • @Monocle
    Hi Robert,

    thanks for the hints. i try follow option (all with @noaudio)

    @tunnel
    FireTV old - work
    Echo 5 - dont work

    @proxy
    FireTV - dont work
    Echo 5 - dont work

    @proxy-tcp
    FireTV - dont work
    Echo 5 - dont work

    Greetings David



  • @Dave

    Bad news … after further testing … I can’t get my Wansview cameras working here with the new Echo Show 5 either. I have gone back and tested them on older devices and they were previously confirmed working on.

    It looks like the Wanview cameras are no longer working on the FireTV 4K, FireTV 4K Stick, FireTV Cube or the Toshiba 4K Fire Edition.

    Maybe firmware FireOS 6.2.6.4 broke support for this camera?
    It is still working on an older FireTV 4K that I have running FireOS 5.2.7.
    It is still working on my Echo Show (Gen1), Echo Show (Gen2) and Echo Spot.



  • ATTENTION
    I have posted an update on these requirements and our additional findings about the ECHO SHOW 5 here: http://monoclecam.com/echo-show-5.



  • @Monocle

    first: thanks for testing. Amazon is not a good HW supporter, so i think it will be a other CAM model if the “wansview” doesnt work anymore.
    But in the first step, i try with ffserver to build a rtsp server but i think the raspi is to slow for this, when it only works with reencode.

    Thanks and regards
    Dave


Log in to reply