Q-See not functioning in Echo Show



  • Howdy,

    Was able to get my Q-See cam’s working consistently using VLC by testing initially with OnVif Device Manager. The URL’s are: “rtsp://172.20.66.60:554/cam/realmonitor?channel=1&subtype=0&unicast=true&proto=Onvif”. VLC prompts for login and then shows the appropriate stream. I can drop both the unicast and proto types and it still works fine (and then matches most of the other cams that I use with Monocle (Amcrest IP). When I ask Alexa to show any of the Q-See devices, it blinks a couple of times and then tells me that the camera is not responding. Connecting from any other device works fine. Any ideas? Thanks in advance!

    Eric



  • @BigRic

    It could be related to the camera’s audio stream, this affect a number of cameras using Alexa. Please see this tips page for steps to try:
    https://monoclecam.com/troubleshoot/tips

    Thanks, Robert



  • Thanks, Robert. I have the audio set to “none” in the Monocle config, expecting that not using it at all would be better than having it mismatched. I don’t need the audio, so I figured this was a safe bet. Was that a mistake on my part? As an FYI, VLC shows Stream1 as audio, PCM ALAW (which is one of the reasons I left it off).



  • @BigRic

    The audio setting (“None”) does not have any impact on what the camera actually includes in its stream. This simply tells Alexa what type of audio to expect. So if the stream is emitting an incompatible audio stream, it will impact the ability for Alexa to view the stream (even with this setting as “None”).

    Some cameras allow you to disable the audio stream in their own settings, but even this is not guaranteed. For some cameras disabling the audio internally does not remove the audio stream, it just does not include any audio packets. Its worth a try if your camera supports disabling audio, but you may still have to try using Monocle Gateway and the @noaudio tag to strip out all audio descriptors from the stream.

    Thanks, Robert



  • @BigRic

    PCM ALaw is one of the flavors of the G.711 audio codec. But also (unfortunately) one Alexa commonly has problems with.



  • Did you ever get this to work? I am having the exact same issue. I have tried a few different rstp urls, all of which work fine in VLC. I have tried different combinations of gateway tags and authentication methods. Basic Auth seems to take the longest before failing so I assume that is correct and my Alexa show gets a little farther before timing out. I have one reolink IP camera what is working great. I am seriously considering switching all my cameras to those as the q-see cameras aren’t that great anyway.



  • @KewlRobD I ended up just replacing the camera with an Amcrest 4K that was on sale for $89 on Amazon. I’ve been really happy with their stuff and the camera has a much better image than the older Q-SEE.



  • @BigRic thanks for the reply. Thankfully the camera I want to view most of the time is an IP reolink and works great. It also has much better video then my analog Q-See cameras. I guess I will start replacing them with reolink cameras.


Log in to reply