Golbong IP Birdhouse camera works



  • Manufacturer:GolbongModel:4901
    rtsp://192.168.1.11:554/user=admin_password=admin_channel=1_stream=0.sdp?real_stream

    @proxy
    This is the exactly what I passed to Monocle including the user and password just as you see it above. In addition, I put the user and password in the spaces required by Monocle. This is to make it work with a Fire TV gen 3.



  • Hi Dalecway
    I am trying to set this camera up on monocle to view on Echo show 2
    Please explain the @proxy … is that on the end of the url line



  • I also have an echo show 2. The camera works fine on it too. Since you don’t understand the proxy you have some work ahead of you. I could only get this camera working using the gateway. Once the gateway is loaded, there is a place to put “tags”. On this camera you will need to use the tag @proxy.
    The gateway is not really hard to deal with and the instructions on the Monocle site are very good. Hope this helps.



  • @Dalecway
    Thanks for that. Didn’t realise you had setup the gateway.



  • The echo show is supposed to work without the gateway and it does for most of my 16 cameras but I had no luck with the golbong. I had to use the gateway for my fire tv and that turned out to work for seeing the golbong on my echo show as well. The Monocle has turned out to be a great product that I use everyday. It’s a lot of fun to just tell alexa to show a camera and see it on the echo show or on my 17 in tv using the fire stick version 3.

    Dale



  • @Graham2607

    Just for reference here is more information on setting up the Monocle Gateway:
    https://monoclecam.com/monocle-gateway

    And for tagging the cameras in the Monocle Web Portal.
    https://monoclecam.com/monocle-gateway/tagging

    The @proxy is probably overcoming some technical limitation of Alexa for this particular camera. Sadly, it’s not uncommon for some cameras to only work using @proxy or @prox-tcp. This has mostly todo with Alexa’s very picky streaming implementation and often the audio codecs.

    Thanks, Robert



  • @Dalecway
    Yes, I have an amcrest ptz, several Qvis security cameras and ring door bell 2 all working on Show 2 and fire tv without the gateway.
    I will have to spend some time sorting the gateway as that does appear to be the only option for getting the birdbox camera working on the show



  • @Dalecway
    Hi
    Been playing with the camera settings. (without the gateway)
    If I turn off the audio (uncheck the box in encode config for the camera) and use the password ‘tlJwpbo6’ (this is what ‘onvif’ says the password is) then I can now see the video on echo show 2.
    I dont understand the password (rtsp stream seems to have its own password) Logging in to the camera is still at default admin admin.
    I also found that if the audio setting on the camera is on but set to no audio in the monocle setup the camera still does not work on echo show 2
    I conclude that the issue is the audio codec. I will continue to play with the settings and give you an update.
    Regards
    Graham



  • This post is deleted!


  • @Monocle
    Hi Robert
    First I changed the password (default was null) to admin
    For your reference I have been playing with the settings on this a camera
    I have found that if audio is unchecked in the Encode Config for the camera then it works on Echo show 2 (without the gateway) configured as follows -
    rtsp://192.168.1.246:554/user=admin_password=admin_channel=1_stream=0.sdp?real_stream
    and entering user and password in fields requesting them
    It seems the audio codec is the issue for echo show 2
    Graham



  • Hi @Graham2607

    If I turn off the audio (uncheck the box in encode config for the camera) and use the password ‘tlJwpbo6’ (this is what ‘onvif’ says the password is) then I can now see the video on echo show 2.

    The audio issues/symptoms you describe are unfortunately all too common. Its probably a G.711 audio codec as Alexa seems to be very picky about those streams.

    I dont understand the password (rtsp stream seems to have its own password) Logging in to the camera is still at default admin admin.

    That is odd. Most cameras I have worked with use the same credentials for the RTSP feed as for the web admin. However, its perfectly acceptable to have separate credentials from as technical perspective.

    I also found that if the audio setting on the camera is on but set to no audio in the monocle setup the camera still does not work on echo show 2
    I conclude that the issue is the audio codec. I will continue to play with the settings and give you an update.

    The audio codec setting in the Monocle Web Portal is only instructing Alexa on what type of audio to expect. It does not have any impact on the actual stream or audio channel unless using the Monocle Gateway. (Note: If you are using the Monocle Gateway and the camera audio codec in the Monocle Web Portal is set to “NONE”, then the gateway will strip out the audio channel.)

    Thanks, Robert



  • @Monocle
    Hi Robert … mystery of the password solved.
    In fact the password was blank (null).
    Why onvif said it was ‘tlJwpbo6’ I have no idea or why it worked with that.
    I reset password to ‘admin’ and used that and all is well (without the gateway and without the audio)

    Kindest Regards
    Graham


Log in to reply