Gateway does not work - what can I do?



  • Hi there,

    unfortunately my gateway does not work. I installed it and did everything according to the installation guide for raspberry.
    I am using the echo show 5, raspberry 3+ and the ip camera from wanted, type called “monolith”:

    b87ab181-df9b-43e2-86ad-051c6042fbe3-image.png

    At point 5 from the installer guide (“monocle-gateway --tail”) the following error message appears:

    29ad12fd-1683-4b67-bb04-4916ea5bfcbd-image.png

    Could anybody give me a hint what I can do? Your help is much appreciated…

    Many thanks
    Walter



  • @Walter

    It looks like some prerequisite is causing a problem.

    Lets see if it installed the executables and try running the executable directly. If we can get it working running the executables standalone, then we can figure out the service/daemon issue.

    If we use the following command:

    ls /usr/local/bin/monocle*
    

    we should see two executables:

    /usr/local/bin/monocle-gateway  /usr/local/bin/monocle-proxy
    

    First, lets make sure the service/daemon is stopped – just in case —

    sudo monocle-gateway --stop
    

    You can run the monocle-gateway executable directly by just using the following command:

    sudo monocle-gateway
    

    You should see something like:

    ******************************************************************
     *             __  __  ___  _  _  ___   ___ _    ___              *
     *            |  \/  |/ _ \| \| |/ _ \ / __| |  | __|             *
     *            | |\/| | (_) | .` | (_) | (__| |__| _|              *
     *            |_|  |_|\___/|_|\_|\___/ \___|____|___|             *
     *                                                                *
     ******************************************************************
    
    -------------------------------------------------
    MONOCLE RUNTIME ENVIRONMENT
    -------------------------------------------------
    VERSION   = 0.0.4
    OS/ARCH   = linux/arm
    PROCESS   = monocle-gateway (PID=31590)
    TIMESTAMP = 2019-07-25T17:28:46.374Z
    
    -------------------------------------------------
    MONOCLE GATEWAY SERVICE         (Version: 0.0.4)
    -------------------------------------------------
    [Monocle Starting]
    [Monocle Connecting]
    [Monocle Started]
    [RTSP Server Starting]
    [RTSP Server Listening] 0.0.0.0:8555 (RTSP)
    [RTSP Server Listening] 0.0.0.0:443 (RTSP-TLS)
    [RTSP Proxy Started] (PID=31599)
    [RTSP Server Listening] 0.0.0.0:8554 (PROXY)
    [RTSP Server Started]
    

    Copy and paste what output you get to this thread and I can review it.

    Thanks, Robert



  • @Monocle said in Gateway does not work - what can I do?:

    sudo monocle-gateway

    Hello Robert,

    thank you four your reply - I did as you said and I get the following output:

    e097ad91-2acd-4f94-a9f8-9952dc570d74-image.png

    I hope you can review it and we find out how to get it run.

    Many Thanks!

    Best regards,
    Walter



  • @Walter

    OK, that is odd. Is this Pi running the latest Raspbian? I have not tested the latest build that was just released along with the RPi 4B yet.

    Can you run this command and show what it includes?

    ls /etc/monocle/
    

    Thanks, Robert



  • @Monocle said in Gateway does not work - what can I do?:

    ls /etc/monocle/

    Hello Robert,

    yes, it is the latest version Raspian Buster. This is what I get:

    62bae754-6731-48e6-a97b-5d69ebab242b-image.png

    Thanks, Walter



  • @Walter

    OK, let me set this up on latest Buster image and see if I get the same failure and can then get it resolved.

    Thanks, Robert



  • @Walter

    OK, I was able to reproduce a similar error. Although it may have been because I did not have a monocle.token file in place when the service was installed.

    After making sure my monocle.token file did exist at /etc/monocle/monocle.token and making sure that file did contain valid token data (file was not empty), I was able to use the following commands to get the daemon updated on the system and working:

    First, I used the --uninstall flag to remove the daemon/systemd config

    sudo monocle-gateway --uninstall
    

    Next, I used the --install flag to reinstall the daemon/systemd config

    sudo monocle-gateway --install
    

    And finally, I was able to start and view the Monocle Gateway

    monocle-gateway --restart
    monocle-gateway --tail
    

    If you are still getting those “condition check” errors, use this command and post what it prints out:

    systemctl status monocle-gateway.service
    

    As for this specific error:

     ******************************************************************
     *             __  __  ___  _  _  ___   ___ _    ___              *
     *            |  \/  |/ _ \| \| |/ _ \ / __| |  | __|             *
     *            | |\/| | (_) | .` | (_) | (__| |__| _|              *
     *            |_|  |_|\___/|_|\_|\___/ \___|____|___|             *
     *                                                                *
     ******************************************************************
    
    pkg/prelude/bootstrap.js:1183
          throw error;
          ^
    
    Error: EISDIR: illegal operation on a directory, read
        at Object.fs.readSync (fs.js:634:3)
        at Object.fs.readSync (pkg/prelude/bootstrap.js:555:32)
        at tryReadSync (fs.js:474:20)
        at Object.fs.readFileSync (fs.js:515:19)
        at Object.fs.readFileSync (pkg/prelude/bootstrap.js:684:36)
        at Object.<anonymous> (/snapshot/monocle-gateway/lib/monocle/MonocleGateway.js:1:2954)
        at Module._compile (pkg/prelude/bootstrap.js:1259:22)
        at Object.Module._extensions..js (internal/modules/cjs/loader.js:711:10)
        at Module.load (internal/modules/cjs/loader.js:610:32)
        at tryModuleLoad (internal/modules/cjs/loader.js:549:12)
    

    I get this if the /etc/monocle/monocle.token path is a directory and not a file. It should be a file.

    You can list the path like this and make sure its a file.

    ls -la /etc/monocle/
    
    total 16
    drwxrwxr-x   3 root monocle 4096 Jul 26 16:37 .
    drwxr-xr-x 109 root root    4096 Jul 26 16:13 ..
    -rw-r--r--   1 root root     285 Jul 26 16:14 monocle.token
    

    Using the file command the output should not be a “directory”.

    file /etc/monocle/monocle.token
    /etc/monocle/monocle.token: directory
    

    Using the file command the output should be a “ASCII text” file.

    file /etc/monocle/monocle.token
    /etc/monocle/monocle.token: ASCII text
    

    Thanks, Robert


Log in to reply