Raspbian Buster & RPi4 for Gateway? [ANSWERED]



  • Has anybody tried or know if Monocle Gateway will run on the new RPi 4 w/ Buster? I’ve got one on the way and was hoping to improve some buffering issues I am receiving. Just tried out this excellent software today with an Amcrest NVR. Very nice job!



  • @AMDPower

    Yes, I just installed and ran the Monocle Gateway on a Raspberry Pi 4B today running the latest Raspbian distribution.
    It seemed to work just fine. Although, make sure to create the /etc/monocle/monocle.token file before installing otherwise its gets into some weird state on daemon startup.

    Unfortunately the buffering issues are mostly decoding problems with Alexa. What camera make and model is it? You can try adding the tag @noaudio to strip out the audio channel, this sometimes improves buffing issues with certain audio codecs.

    Other tips for buffering issues would be to avoid WiFi connected cameras and use wired Ethernet where possible. Use wired Ethernet for the Monocle Gateway. Optionally use the lower resolution (secondary) sub-stream (most cameras support a sub-stream.) Try playing with the H.264 profiles and H.264+ settings. Disable audio or play with audio codec settings.

    Lowering the audio sampling frequency to 8K was crucial on some of the older Amcrest cameras to reduce buffering.

    a2940dc9-abd5-4b5e-80d6-acdf7b1962e3-image.png

    Thanks, Robert



  • Thanks for the information. I have a variety of cameras but they are proxied through my Amcrest NVR which is accessed through a single RTSP address and then channel number. It’s weird because even switching to the secondary stream @ 640x360 caused some buffering. I’ll give the @noaudio a go. Thanks!



  • @AMDPower

    I updated my previous post with some additional info and tips.

    Thanks, Robert



  • @AMDPower said in Raspbian Buster & RPi4 for Gateway?:

    It’s weird because even switching to the secondary stream @ 640x360 caused some buffering. I’ll give the @noaudio a go. Thanks!

    Yes, I have seen this too on some cameras. Definitely try the @noaudio tag … Alexa really has compatibility issues with many audio streams.


Log in to reply