the camera does not respond



  • I have used the guide to install everything
    I use Foscam FI9900P and Echo Show 5
    I think that all is correct but I get the message: the camera does not respond

    What i can do more

    MONOCLE RUNTIME ENVIRONMENT
    Aug 01 19:52:13 raspberrypi3 monocle-gateway[9821]: -------------------------------------------------
    Aug 01 19:52:13 raspberrypi3 monocle-gateway[9821]: VERSION = 0.0.4
    Aug 01 19:52:13 raspberrypi3 monocle-gateway[9821]: OS/ARCH = linux/arm
    Aug 01 19:52:13 raspberrypi3 monocle-gateway[9821]: PROCESS = monocle-gateway (PID=9821)
    Aug 01 19:52:13 raspberrypi3 monocle-gateway[9821]: TIMESTAMP = 2019-08-01T17:52:13.541Z
    Aug 01 19:52:13 raspberrypi3 monocle-gateway[9821]: -------------------------------------------------
    Aug 01 19:52:13 raspberrypi3 monocle-gateway[9821]: MONOCLE GATEWAY SERVICE (Version: 0.0.4)
    Aug 01 19:52:13 raspberrypi3 monocle-gateway[9821]: -------------------------------------------------
    Aug 01 19:52:13 raspberrypi3 monocle-gateway[9821]: [Monocle Starting]
    Aug 01 19:52:13 raspberrypi3 monocle-gateway[9821]: [Monocle Connecting]
    Aug 01 19:52:13 raspberrypi3 monocle-gateway[9821]: [Monocle Started]
    Aug 01 19:52:13 raspberrypi3 monocle-gateway[9821]: [RTSP Server Starting]
    Aug 01 19:52:13 raspberrypi3 monocle-gateway[9821]: [RTSP Server Listening] 0.0.0.0:8555 (RTSP)
    Aug 01 19:52:13 raspberrypi3 monocle-gateway[9821]: [RTSP Server Listening] 0.0.0.0:443 (RTSP-TLS)
    Aug 01 19:52:13 raspberrypi3 monocle-gateway[9821]: [RTSP Proxy Started] (PID=9844)

    Aug 01 19:52:13 raspberrypi3 monocle-gateway[9821]: [RTSP Server Listening] 0.0.0.0:8554 (PROXY)
    Aug 01 19:52:13 raspberrypi3 monocle-gateway[9821]: [RTSP Server Started]
    Aug 01 19:52:14 raspberrypi3 monocle-gateway[9821]: [Monocle Connected]
    Aug 01 19:52:14 raspberrypi3 monocle-gateway[9821]: [RTSP Server Registered]
    Aug 01 19:52:14 raspberrypi3 monocle-gateway[9821]: -------------------------------------------------
    Aug 01 19:52:14 raspberrypi3 monocle-gateway[9821]: MONOCLE RTSP SERVICE - INITIALIZED
    Aug 01 19:52:14 raspberrypi3 monocle-gateway[9821]: -------------------------------------------------
    Aug 01 19:52:14 raspberrypi3 monocle-gateway[9821]: FQDN = 362d2ef6-ad45-47f3-93a5-b4c4aeb00be4.mproxy.io
    Aug 01 19:52:14 raspberrypi3 monocle-gateway[9821]: HOST = 192.168.178.68
    Aug 01 19:52:14 raspberrypi3 monocle-gateway[9821]: PORT = 443
    Aug 01 19:52:14 raspberrypi3 monocle-gateway[9821]: -------------------------------------------------
    Aug 01 19:52:56 raspberrypi3 monocle-gateway[9821]: -------------------------------------------------
    Aug 01 19:52:56 raspberrypi3 monocle-gateway[9821]: INITIALIZE RTSP STREAM: Haustür
    Aug 01 19:52:56 raspberrypi3 monocle-gateway[9821]: -------------------------------------------------
    Aug 01 19:52:56 raspberrypi3 monocle-gateway[9821]: - NAME : Haustür
    Aug 01 19:52:56 raspberrypi3 monocle-gateway[9821]: - LABEL : PRIMARY
    Aug 01 19:52:56 raspberrypi3 monocle-gateway[9821]: - URL : rtsp://192.168.178.41:89/videoMain
    Aug 01 19:52:56 raspberrypi3 monocle-gateway[9821]: - UUID : STREAM:8cea7f46-c0a6-4022-a9b7-e6550b0b3d8f
    Aug 01 19:52:56 raspberrypi3 monocle-gateway[9821]: - SESS : ad893499-5865-4cf4-8bbc-a512f9043ddd
    Aug 01 19:52:56 raspberrypi3 monocle-gateway[9821]: - MODIF : Thu Aug 01 2019 18:04:09 GMT+0200 (CEST)
    Aug 01 19:52:56 raspberrypi3 monocle-gateway[9821]: - TAGS : @tunnel
    Aug 01 19:52:56 raspberrypi3 monocle-gateway[9821]: -------------------------------------------------
    Aug 01 19:52:59 raspberrypi3 monocle-gateway[9821]: -------------------------------------------------
    Aug 01 19:52:59 raspberrypi3 monocle-gateway[9821]: INITIALIZE RTSP STREAM: Haustür
    Aug 01 19:52:59 raspberrypi3 monocle-gateway[9821]: -------------------------------------------------
    Aug 01 19:52:59 raspberrypi3 monocle-gateway[9821]: - NAME : Haustür
    Aug 01 19:52:59 raspberrypi3 monocle-gateway[9821]: - LABEL : PRIMARY

    Aug 01 19:52:59 raspberrypi3 monocle-gateway[9821]: - URL : rtsp://192.168.178.41:89/videoMain
    Aug 01 19:52:59 raspberrypi3 monocle-gateway[9821]: - UUID : STREAM:8cea7f46-c0a6-4022-a9b7-e6550b0b3d8f
    Aug 01 19:52:59 raspberrypi3 monocle-gateway[9821]: - SESS : 28e49077-e814-4e54-a925-9e43f57f7750
    Aug 01 19:52:59 raspberrypi3 monocle-gateway[9821]: - MODIF : Thu Aug 01 2019 18:04:09 GMT+0200 (CEST)
    Aug 01 19:52:59 raspberrypi3 monocle-gateway[9821]: - TAGS : @tunnel
    Aug 01 19:52:59 raspberrypi3 monocle-gateway[9821]: -------------------------------------------------
    Aug 01 19:53:01 raspberrypi3 monocle-gateway[9821]: -------------------------------------------------
    Aug 01 19:53:01 raspberrypi3 monocle-gateway[9821]: INITIALIZE RTSP STREAM: Haustür
    Aug 01 19:53:01 raspberrypi3 monocle-gateway[9821]: -------------------------------------------------
    Aug 01 19:53:01 raspberrypi3 monocle-gateway[9821]: - NAME : Haustür
    Aug 01 19:53:01 raspberrypi3 monocle-gateway[9821]: - LABEL : PRIMARY

    Aug 01 19:53:01 raspberrypi3 monocle-gateway[9821]: - URL : rtsp://192.168.178.41:89/videoMain
    Aug 01 19:53:01 raspberrypi3 monocle-gateway[9821]: - UUID : STREAM:8cea7f46-c0a6-4022-a9b7-e6550b0b3d8f
    Aug 01 19:53:01 raspberrypi3 monocle-gateway[9821]: - SESS : bc7a251e-fc0a-4ef8-9c33-bdad68d43a05
    Aug 01 19:53:01 raspberrypi3 monocle-gateway[9821]: - MODIF : Thu Aug 01 2019 18:04:09 GMT+0200 (CEST)
    Aug 01 19:53:01 raspberrypi3 monocle-gateway[9821]: - TAGS : @tunnel



  • @pfeffi

    I bet you are using a Fritzbox? Did I get that right? 🙂



  • yes I do Fritzbox 7590
    why, is it a problem



  • @pfeffi

    I need to do a special write up just for the Fritzbox. You can search the forums here for “Fritzbox” and you can find more in-depth details and diagnostics testing that has been done in the past. Long story short … the Fritzbox routers BLOCKs DNS resolution for DNS hostnames that resolve to internal/private IP addresses. This is called DNS REBINDING. You can see some information on our site about it here: https://monoclecam.com/monocle-gateway/troubleshooting/dns-rebinding

    Basically, the Alexa devices are provided a publicly resolvable DNS hostname that it intended to resolve back to your local/internal Monocle Gateway instances. However the router is blocking the DNS request and the Alexa devices don’t know where to make the request. We have to use publicly resolvable DNS hostnames because of the Amazon requirements for SSL/TLS encryption.

    I don’t personally know the actual method to allow this on the Fritzbox, but others here on the forum have been successful. When the Monocle Gateway starts it prints out this line:

    Aug 01 19:52:14 raspberrypi3 monocle-gateway[9821]: -------------------------------------------------
    Aug 01 19:52:14 raspberrypi3 monocle-gateway[9821]: MONOCLE RTSP SERVICE - INITIALIZED
    Aug 01 19:52:14 raspberrypi3 monocle-gateway[9821]: -------------------------------------------------
    Aug 01 19:52:14 raspberrypi3 monocle-gateway[9821]: FQDN = 362d2ef6-ad45-47f3-93a5-b4c4aeb00be4.mproxy.io
    Aug 01 19:52:14 raspberrypi3 monocle-gateway[9821]: HOST = 192.168.178.68
    

    The line with the “FQDN” is the DNS hostname assigned to your gateway instance. That is the one that you need to allow Fritz to pass. Its trying to resolve to IP address 192.168.178.68, so make sure that is the correct IP address as well.

    Thanks, Robert



  • okay, the Fritzbox for dns-rebind set up
    and monocle-gateway --tail

    : INITIALIZE RTSP STREAM: Garten
    : ----------------------------------- --------------
    : - NAME: Garten
    : - LABEL: PRIMARY
    : - url: rtsp: //192.168.178.39: 88 / videoMain
    : - UUID: STREAM: de9d1202-87ac-4af3-a1a2-15d3cc7cadbb
    : - SESS: 7d91ba9c-78b8-48f1-b6b5-c4ec1f0cedae
    
    : - MODIF: Fri Aug 02 2019 11:39:40 GMT + 0200 (CEST)
    : - TAGS: @ noaudio, @ proxy-tcp
    : ----------------------------------- --------------
    : 2019-08-02T09: 56: 01.623Z [INFO] [RTSP PROXY] REGISTERING STREAM [Garden / PRIMARY]; (STREAM: de9d1202-87ac-4af3-a1a2-15d3cc7cadbb)
    
    : 2019-08-02T09: 56: 01.628Z [DEBUG] <RTSP-PROXY> [REQUEST] -> [REGISTER] rtsp: //192.168.178.39: 88 / video main
    : 2019-08-02T09: 56: 01.629Z [TRACE] <RTSP-PROXY> [REQUEST] -> [HEADERS] {
    : "cseq": "1",
    
    : "transport": "reuse_connection = 0; preferred_delivery_protocol = interleaved; proxy_url_suffix = STREAM: de9d1202-87ac-4af3-a1a2-15d3cc7cadbb; username = pfeffi; password = enibas56"
    :}
    
    : 2019-08-02T09: 56: 01.631Z [DEBUG] <RTSP-PROXY> [RESPONSE] <- [200 (OK)] <cseq = 1> (session = undefined)
    : 2019-08-02T09: 56: 01.632Z [TRACE] <RTSP-PROXY> [RESPONSE] <- [HEADERS] {
    : "cseq": "1",
    : "date": "Fri, Aug 02 2019 09:56:01 GMT"
    
    :}
    
    : ----------------------------------- --------------
    
    : INITIALIZE RTSP STREAM: Garten
    : ----------------------------------- --------------
    : - NAME: Garten
    : - LABEL: PRIMARY
    : - url: rtsp: //192.168.178.39: 88 / videoMain
    
    : - UUID: STREAM: de9d1202-87ac-4af3-a1a2-15d3cc7cadbb
    A: - SESS: 0ee25f02-79b5-4a10-9dd7-381c09653135
    : - MODIF: Fri Aug 02 2019 11:39:40 GMT + 0200 (CEST)
    
    : - TAGS: @ noaudio, @ proxy-tcp
    A: ----------------------------------- --------------
    
    : 2019-08-02T09: 56: 04.120Z [INFO] [RTSP PROXY] STREAM [Front Door / PRIMARY] WILL BE DE-REGISTERED IN 4 MINUTES
    
    : 2019-08-02T09: 56: 04.120Z [INFO] [RTSP PROXY] STREAM [Garten / PRIMARY] WILL BE DE-REGISTERED IN 4 MINUTES
    : ----------------------------------- --------------
    : INITIALIZE RTSP STREAM: Garten
    : ----------------------------------- --------------
    : - NAME: Garten
    : - LABEL: PRIMARY
    : - url: rtsp: //192.168.178.39: 88 / videoMain
    : - UUID: STREAM: de9d1202-87ac-4af3-a1a2-15d3cc7cadbb
    
    : - SESS: dc51af01-84a8-4807-8bc8-88bb8bbdec62
    : - MODIF: Fri Aug 02 2019 11:39:40 GMT + 0200 (CEST)
    : - TAGS: @ noaudio, @ proxy-tcp
    : ----------------------------------- --------------
    

    shows me something more
    but does not work despite everything

    sudo ping 362d2ef6-ad45-47f3-93a5-b4c4aeb00be4.mproxy.io
    ping: 362d2ef6-ad45-47f3-93a5-b4c4aeb00be4.mproxy.io: There is no address for this hostname

    okay, have a success
    the wildcard *.mproxy.io in the fritzbox does not work
    I have to enter the full address, then it works
    I think it is not your problem



  • @pfeffi said in the camera does not respond:

    y.io in the fritzbox does not work
    I have to enter the full address, then it works
    I think it is not your problem

    We are still no seeing the incoming TCP requests in the log from the Alexa devices. It will be obvious in the log and there will be many many more lines of information.

    You might need to reboot Alexa after you allow the DNS REBIND on the Fritzbox. She seems to cache DNS entries for a long time and the reboot can help flush the cache.

    Thanks, Robert



  • Thanks for the hint. Now with the DNS entry in my fritzbox its working!
    But now i want to run Monocle on Docker with a different IP.
    What networking modes/drivers i should use and how to configure my Fritzbox.

    Thanks! 🙂



  • @jannnfe

    Please see:

    You can move your existing gateway with the same monocke.token file into a docker container. If you keep the same monocle.token file, your DNS hostname will stay the same. When a new IP is registered, it will get updated in the public DNS registry and will get propagated across the Internet. This may take several minutes or up to an hour to propagate. You may have to reboot your Alexa devices to get the updated IP as Alexa seems to cache DNS entries for a long time.

    You can also generate a new token file to speed the migration up, but then you would also need to update Fritz with a new DNS hostname.

    Thanks, Robert


Log in to reply