Annke N48PAW NVR



  • Hi, any ideas how i get this to stream to a show 5? I’ve found the rtsp stream and this works fine on the vlc view, ive downloaded and run the gateway added the camera etc in alexa but when trying to show the camera the only response i get is the camera isnt repsonding

    command promt shows this
    3c83d3f4-12e5-40b1-9f69-3f83263fa61e-image.png

    camera setup in is
    93fa3c3e-d8a7-43e7-93e7-37acdd0189dd-image.png

    Thanks



  • @mightyjoe

    Are there any errors in the log when Monocle Gateway starts up?

    Most times when you only get the “INITIALIZE RTSP STREAM:” message and you don’t see any TCP connections after that from the Alexa device, it comes down to just a few things.

    • DNS REBINDING (This is usually the problem)
      https://monoclecam.com/monocle-gateway/troubleshooting/dns-rebinding

    • FIREWALL
      Is a local firewall blocking access to port 443 on the Monocle Gateway computer. Alexa devices inside your LAN will need to access this port.

    • IP ADDRESS
      When Monocle Gateway starts up, it prints out the auto-detected IP address from the local machine (listed as “HOST”) in the log file. Make sure this is the correct IP address where the Alexa devices can access.

    • VLAN/GUEST NETWORK
      If your Alexa devices are on a separate VLAN or Guest WIFI network, they will need to be able to access the Monocle Gateway host. Guest networks often restrict access to local network nodes.

    Thanks, Robert



  • Hi, having had chance to look at this it does appear to be the DNS rebinding issue, having had a dig around it appears that my modem/router doesn’t allow me resolve this, any recommendations on a good router/modem that will allow me to solve this, im on BT infinity using their standard hub5 at the moment



  • @mightyjoe

    Other potential workarounds:

    1.) If you router provides the ability to either run a DNS server or DNS forwarder, it might provide the ability for you to define fixed DNS hostnames. If it does you can simply define your gateway’s unique *.mproxy.io DNS hostname and map it to your local IP address of the gateway.

    2.) If you router allows you to override and assign specific DNS servers to the DHCP clients, you may be able to simply set a public DNS server such as Google (8.8.8.8, 8.8.4.4) as the default DNS server to be given to devices on your network. (rather than the router acting as the DNS server/forwarder)

    3.) You can run your own DNS server such as PiHole and manually define the DNS entry for your gateway. You would need to configure your router’s DHCP server to give out the address of this DNS server.

    4.) If you can expose port 443 on your router and forward that internally to the gateway, this could be an option. Some ISP don’t allow serving on port 443, so you might have to check that. Some custom configuration will also be needed for Monocle Gateway to associate your public IP address with the gateway’s unique *.mproxy.io DNS hostname. (Not, this solution is not ideal long term, because it is exposing port 443 outside your private network – but may be temporarily suitable for testing.)

    Hi, having had chance to look at this it does appear to be the DNS rebinding issue, having had a dig around it appears that my modem/router doesn’t allow me resolve this, any recommendations on a good router/modem that will allow me to solve this, im on BT infinity using their standard hub5 at the moment

    To specially answer your question, I’m not sure I have a suggestion for what would be best in the UK under BT ISP. I personally use a PFSense router as it affords a ton of customization features and is a bit more robust than an off the shelf router. Of course that also comes with more complexity 🙂


Log in to reply