Picture degradation



  • I am using Monocle with the gateway running on my windows laptop in order to stream video from Jennov 1080p Wifi cameras. I have a strong wifi coverage and a robust video stream when seen on laptop, phone app and NVR screens.

    When I connect with my Echo Show 5s though the video is fine only for about 6-7 seconds then it starts flicker and turns all grey, then light purple at the end.
    This happens in all 8 IP cameras to all 4 of my Echo Show 5s I have at home.

    Oh, and I had to change tag to @proxy because @tunnel did not work for me.

    Any ideas???

    Thank You in advance for your help!

    /Dimi



  • @Dimitris76

    Most likely the Alexa device does not like something about the video encoding. So it may be a bit of trial and error to adjust video codec settings directly on your camera and see if you can find a working combination. Try switching H.264 profiles, try enabling/disabling H.264+ if that is an option for this camera. Try changing bitrates and resolutions.

    Another quick option to try is to just add the @noaudio tag to this camera in the Monocle Web Portal. Sometimes Alexa had issues with certain audio streams and can cause buffering and other streaming issues and disconnects shortly after starting a stream. Try this even if you camera does not have audio enables or supports audio. Some cameras include an empty audio channel.

    Thanks, Robert



  • Monocle,

    Thank you for your answer!

    I copy/pasted the stream URL to VLC-player and saw on the codec info that the audio stream my camera outputs is “aLaw”. That’s a G711 type of codec, isn’t it?

    The reason I am asking is because I have the cameras audio codec set as AAC right now in Monocle account and the audio still works!

    /Dimi



  • @Dimitris76

    Yes, aLaw, mLaw and uLaw are all forms of G.711.

    The video codec, audio codec, resolution, etc configured via the Monocle Web Portal all provide this information to Alexa before she attempts to stream. However, I don’t think she really cares (at this time) as she seem to work even with incorrect settings. So I think these are hints, but Alexa figures out all the legitimate details when the stream starts.

    With that said, definitely try the @noaudio tag along with your existing @proxy tag. The G711 audio codec is one that Alexa seems to struggle more with.

    Thanks, Robert



  • Monocle,

    will try the @noaudio tag when I get home and post my results here.

    /Dimi



  • Well… I tested all possible tag combinations

    @proxy, @noaudio
    @tunnel
    @tunnel, @noaudio
    @proxy-tcp
    @proxy-tcp, @noaudio

    and nothing worked… 😞

    I am back to @proxy that gives me 5-7 sceonds worth of footage and hope someone comes up with a solution to this problem.


Log in to reply