Gateway / Fire Tablet Problem



  • Amcrest IP2M-841
    Fire Tablet 8 (2018) with Show Mode
    Monocle Gateway

    Set up cameras in Monocle and tested the RTSP addresses using VLC. Verified H264 and AAC. Attempting to run

    • @tunnel (Nothing happens in the gateway at all)
    • @tunnel, @noaudio (Nothing happens in the gateway at all)
    • @proxy (I get some stuff back, but no stream)
    • @proxy, @noaudio (I get some stuff back, but no stream)

    Running the Authentication in BASIC because DIGEST kicks up an error that goes away in BASIC.

    [RESPONSE] <-- [415 (Invalid parameter)]
    

    Setup in Monocle Dashboard:

    Jasper Camera
    Jasper Bedroom
    Manufacturer: Amcrest Model: IP2M-841
    rtsp://192.168.1.51:554/cam/realmonitor?channel=1&subtype=0
    Last Viewed: Wed Aug 07 2019 18:47:45 GMT+0000 (UTC)
    BASIC H264 AAC 1920*1080 @proxy
    

    So here is the full information is spits out:

    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Jasper Camera
    -------------------------------------------------
     - NAME  : Jasper Camera
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.1.51:554/cam/realmonitor?channel=1&subtype=0
     - UUID  : STREAM:db8a014b-6ab6-4233-be1a-c6e5e4e1d946
     - SESS  : b05c4e7c-d4b5-4416-a0c7-f6f6e0b2278d
     - MODIF : Wed Aug 07 2019 13:51:56 GMT-0500 (Central Daylight Time)
     - TAGS  : @proxy
    -------------------------------------------------
    
    2019-08-07T19:03:57.072Z [INFO]  [RTSP PROXY] REGISTERING STREAM [Jasper Camera/PRIMARY]; (STREAM:db8a014b-6ab6-4233-be1a-c6e5e4e1d946)
    2019-08-07T19:03:57.079Z [DEBUG] <RTSP-PROXY> [REQUEST]  --> [REGISTER] rtsp://192.168.1.51:554/cam/realmonitor?channel=1&subtype=0
    2019-08-07T19:03:57.080Z [TRACE] <RTSP-PROXY> [REQUEST]  --> [HEADERS] {
      "cseq": "1",
      "transport": "reuse_connection=0;preferred_delivery_protocol=udp;proxy_url_suffix=STREAM:db8a014b-6ab6-4233-be1a-c6e5e4e1d946;username=BYE;password=FELICIA"
    }
    2019-08-07T19:03:57.082Z [DEBUG] <RTSP-PROXY> [RESPONSE] <-- [200 (OK)] <cseq=1> (session=undefined)
    2019-08-07T19:03:57.083Z [TRACE] <RTSP-PROXY> [RESPONSE] <-- [HEADERS] {
      "cseq": "1",
      "date": "Wed, Aug 07 2019 19:03:57 GMT"
    }
    }
    
    

    After a minute or so, it then reports:

    2019-08-07T19:04:45.753Z [INFO]  [RTSP PROXY] STREAM [Jasper Camera/PRIMARY] WILL BE DE-REGISTERED IN 4 MINUTES
    

    I’m not finding anyplace else I can go from here. Can anyone advise?



  • @stardeo

    What type of router do you have? Looks like the Alexa devices are not establishing TCP connections to the gateway after you request a camera stream.
    Some routers block DNS REBINDING, See here: https://monoclecam.com/monocle-gateway/troubleshooting/dns-rebinding and also search the forums for “DNS REBINDING”.

    Are your Alexa devices attached to the same network? Not a GUEST network or VLAN that is isolated from the gateway?

    If you are running the gateway on Windows or OSX check the Firewall settings and try disabling it while testing.

    Thanks, Robert



  • Ack! I did forget to include that information. My apologies.

    I have a Netgear Nighthawk X6 R7900. I reviewed the DNS REBINDING document in troubleshooting when doing setup. I tested my DNS name using ping and was able to resolve the address.

    The devices are all attached to the same network. I even ensured they were both on 2.4. I don’t have a guest or vlan set up.

    On the windows machine in question, the firewall is disabled to make sure it wasn’t blocking the connection either to the gateway.

    It’s strange because from the old forum notes it seems people have good luck with Amcrest cameras.



  • @stardeo

    Yes, I run mostly Amcrest cameras here with little to no issues. In fact, I have two cameras of that exact model. (I don’t however have a Fire 8 Tablet.)

    Based on the log info, at this point I think we have some network issue and not a camera issue.

    By the way, for this camera, I use the following settings:

    f9ecab89-4cbc-460c-bf44-9921d6a9293d-image.png

    Please note, the audio settings are important for this model. If the “Sampling Frequency” is higher, I get BUFFERING issues with Alexa viewing the stream.

    ba3213ac-6e78-4b99-9f95-44bfc6ce4176-image.png

    Also, I only use the “@tunnel” tag for all my Amcrest cameras.

    a06bacca-61e1-4a51-801a-31bf62b16b8d-image.png



  • @Monocle

    Also, make sure you are running the latest firmware on these older models. I remember upgrading mine a year or so ago.

    Try with the @tunnel tag and then copy the log output here so I can review it. In fact, go ahead and restart the monocle gateway then ask Alexa for the camera stream. I would like to see the log data include the startup information as well as the camera request and any RTSP streaming log info.

    Thanks, Robert



  • Thanks for the help! I checked my camera settings and it appears that they are correct. I then checked the firmware. Yikes…out of date:
    OLD: 2.520.AC00.18.R, Build Date: 2017-06-29
    NEW: V2.420.AC00.18.R, Build Date: 2019-08-03

    I then booted up the Monocle Gateway. I asked for the Jasper Camera and got this, but no stream started and eventually Alexa gave up.

    ******************************************************************
     *             __  __  ___  _  _  ___   ___ _    ___              *
     *            |  \/  |/ _ \| \| |/ _ \ / __| |  | __|             *
     *            | |\/| | (_) | .` | (_) | (__| |__| _|              *
     *            |_|  |_|\___/|_|\_|\___/ \___|____|___|             *
     *                                                                *
     ******************************************************************
    
    
    -------------------------------------------------
    MONOCLE RUNTIME ENVIRONMENT
    -------------------------------------------------
    VERSION   = 0.0.4
    OS/ARCH   = win32\x64
    PROCESS   = monocle-gateway (PID=6076)
    TIMESTAMP = 2019-08-08T19:46:47.399Z
    
    -------------------------------------------------
    MONOCLE GATEWAY SERVICE         (Version: 0.0.4)
    -------------------------------------------------
    [Monocle Starting]
    [Monocle Connecting]
    [Monocle Started]
    [RTSP Server Starting]
    [RTSP Server Listening] 0.0.0.0:8555 (RTSP)
    [RTSP Server Listening] 0.0.0.0:443 (RTSP-TLS)
    [RTSP Proxy Started] (PID=1704)
    [RTSP Server Listening] 0.0.0.0:8554 (PROXY)
    [RTSP Server Started]
    [Monocle Connected]
    [RTSP Server Registered]
    
    -------------------------------------------------
    MONOCLE RTSP SERVICE - INITIALIZED
    -------------------------------------------------
    FQDN = a66e33c4-896b-4134-9b73-232ffae749f5.mproxy.io
    HOST = 192.168.1.95
    PORT = 443
    -------------------------------------------------
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Jasper Camera
    -------------------------------------------------
     - NAME  : Jasper Camera
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.1.51:554/cam/realmonitor?channel=1&subtype=0
     - UUID  : STREAM:db8a014b-6ab6-4233-be1a-c6e5e4e1d946
     - SESS  : 5d6f291f-82a8-4a3c-9386-c1433807ade9
     - MODIF : Thu Aug 08 2019 14:46:42 GMT-0500 (Central Daylight Time)
     - TAGS  : @tunnel
    -------------------------------------------------
    

    I think I’m done chasing this at the moment. I really do appreciate the help and will be glad to give more information if it can help Monocle grow. Best of luck!



  • @stardeo ,

    OK, no problem at all. Just let me know if you want to pursue this again down the road.

    It looks like some sort of networking issue where the Alexa device is unable to connect to the Monocle Gateway. We would expect additional line of information in the log when Alexa attempts to connect and start the RTSP session.

    Thanks, Robert


Log in to reply