Cannot get Echo Show 5 working with Foscam FI9821P V3



  • I am able to connect via VLC. I have the gateway running. I tried BASIC and DIGEST auth types and made a simple password. Gateway running from Admin CMD prompt. Video set to 720 in account. Get these results:

    Microsoft Windows [Version 10.0.18362.295]
    (c) 2019 Microsoft Corporation. All rights reserved.
    
    -------------------------------------------------
    MONOCLE RUNTIME ENVIRONMENT
    -------------------------------------------------
    VERSION   = 0.0.4
    OS/ARCH   = win32\x64
    PROCESS   = monocle-gateway (PID=21480)
    TIMESTAMP = 2019-08-24T06:24:09.989Z
    
    -------------------------------------------------
    MONOCLE GATEWAY SERVICE         (Version: 0.0.4)
    -------------------------------------------------
    [Monocle Starting]
    [Monocle Connecting]
    [Monocle Started]
    [RTSP Server Starting]
    [RTSP Server Listening] 0.0.0.0:8555 (RTSP)
    [RTSP Server Listening] 0.0.0.0:443 (RTSP-TLS)
    [RTSP Proxy Started] (PID=21316)
    [RTSP Server Listening] 0.0.0.0:8554 (PROXY)
    [RTSP Server Started]
    [Monocle Connected]
    [RTSP Server Registered]
    
    -------------------------------------------------
    MONOCLE RTSP SERVICE - INITIALIZED
    -------------------------------------------------
    FQDN = 53ed4890-2473-4154-8175-c2c5ff261745.mproxy.io
    HOST = 192.168.1.131
    PORT = 443
    -------------------------------------------------
    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Stefan
    -------------------------------------------------
     - NAME  : Stefan
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.1.204:554/videoMain
     - UUID  : STREAM:42e460f3-ebf5-4e50-9c4c-3281da3e70e3
     - SESS  : 46789ce1-7f60-4492-824f-26e9e388467c
     - MODIF : Sat Aug 24 2019 02:15:51 GMT-0400 (Eastern Daylight Time)
     - TAGS  : @fixaudio,@tunnel
    -------------------------------------------------
    
    2019-08-24T06:34:44.827Z [INFO]  [192.168.1.138:38196 <rypK98RNS>] RTSP CLIENT SOCKET CONNECTED
    2019-08-24T06:34:44.947Z [INFO]  [192.168.1.138:38196 <rypK98RNS>] RTSP CLIENT ATTACHED TO STREAM: Stefan (STREAM:42e460f3-ebf5-4e50-9c4c-3281da3e70e3)
    2019-08-24T06:34:44.953Z [INFO]  [192.168.1.138:38196 <rypK98RNS>] RTSP ENDPOINT SOCKET CONNECTED {192.168.1.204:554}
    2019-08-24T06:34:44.957Z [DEBUG] [192.168.1.138:38196 <rypK98RNS>] [CLIENT REQUEST]  --> [DESCRIBE] rtsp://53ed4890-2473-4154-8175-c2c5ff261745.mproxy.io:443/STREAM:42e460f3-ebf5-4e50-9c4c-3281da3e70e3?session=46789ce1-7f60-4492-824f-26e9e388467c
    2019-08-24T06:34:44.959Z [TRACE] [192.168.1.138:38196 <rypK98RNS>] [CLIENT REQUEST]  --> [HEADERS] {
      "accept": "application/sdp",
      "user-agent": "Fire OS/6.0 stagefright/1.2 (Linux;Android 7.1.2)",
      "cseq": "1"
    }
    2019-08-24T06:34:44.964Z [DEBUG] [192.168.1.138:38196 <rypK98RNS>] [ENDPOINT REQUEST]  --> [DESCRIBE] rtsp://192.168.1.204:554/videoMain
    2019-08-24T06:34:44.966Z [TRACE] [192.168.1.138:38196 <rypK98RNS>] [ENDPOINT REQUEST]  --> [HEADERS] {
      "accept": "application/sdp",
      "user-agent": "Fire OS/6.0 stagefright/1.2 (Linux;Android 7.1.2)",
      "cseq": "1"
    }
    2019-08-24T06:34:44.975Z [DEBUG] [192.168.1.138:38196 <rypK98RNS>] [ENDPOINT RESPONSE] <-- [400 (Bad Request)] <cseq=0> (session=undefined)
    2019-08-24T06:34:44.976Z [TRACE] [192.168.1.138:38196 <rypK98RNS>] [ENDPOINT RESPONSE] <-- [HEADERS] {
      "server": "Hisilicon Streaming Media Server/1.0.0(Jan  6 2016)",
      "cseq": "0"
    }
    2019-08-24T06:34:44.979Z [WARN]  [192.168.1.138:38196 <rypK98RNS>] RTSP ENDPOINT RESPONSE ERROR: [DESCRIBE] = 400 (Bad Request)
    2019-08-24T06:34:44.982Z [DEBUG] [192.168.1.138:38196 <rypK98RNS>] [CLIENT RESPONSE] <-- [400 (Bad Request)] <cseq=0> (session=undefined)
    2019-08-24T06:34:44.985Z [TRACE] [192.168.1.138:38196 <rypK98RNS>] [CLIENT RESPONSE] <-- [HEADERS] {
      "server": "Hisilicon Streaming Media Server/1.0.0(Jan  6 2016)",
      "cseq": "0"
    }
    2019-08-24T06:34:44.988Z [INFO]  [192.168.1.138:38196 <rypK98RNS>] RTSP ENDPOINT SOCKET CLOSED [192.168.1.138:38196 <rypK98RNS>]
    2019-08-24T06:34:44.993Z [INFO]  [192.168.1.138:38196 <rypK98RNS>] RTSP CLIENT SOCKET CLOSED
    2019-08-24T06:34:44.997Z [INFO]  [192.168.1.138:38196 <rypK98RNS>] RTSP CLIENT DETACHED FROM STREAM: Stefan (STREAM:42e460f3-ebf5-4e50-9c4c-3281da3e70e3)
    


  • Update, using @proxy, @noaudio fixed my issue. However, I’m getting intermittent messages from Alexa: “I could find any enabled video skills that can find that. Go to the Alexa app to manage your video skills and devices.” Anyone else having this issue?



  • @the_samb0t

    Glad you got it working. I have not experienced the “I could find any enabled video skills that can find that." issue and I don’t remember anyone reporting that. If you Alexa device setup for multiple profiles? I do know that if you change provides on Alexa, you may be an on account that is not associated with your Monocle linked skill.

    Thanks, Robert



  • @Monocle said in Cannot get Echo Show 5 working with Foscam FI9821P V3:

    Glad you got it working. I have not experienced the “I could find any enabled video skills that can find that." issue and I don’t remember anyone reporting that. If you Alexa device setup for multiple profiles? I do know that if you change provides on Alexa, you may be an on account that is not associated with your Monocle linked skill.

    Io ho il modello FI9816P e avevo lo stesso problema (400 bad request) e ho risolto con @proxy al posto di @tunnel. Non è stato necessario il tag @noaudio e in questo modio l’audio si sente perfettamente su echo show 5. (Paolo)


Log in to reply