Success with RLC-410 4MP Camera on Echo Show 5



  • I don’t see any info on the RLC-410 4MP cameras. So after some difficulty and troubleshooting, I finally got my cameras working with the Echo Show 5.

    The @tunnel tag did not work. @tunnel, @noaudio did not work either. When I tried @proxy, I finally got it to show up on the Echo Show 5.

    I am also using the sub stream of the camera (rtsp://<ip>:554/h264Preview_01_sub), as the main stream has a resolution over 1080P (2560x1440), which your requirements on the Echo Show 5 say won’t support it. The sub stream only has a resolution of 640x325, but it looks OK on the Echo Show 5.

    Anyway, just wanted to note my success, in case anyone else is looking!

    Thanks!



  • @Gunn

    Thanks for posting your info … I’m sure it will help somebody down the road.

    Typically for Reolink cameras, you only need @tunnel and to make sure the manufacturer is configured as “Reolink” in the Monocle web portal. Behind the scene, we add the tag @ntpnow which addresses a specific compatibility issue with Reolinks.
    https://monoclecam.com/monocle-gateway/tagging#atntpnow

    Glad to hear you got it working. The resolution limit is true, at least the last time I tested this a few months ago. I’m not sure why Amazon limits this device to 1080P streams. None of the other Echo Shows (apart from the Echo Spot) do this.

    Thanks, Robert



  • @Monocle

    Well, I had it working. I had a hard drive failure and had to basically re-build the Windows 10 machine I had Monocle gateway running on. Now I can’t get it to work.

    I had to create a new API token. I downloaded the 64-bit Windows version, unzipped it and copied in the token file. I went into the Alexa skill, unlinked it and re-linked it. Saw my two cameras listed as Alexa devices.

    When I run the gateway, I notice something that is different than the screenshots in the documenation:

    -------------------------------------------------
    MONOCLE RUNTIME ENVIRONMENT
    -------------------------------------------------
    VERSION   = 0.0.4
    OS/ARCH   = win32\x64
    PROCESS   = monocle-gateway (PID=11148)
    TIMESTAMP = 2019-11-28T00:22:58.657Z
    
    -------------------------------------------------
    MONOCLE GATEWAY SERVICE         (Version: 0.0.4)
    -------------------------------------------------
    [Monocle Starting]
    [Monocle Connecting]
    [Monocle Started]
    [RTSP Server Starting]
    [RTSP Server Listening] 0.0.0.0:8555 (RTSP)
    [RTSP Server Listening] 0.0.0.0:443 (RTSP-TLS)
    [RTSP Proxy Started] (PID=796)
    [RTSP Server Listening] 0.0.0.0:8554 (PROXY)
    [RTSP Server Started]
    [RTSP Proxy Stopped] CODE=3221225781; SIGNAL=null
    [Monocle Connected]
    [RTSP Server Registered]
    
    -------------------------------------------------
    MONOCLE RTSP SERVICE - INITIALIZED
    -------------------------------------------------
    FQDN = b0359c5e-eecf-495d-a4eb-dddfc007b1cc.mproxy.io
    HOST = 192.168.1.8
    PORT = 443
    

    I’m assuming that “[RTSP Proxy Stopped] CODE=3221225781; SIGNAL=null” is a problem…?!

    When I ask to display a camera, I see the following error in the monocle-gateway:

    2019-11-28T00:27:06.356Z [ERROR] Uncaught Exception connect ECONNREFUSED 127.0.0.1:8554
    [ 'Uncaught Exception', 'connect ECONNREFUSED 127.0.0.1:8554' ]
    2019-11-28T00:27:06.361Z [ERROR] Error: connect ECONNREFUSED 127.0.0.1:8554
    [ { Error: connect ECONNREFUSED 127.0.0.1:8554
        at Object._errnoException (util.js:1031:13)
        at _exceptionWithHostPort (util.js:1052:20)
        at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1195:14)
        errno: 'ECONNREFUSED',
        code: 'ECONNREFUSED',
        syscall: 'connect',
        address: '127.0.0.1',
        port: 8554 } ]
    

    That’s not good. Can’t figure it out! Any ideas?!!

    Thanks,

    Tom



  • @Gunn

    Hi Tom,

    There were some issues with a SSL certificate on the servers yesterday, so you may have better luck today. Also the monocle-proxy error you pointed out is often related to some missing runtime dependencies … please see the note below:

    Please note when starting the service/application, if you get any errors that say the file MSVCR100.DLL is missing, then you will also need to download and install the Microsoft Visual C++ 2010 Runtime Libraries available here: Download Microsoft Visual C++ 2010 SP1 Redistributable Package (x86) from Official Microsoft Download Center

    Try installing the MS C++ runtime and then restart Monocle Gateway and see if that error goes away.

    Thanks, Robert


Log in to reply