Amazon Echo Show 5 and Unifi Protect [SOLVED]



  • I set up a Unifi Dream Machine Pro recently and was able to restore Unifi Protect from the backup taken from the previous CKG2+. Everything works perfectly with that restore, aside from accessing the RTSP streams via an Echo Show Five.

    I previously had this working by hosting monocle-gateway on a local VM, and in conjunction with the Monocle skill was able to view the RTSP streams on the Show.

    Now Protect will only give me the IPv6 address for the RTSP streams and no amount of configuration-fu with Monocle or the gateway will display the stream. Ive tried the IPv6 address in the Monocle config, Ive tried substituting the v6 address for the local v4 address, and have removed/discovered the cams each time Ive made a config change. Nothing is working.

    The cameras are getting IPv4 addresses from the UDM’s DHCP server and I can access the cams directly via their IPv4 addresses. The monocle-gateway is properly configured and running properly, and I can see it throwing a not-found error when I use the IPv6 address and a connection-refused when I substitute the cameras’ IPv4 addresses.

    I’ve asked this same thing on the Ubiquiti forums and am looking for how to get the UDM-version of Unifi Protect to issue IPv4 addresses for RTSP streams, but Im curious if there is a way to modify the Monocle cam config or the monocle-gateway to recognize the IPv6 address Protect is issuing.

    If any other detail is helpful for diagnostics, let me know.

    Thanks.



  • @spalmisano Use 192.168.1.1 for the IP address, assuming you have the standard UDM-Pro/Protect set up.

    I ran into this getting my UVC-G3 showing on my Show 5.

    Don’t do like I did, and use the IP address for the camera; use the IP address of the Protect controller.

    Mailbox
    Unifi G3
    Manufacturer:Ubiquiti, Inc.Model:UVC-G3
    rtsp://192.168.1.1:7447/<your string here>
    Last Viewed:Sat Sep 07 2019 18:25:09 GMT+0000 (UTC)
    H264NONE1920*1080@tunnel
    


  • That did it. Thank you very much.


Log in to reply