DNS rebinding issue preventing streaming?



  • Hi,
    have just started with Monocle to try and get my Reolink RLC-422 connected to my Alexa Spot, and everything looks to be configured correctly, but from other posts, I think I may have hit the DNS rebinding issue, and a little stuck on how to proceed.

    I can ask Alexa to view camera, and in the Monocle Gateway output, I can see the request coming in but Alexa is unable to show the stream.

    Going through some posts, I can see that DNS binding can be an issue here, and so have tried the following, both on the PC running the gateway and on another PC in my home network.

    C:\Windows\system32>nslookup xxxxxx-73ce-415c-bc6f-fde2cbabe1ef.mproxy.io
    Server:  router.asus.com
    Address:  192.168.1.1
    
    *** router.asus.com can't find xxxxxx-73ce-415c-bc6f-fde2cbabe1ef.mproxy.io: Non-existent domain
    
    C:\Windows\system32>nslookup xxxxxx-73ce-415c-bc6f-fde2cbabe1ef.mproxy.io 8.8.8.8
    Server:  dns.google
    Address:  8.8.8.8
    
    *** dns.google can't find xxxxxx-73ce-415c-bc6f-fde2cbabe1ef.mproxy.io: Non-existent domain
    
    

    It seems the FQDN cannot be resolved, and I think that’s the problem.

    My router is an ASUS RT-AC88U and hunting through the screens and manual, there doesn’t appear to be any way of adding the mproxy.io as an exclusion in the router, or in fact anything to do with DNS binding.

    Any suggestions on how to debug further or override this host lookup ?



  • I found a solution after some playing. It appears that the Google DNS server (8.8.8.8) couldn’t resolve the IP, but the OpenDNS server (208.67.222.222) could, so I reconfigured the DNS server my router used and now it can connect through.

    I’m still not quite there as all I get on the Alexa is “buffering” but it’s a step forward!



  • @schmorgs

    Google DNS servers should resolve the hostname … maybe they were slow to update/synchronize at the time you were using it?
    I just tested using nslookup on my unique mproxy hostname on both 8.8.8.8 and 8.8.4.4 (Google DNS servers) and it resolved just fine.

    For Reolink cameras, make sure the “manufacturer” property on the camera config in the Monocle web portal is set to “Reolink”. Also as you probably already know, the tag @tunnel should also be applied to that camera.

    Feel free to post the request info from your monocle gateway log here while attempting to ask Alexa for your camera stream. Maybe we can spot something obvious.

    Thanks, Robert


Log in to reply