Victure PC420



  • Hi, I have bought a cheap camera from amazon and looking to get it to work with alexa.

    I have found the RTSP url, it is: rtsp://192.168.168.205:554/realmonitor?channel=0&stream=0.sdp.

    Using VLC i can view the stream. the codecs info is as follows:

    -Stream 0
    –Codec H264 - MPEG-4 AVC (part 10) (h264)
    –Type Video
    –Video Resollution: 1920x1080
    -Stream 1
    – Codec PCM ALAW (alaw)
    –Type Audio
    –Channels: Mono
    –Sample rate: 8000hz
    –Bits per a sample: 16

    When setting it up in Monocle and asking alex to show the camera, It trys for a while and then just says the camera is not responding.

    The Monocle setting are as follows:

    {
    “timestamp”: “2019-11-01T19:58:11.564Z”,
    “request”: “InitializeCameraStreams”,
    “response”: [
    {
    “uri”: “rtsp://%USER%:%PWD%@192.168.168.205:554/realmonitor?channel=0&stream=0.sdp”,
    “proxy”: “rtsp://proxy.monoclecam.com:443/1aff31b2-38ad-4330-9aae-5a84485c63a8”,
    “idleTimeoutSeconds”: “90”,
    “resolution”: {
    “width”: “1920”,
    “height”: “1080”
    },
    “authorizationType”: “DIGEST”,
    “videoCodec”: “H264”,
    “audioCodec”: “G711”,
    “protocol”: “RTSP”
    }
    ]

    I have tried both DIGEST and BASIC authorization types. no difference.

    Any suggestions would be great

    Thanks



  • @peted

    Which Alexa device are you using?

    You probably need to try using our Monocle Gateway software to get any further:
    https://monoclecam.com/troubleshoot/tips

    Thanks, Robert



  • Thanks, This is now working. A proxy server has fixed the issue, the config needed @proxy and @ntpnow tags and basic authenitication.

    Another question, this is now working an a Fire4K stick, When trying to access it from my alexa enabled LG TV, it just shows a black screen, the proxy server shows the info below. Any advice would be great.

    Thanks

    Nov 15 19:40:53 raspberrypi monocle-gateway[1056]: -------------------------------------------------
    Nov 15 19:40:53 raspberrypi monocle-gateway[1056]: INITIALIZE RTSP STREAM:  Monster
    Nov 15 19:40:53 raspberrypi monocle-gateway[1056]: -------------------------------------------------
    Nov 15 19:40:53 raspberrypi monocle-gateway[1056]:  - NAME  : Monster
    Nov 15 19:40:53 raspberrypi monocle-gateway[1056]:  - LABEL : PRIMARY
    Nov 15 19:40:53 raspberrypi monocle-gateway[1056]:  - URL   : rtsp://192.168.168.205:554/realmonitor
    Nov 15 19:40:53 raspberrypi monocle-gateway[1056]:  - UUID  : STREAM:3c299efa-8472-4de3-bd74-15686473a9a8
    Nov 15 19:40:53 raspberrypi monocle-gateway[1056]:  - SESS  : ee88793c-a37e-49c7-beb5-28071893e982
    Nov 15 19:40:53 raspberrypi monocle-gateway[1056]:  - MODIF : Fri Nov 15 2019 18:17:24 GMT+0000 (GMT)
    Nov 15 19:40:53 raspberrypi monocle-gateway[1056]:  - TAGS  : @ntpnow,@proxy
    Nov 15 19:40:53 raspberrypi monocle-gateway[1056]: -------------------------------------------------
    Nov 15 19:40:53 raspberrypi monocle-gateway[1056]: 2019-11-15T19:40:53.191Z [INFO]  [RTSP PROXY] REGISTERING STREAM [Monster/PRIMARY]; (STREAM:3c299efa-8472-4de3-bd74-15686473a9a8)
    Nov 15 19:40:53 raspberrypi monocle-gateway[1056]: 2019-11-15T19:40:53.196Z [DEBUG] <RTSP-PROXY> [REQUEST]  --> [REGISTER] rtsp://192.168.168.205:554/realmonitor
    Nov 15 19:40:53 raspberrypi monocle-gateway[1056]: 2019-11-15T19:40:53.196Z [TRACE] <RTSP-PROXY> [REQUEST]  --> [HEADERS] {
    Nov 15 19:40:53 raspberrypi monocle-gateway[1056]:   "cseq": "1",
    Nov 15 19:40:53 raspberrypi monocle-gateway[1056]:   "transport": "reuse_connection=0;preferred_delivery_protocol=udp;proxy_url_suffix=STREAM:3c299efa-8472-4de3-bd74-15686473a9a8;username=admin;password=123456"
    Nov 15 19:40:53 raspberrypi monocle-gateway[1056]: }
    Nov 15 19:40:53 raspberrypi monocle-gateway[1056]: 2019-11-15T19:40:53.197Z [DEBUG] <RTSP-PROXY> [RESPONSE] <-- [200 (OK)] <cseq=1> (session=undefined)
    Nov 15 19:40:53 raspberrypi monocle-gateway[1056]: 2019-11-15T19:40:53.197Z [TRACE] <RTSP-PROXY> [RESPONSE] <-- [HEADERS] {
    Nov 15 19:40:53 raspberrypi monocle-gateway[1056]:   "cseq": "1",
    Nov 15 19:40:53 raspberrypi monocle-gateway[1056]:   "date": "Fri, Nov 15 2019 19:40:53 GMT"
    Nov 15 19:40:53 raspberrypi monocle-gateway[1056]: }
    


  • @peted

    Glad to hear you have made some progress.

    I’ve never tested a LG TV with Alexa before, only the Toshiba FireTV Edition.

    However, based on the log it appears that the TV is never attempting to establish a TCP/RTSP connection with the monocle gateway server. The gateway is receiving the camera request from the Monocle servers and thus from the Alexa Cloud and the gateway is setting up the RTSP proxy for the stream, but the Alexa enabled TV should then attempt to make a TCP connection to the local gateway service and this appears to be missing. So the first question is … is the Alexa TV connected to the same WiFi network and not a Guest network or some other VLAN? You may also need to try restarting the TV, unplug and reboot – to flush any old DNS cached entries just in case. Beyond this, I’m not sure what the issue would be. The TV needs to make a local connection to the gateway just like your other FireTV (4K Stick). So its most likely a networking issue … that or the TV may not support Alexa smart home cameras? You may check with LG or Amazon to make sure this TV model is supported.

    Thanks, Robert


Log in to reply