please remove auto fill of port address (:554)



  • The RTSP://connection to my camera already represents to connect to port 554…So my camera doesn’t like the :554 entered after the IP address,I’ve tested with and with out the port :554 using VLC and Onvifer… My camera will only work without the :554

    I can’t enter the address without it automatically putting in the :554 when I save it…

    Can this function be disabled?



  • @Dayhunter

    That’s really odd. Port 554 is the default RTSP port. If you omitted the port number, it effectively would be the same using port 554 under the hood. (as you suggested) It sounds like something is wrong in the camera firmware if it can’t support the explicit port in the URL.

    Let me see what I can do to remove it or strip it out before its gets sent to Alexa. What type of camera is it and are you also using our Monocle Gateway software?

    Thanks, Robert



  • @Monocle

    No issue with the firmware, its an avigalion camera…not all device’s require the port number to be designated in address bar… suchs as a secure site… https…indicates that its port 443 and you don’t have to add port 443 in the address bar its indicated by the (S) for secure.

    So… back to my question, can the your programmer remove the auto entre of the port address when I save… ? It not required when desigation is RTSP… it looks for the stream on RTSP which the port is already set at the drvice…?

    Thanks…



  • @Dayhunter

    We are looking into removing the autofill port number — I should have an update/solution on that by Monday.

    I agree that it (the camera and all viewer software) should work without the implicit 554 port number; however, they should also work with the implicit port number as well. Take your HTTPS example, you can include port 443 in the URL or omit it and the site and browser will work identical in both cases. This should be the same for the camera using the RTSP prefix in the URL format. So if the camera is refusing to work with the implicit port number in the URL then something is up – possibly with the camera’s firmware or the software attempting to access the stream. It’s up to the viewing software to actually establish the TCP connection on port 554 if an explicit port is not defined in the RTSP URL. However, the camera could be preventing the RTSP negotiation if there is something about the explicit port number in the URL defined in the headers or in the raw request that it doesn’t like for some reason.

    I’ll update this thread once we have a solution or fix in place. Thanks, Robert



  • I am hoping this resolves some issues. All of my Amcrest cameras have stopped responding to alexa. I have tried to remove port 554 but it does just place it back in. I will watch for the update.



  • @Dayhunter, @wolfe4656

    FYI,
    We have plans to roll out this change tomorrow to the live web portal application.

    Thanks, Robert



  • Will this update strip out all defined ports?

    I have cameras on Ubiquiti’s UniFi Protect. Everything running great until this morning. Tried to show the Front Door on a Echo Show and it will not connect now. No changes to the network. RTSP feeds from camera are still active and working.

    I’ve defined my rtsp feed as rtsp://10.0.1.2:7447/xxxxx…

    I believe it could be stripping my :7447 port. Can this be disable or do I need to try to define my UniFi Protect rtsp port as :554?



  • @curtissimo

    No this change will not affect explicitly defined ports (ports other than 554). Additionally, this change has not yet rolled out – so the issue you are experiencing must be something else.

    Thanks, Robert



  • @Monocle what would be the suggested way to troubleshoot this? I haven’t changed anything and I’ve verified that all links are the same, equipment is online and operational, and attempted to rescan for devices in Alexa app. I’ve also reviewed your camera feed history and it appears that nothing has changed in the payload.



  • @curtissimo

    First, and I know this sounds cliché, but try rebooting the camera and Alexa device. I have personally experienced issues where the Alexa device required a reboot before she would show camera feeds again.

    What type of Alexa device? Are you aware of any recent system updates on the Alexa devices? Are you using the Monocle Gateway software in your environment?

    Thanks, Robert



  • Its ok, I understand. I have and already tried. Restarted Cameras, UniFi Protect NVR, and Echo Show 5. All 7 cameras will not connect. No software updates from yesterday to today that would have caused the change.

    Yes, Monocle Gateway software running on Ubuntu Server 18.04 LTS.



  • @curtissimo

    OK, next step would be to collect the log data while you are asking Alexa for the camera feed. You can post it to this forum, maybe in a new support thread and we can take a look. We will review the log data and make sure the gateway is receiving the instructions and negotiating the RTSP stream with the camera.

    Probably would not hurt to restart the gateway as well if you have not already done so.



  • @Dayhunter, @wolfe4656

    This change is now in place. You can edit your camera feed in the web portal and remove port 554 and save the camera entry. It should no longer force the default port in the URL if it is omitted in the string.

    However, there is one caveat … the existing version of Monocle Gateway does not play nice with the RTSP URL string with no defined port number. So we have made additional changes to force the default RTSP port number back into the URL string if sending this URL to a Monocle Gateway instance. Please note, the camera entry is not altered, but the URL will be updated at runtime when sending to an existing version of the gateway. We have also thus made updates to the gateway software to handle this case where a default RTSP port may not be defined. So new versions of the gateway will handle this condition and the server will send the un-altered RTSP URL to new versions of Monocle Gateway. If you are using Monocle Gateway to test this change, you will need an updated version. I can provide an experimental version upon request, just let me know what platform you are running it on.

    Thanks, Robert


Log in to reply