OpenEye IP Camera issues



  • Hello,

    I have multiple openeye brand cameras I am attempting to connect to fire tv stick and fire stick 4K.
    Gets stuck at buffering when opened on fire Tv’s or fire tv 4K.

    Camera is openeye cm-715ai and oe-c7163a .

    Alexa tries to connect to cameras on voice request, but shows buffering and never succeeds.

    Might have seen a successful for a frame or 2 once , but it could have been a glitch hold over frame from casting to fire tv using vlc and air screen App on fire tv. I was watching camera via another method before initiating voice request, so unsure if Alexa really displayed it for a second, or if it defaulted back to previous shown screen for a second.

    Camera Streams can be casted to fire tv via vlc, but not open direct with Alexa.

    Tried lower resolutions. No change

    Camera stream ok in VLC. Looked at codecs.

    Video codec from vlc. H264 -mpeg-4 AVC (part 10) (h264)

    Audio was found to be unsupported format on these cameras. Codec PCM-MU-LAW (mlaw). Mono 8000hz 16 bits per sample. Therefore I installed gateway to remove audio.

    Installed monocle gateway on windows. Appears to start ok.

    Tried all tags, including @noaudio

    Alexa finds camera ok. If my settings are made to be wrong intentionally, I get message camera not responding from Alexa , when I make settings accurate, Alexa fire tv goes from waiting for camera state to the buffering state, but then fails after buffering a while.

    Gateway shows the service initialized

    I see camera attempt to stream and retry in gateway a few times.

    Any suggestions?

    How do I verify @noaudio tag is working and gateway is really removing audio stream before sending to Alexa to make the camera compatible?

    Thanks !



  • Another discovery. I found that when using @tunnel or @proxy as required to route traffic through gateway, Alexa says camera did not respond. Remove the tag and camera responds, but sticks buffering. One of the cameras does display image for a moment, then goes back to buffering when not using gateway. Upon addition of @tunnel, state changes to camera did not respond.

    Checked dns using Ns lookup and .mproxy.io resolves to my local address of the gateway server as expected.

    Tried new token and rebooted fire stick. Still no luck.

    Jacob



  • Made some progress. DNS resolves proper on all networked devices. I Found something else from my nvr software listening on port 443 and shut it down.

    I now can get a connection through the gateway using @tunnel, and I get a momentary image displayed. Shortly after display it goes back to buffering. @noaudio doesn’t seem to help. I am now confident it’s routing through the gateway, but the audio stream or something seems to be causing fire tv to fail.

    Any suggestions?

    Thanks,

    Jacob.



  • @kerbsjacob

    Hi Jacob,

    Please post the log from the gateway where you ask Alexa for the camera stream and it negotiates the RTSP stream with Alexa and then fails. We can verify the no audio is working by reviewing the log data.

    Thanks, Robert



  • f0a2f29e-8ad6-4b45-a8c6-05659b85bf32-image.png

    4317b8d8-ecd2-4fb7-8344-3b049ce867fa-image.png 179bef51-086d-455b-ab34-8dd4f56a8c1c-image.png

    53eae29a-f9f9-495d-9e4c-8715a3725aaa-image.png

    2039409e-ad77-404f-8043-0ab12019474f-image.png



  • camera stayed open and working for about 10 seconds on this attempt, longer than any time before.



  • @kerbsjacob

    I don’t see an audio stream included in the camera’s response (SDP <stream descriptor>). So I don’t think audio is a factor here.

    Try removing the @tunnel tag and replace with @proxy. If that does not work, try @proxy-tcp instead.

    If still no luck, replace tags with both: @tunnel, @fake-fmtp.

    Let see if any of these help at all. If not, the next step would be, if possible, to make the stream temporarily available to us to further test against with some additional tools.



  • Hello,
    Thanks for the reply.
    I tried all the mentioned combinations.

    With @tunnel and @Fake-fmtp the behavior is the same as before. The stream only shows briefly.

    with either @proxy option, Fire TV seems it can not connect at all.

    I have noticed the 4K fire tv stick never really shows image or buffering and fails right away, the standard fire tv stick at least shows video for a few moments before going to saying buffering and then failing.

    Is it worthwhile trying to install gateway on another device? I am just wondering if maybe some other software is somehow conflicting… Otherwise I guess I need to figure out how to setup remote access to a stream for further troubleshooting.



  • @kerbsjacob

    No I don’t think the gateway is an issue in this case so no need to set that up on another machine … based on the logs it appears to be doing its job.

    It’s entirely possible that Alexa simply is not compatible with the stream. But if you are able to provide remote access, we can try a few more tricks just to see if we can get it working.

    To setup for remote access, you would have to configure a port forwarding option on your router/Internet gateway that exposes a port number to the outside world, lets say port 9554 and forwards that port internally to your IP camera’s local address on port 554. You would provide us your public IP address and whatever port number you exposed (i.e. 9554) and we could attempt to access the camera directly. We would also need some temporary (view-only) access credentials if the camera requires authentication for the stream. You can provide these details to us via the private message / chat feature in this forum.

    Thanks, Robert



  • Hello Robert,
    Thanks for your help. I got most of the cameras working. I had to make sure audio stream was off from cameras themselves and remove the @ noaudio tag from gateway and go back to @tunnel only. The gateway seemed to be getting bogged down trying to remove the audio causing excessive buffering. This got all cameras except 1 to show for a period of 40 seconds before disconnecting. The other one is a different model openeye PTZ and it doesn’t respond at all no matter what I do.

    Is it normal for the fire tv to disconnect automatically after 40 seconds?
    Also, while this works on the fire tv, I have had no luck with the 4k version.

    Best regards
    Jacob


Log in to reply