RLC-423, RLC-422, C2-Pro confirmed working on Echo Show 2nd Gen 10.1"



  • 40570acd-4e35-438a-8ed0-1acdfadc30d3-image.png

    I got these three Reolink cameras working for me on an Echo Show 2nd Gen 10.1" screen: RLC-423, RLC-422, and the C2-Pro. I’m using the Monocle Gateway service running on a Synology DS1515+ NAS (Docker Container). Main stream (not sub stream) working & looks good. @tunnel is only tag I’m using. Use “Digest” for authentication over default port 554.

    Only issue I ran into was due to Amazon’s “Household profiles”. My wife and I share an Amazon Prime subscription so there’s some overlap i.e. content, features. When I ordered my Echo Show 2nd Gen there was an option to automatically register it to my Amazon account which I did choose. I assumed it would be linked to my account since I ordered it but the device came linked to my wife’s account for some reason. After much troubleshooting, not getting the cameras to connect, I figured out the Echo Show was not using my profile hence it wasn’t able to see the cameras nor any other of my smart home devices. If you share an Amazon account with someone you can ask Alexa which account she’s using by saying “Alexa, which account is this?”. After telling Alexa to switch over to my account the cameras connected fine.

    I also have a Reolink Argus 2 camera but according to the forums it doesn’t support RTSP so it won’t work with Monocle at this time. I did however get it working using Reolink’s own Alexa skill but the video/audio delay is significant. It’s so bad I decided not worth even using. My guess is because it’s routing the feed up to the cloud first, then back down to my local network but that’s just an educated guess. To enable this, in addition to the Reolink Alexa skill, you must launch the Reolink mobile app, click the “Cloud” tab, Smart Home, then click “Enable” under the device you want. Initially I tested all my Reolink cameras using only this skill & left Monocle out of the picture but all the camera feeds had not only a significant video/audio delay but the resolution of the feed was bad. Monocle provides a much better video/audio feed quality. I contacted Reolink about the video/audio delay and below was their response:

    “I am so sorry for the trouble caused, as for the Echo Show current status not only our camera but also other brand camera on the market, also have the same issue, we have known this issue, our development team are working hard on it and find whether there is a solution to solve it. But we still facing lots of difficulties, if we can find a proper solution that we will make it for the future upgrade.”



  • @helloit

    Glad to hear your Reolinks are working with Monocle!

    I would also suggest asking Reolink for a feature request to open RTSP access to the Argus series of cameras. Manufacturers will continue pushing in the direction of closed access if we the consumers don’t push back with our voices and wallets.

    As for the Docker container on Synology, did you find the instructions here and if so were they helpful?
    https://monoclecam.com/monocle-gateway/install/synology

    Thanks, Robert



  • Hi Robert,

    Great suggestion. I went ahead and sent Reolink that feature request for RTSP access to the Argus cams.

    Yes the instructions from that link are what I used to get up and running and were super helpful. Many thanks for including. People with IP cameras may already be using a NAS to act as the NVR so it’s nice that it can also be used to run Monocle. Only step that didn’t exactly match my scenario was in the “Configure docker-compose.yml” section, step #6. I didn’t have a physical network interface named “ovs_bond0” but instead just “bond0”. But wasn’t a big deal, it’s easy to SSH in and verify.

    A helpful tip for troubleshooting, logging into the Synology NAS web page, going to Docker, and viewing the log via the GUI interface is ok but if one prefers the terminal like I do (I use Putty), you can pull up the same log using the commands below, if anyone is interested.

    sudo su -
    docker logs monocle-gateway --follow

    Thanks,


Log in to reply