UCAM247 Cameras



  • I can confirm the following UCAM247 cameras are working well with Monocle.

    NC328W-IR-1080P (outdoor model)
    NC328W-IR-1080P (indoor model)

    I believe these cameras use the same backend software as the Phylink cameras so should be workable using the same info

    For clarification…both of these models worked fine on gen 1 Show, gen 2 Show and Echo Spot.

    Initially, these were not viewable on the newer Echo Show 5 or Echo Show 8. These devices could only view the cameras using the Monocle Gateway…I used the "tunnel tag and this seemed to work fine. Both of the cameras are 1080p cameras and they appear to be showing at the full resolution that the new Show devices allow

    I am running my home network on a Linksys WRT1200AC…I am not running the stock firmware but have flashed it with DDWRT. By default…DDWRT is set to DISABLE DNSBinding and this was enough to stop the cameras feeds working. ONC328W-IR-1080It is possible to enable/allow DNSBinding but it is opening a security loophole in your network so, after assistance from Monocle themselves, I can confirm that using the following command in your Services/Additional DNSMasq Options will allow this single device to bypass the issue

    rebind-domain-ok=/here you will place then information you can get from the monocle-gateway status .mproxy.io/

    Mine looks like this and works fine…I have changed some of the details obviously but should give you the idea

    rebind-domain-ok=/72a54bb8-197a-bg87-8823-a035a74c0fds.mproxy.io/

    I am by no means an expert on this stuff but if anyone has any questions, feel free to ask away and I can do whatever I can to help



  • @Jouster-74 said in UCAM247 Cameras:

    Just to add to this topic, you can also just use the following in your DNSMasq options to include all potential subdomains from the primary/base domain we use for the gateway.

    rebind-domain-ok=/mproxy.io/
    

    The explicit FQDN (fully-qualified) domain is perhaps a bit more “secure”, but in the event you replace your Monocle API token used with Monocle Gateway, you will also need to remember to update your DNSMasq options.

    Either one should work, its entirely up to you!

    Thanks, Robert


Log in to reply