Hikvision Camera Streams Disconnecting After ~30 Seconds



  • Hello,

    I’ve just setup the Monocle Gateway along with the new Echo Show 2nd Gen (10.1") device. After the 10-15 seconds of buffering, the camera stream only plays for around 30 seconds then disconnects. This is across multiple different Hikvision Camera models under the Hikvision NVR DS-7616NI-I2 / 16P. I can immediately (with the initial delay) start the stream again, but it will disconnect again after around 30 seconds.

    Initially I cannot get it working at all without the Gateway but do plan on using it with the Fire TV 4K Stick so I don’t mind keeping the gateway.

    I reviewed the logs (below) but don’t see anything that could be used to assist. One other option I tried was to set the timeout in the Web UI to 60 seconds, shorter, longer, but the feed always cuts out after ~30 seconds.

    Log below (When suing @proxy TAG):

    2019-12-01T01:05:51.208Z [INFO]  [192.168.1.127:57890 <HkDlfqeTr>] RTSP ENDPOINT PLAYING MEDIA STREAM: Front Door (STREAM:e25de920-1b86-4619-8580-762dc5b0f443)
    2019-12-01T01:05:51.217Z [INFO]  [192.168.1.127:57890 <HkDlfqeTr>] RTSP CLIENT PLAYING MEDIA STREAM: Front Door (STREAM:e25de920-1b86-4619-8580-762dc5b0f443)
    2019-12-01T01:07:01.250Z [INFO]  [192.168.1.127:57890 <HkDlfqeTr>] RTSP CLIENT SOCKET CLOSED
    2019-12-01T01:07:01.252Z [INFO]  [192.168.1.127:57890 <HkDlfqeTr>] RTSP CLIENT DETACHED FROM STREAM: Front Door (STREAM:e25de920-1b86-4619-8580-762dc5b0f443)
    2019-12-01T01:07:01.258Z [INFO]  [192.168.1.127:57890 <HkDlfqeTr>] RTSP ENDPOINT SOCKET CLOSED [192.168.1.127:57890 <HkDlfqeTr>]
    

    Camera Feed/Stream URL (RTSP):
    rtsp://192.168.1.240:10554/Streaming/Channels/1201/
    Authentication: DIGEST
    Video Resolution 192x192
    Video Codec 264
    Audio Codec None (Others Tried As Well)
    Timeout (Seconds)
    blank, 60, others tried as well
    Tags (Optional)
    @proxy

    When using @tunnel TAG I can’t get it to work at all and eventually says “Hmm, the camera isn’t responding”. Log below:

    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Front Door
    -------------------------------------------------
     - NAME  : Front Door
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.1.240:10554/Streaming/Channels/1201/
     - UUID  : STREAM:e25de920-1b86-4619-8580-762dc5b0f443
     - SESS  : c4ddd302-f255-48a1-b9e4-e54f69d7954a
     - MODIF : Sat Nov 30 2019 20:15:46 GMT-0500 (Eastern Standard Time)
     - TAGS  : @tunnel
    -------------------------------------------------
    
    2019-12-01T01:16:58.145Z [INFO]  [192.168.1.127:57906 <HyGq4clpH>] RTSP CLIENT SOCKET CONNECTED
    2019-12-01T01:16:58.273Z [INFO]  [192.168.1.127:57906 <HyGq4clpH>] RTSP CLIENT ATTACHED TO STREAM: Front Door (STREAM:e25de920-1b86-4619-8580-762dc5b0f443)
    2019-12-01T01:16:58.276Z [INFO]  [192.168.1.127:57906 <HyGq4clpH>] RTSP ENDPOINT SOCKET CONNECTED {192.168.1.240:10554}
    2019-12-01T01:16:58.281Z [DEBUG] [192.168.1.127:57906 <HyGq4clpH>] [CLIENT REQUEST]  --> [DESCRIBE] rtsp://<REMOVED ID STREAM URL>.mproxy.io:443/STREAM:e25de920-1b86-4619-8580-762dc5b0f443?session=c4ddd302-f255-48a1-b9e4-e54f69d7954a
    2019-12-01T01:16:58.282Z [TRACE] [192.168.1.127:57906 <HyGq4clpH>] [CLIENT REQUEST]  --> [HEADERS] {
      "accept": "application/sdp",
      "user-agent": "stagefright/1.2 (Linux;Android 5.1.1)",
      "cseq": "1"
    }
    2019-12-01T01:16:58.284Z [DEBUG] [192.168.1.127:57906 <HyGq4clpH>] [ENDPOINT REQUEST]  --> [DESCRIBE] rtsp://192.168.1.240:10554/Streaming/Channels/1201/
    2019-12-01T01:16:58.291Z [TRACE] [192.168.1.127:57906 <HyGq4clpH>] [ENDPOINT REQUEST]  --> [HEADERS] {
      "accept": "application/sdp",
      "user-agent": "stagefright/1.2 (Linux;Android 5.1.1)",
      "cseq": "1"
    }
    2019-12-01T01:17:28.274Z [WARN]  [192.168.1.127:57906 <HyGq4clpH>] RTSP CLIENT SOCKET TIMEOUT
    2019-12-01T01:17:28.282Z [INFO]  [192.168.1.127:57906 <HyGq4clpH>] RTSP CLIENT SOCKET CLOSED
    2019-12-01T01:17:28.282Z [INFO]  [192.168.1.127:57906 <HyGq4clpH>] RTSP CLIENT DETACHED FROM STREAM: Front Door (STREAM:e25de920-1b86-4619-8580-762dc5b0f443)
    2019-12-01T01:17:28.283Z [INFO]  [192.168.1.127:57906 <HyGq4clpH>] RTSP ENDPOINT SOCKET CLOSED [192.168.1.127:57906 <HyGq4clpH>]
    

    Using VLC shows the stream right away and doesn’t disconnect.

    Would love to get this working more consistently in Monocle. Any help is greatly appreciated!


Log in to reply