Hikvision Cameras not working on Echo Show8



  • Hi all

    Have the following setup in the UK and having problems, advice appreciated as at wits end :):

    working CCTV setup

    DS-2CD2532F-IS - (Chinese V5.2.0 build 140721)
    192.168.1.32, port 555
    (physically into LAN via POE hub direct and not into NVR.)
    (have also mapped manually into NVR and cam works ok on - IE browser, VLC, NVR and ios/Android phones via HIK)

    bought a SHOW8 and trying to config to show video feed - not working…

    Monocle setup

    Have configured monocle trying different configs:

    • rtsp://192.168.0.32:555/video.h264 = main stream and viewable on VLC but not Alexa

    • rtsp://192.168.0.32:555/Streaming/channels/102 = main stream and viewable on VLC but not Alexa

    • rtsp://192.168.0.32:555/Streaming/Channels/101 = substream and viewable on VLC but not Alexa

    (configured as BASIC, H264 192*192 - also tried DIGEST on 102 and works ok VLC but not Alexa)

    Issue

    verified all working on VLC first (which all the above work ok), then tried alexa - it sits for a few minutes and "hmmm… the camera isnt responding " message

    Gateway

    configured gateway API,
    allowed firewall
    tried combination tags of @noaudio, tried @tunnel and @proxy.

    Gateway showing connection attempt via Alexa on PC DOS for gateway, but still no video feed on alexa.

    Gateway shows the following

    For the H264 :


    INITIALIZE RTSP STREAM: Front video

    • NAME : Front video
    • LABEL : PRIMARY
    • URL : rtsp://192.168.0.32:555/video.h264
    • UUID : STREAM:db1abcf3-346e-407f-9ad9-0c7e17ef1518
    • SESS : cf09938d-29dd-4b72-af03-256929a06077
    • MODIF : Sat Dec 07 2019 05:35:06 GMT+0000 (GMT Standard Time)
    • TAGS : @noaudio,@tunnel

    on Same cam with different syntax of Channel/Streams/xxx , get different output from gateway - but still doesnt work! :


    INITIALIZE RTSP STREAM: Front101

    • NAME : Front101
    • LABEL : PRIMARY
    • URL : rtsp://192.168.0.32:555/Streaming/Channels/101
    • UUID : STREAM:a9f6c13d-b345-483a-b02b-fe91c2dd715a
    • SESS : 5d22da4a-0713-4429-93d1-05dc157f968d
    • MODIF : Sat Dec 07 2019 06:38:11 GMT+0000 (GMT Standard Time)
    • TAGS : @noaudio,@proxy

    2019-12-07T07:24:30.880Z [INFO] [RTSP PROXY] REGISTERING STREAM [Front101/PRIMARY]; (STREAM:a9f6c13d-b345-483a-b02b-fe91c2dd715a)
    2019-12-07T07:24:30.897Z [DEBUG] <RTSP-PROXY> [REQUEST] --> [REGISTER] rtsp://192.168.0.32:555/Streaming/Channels/101
    2019-12-07T07:24:30.899Z [TRACE] <RTSP-PROXY> [REQUEST] --> [HEADERS] {
    “cseq”: “1”,
    “transport”: “reuse_connection=0;preferred_delivery_protocol=udp;proxy_url_suffix=STREAM:a9f6c13d-b345-483a-b02b-fe91c2dd715a;username=XXXX;password=XXXXXXXX
    }
    2019-12-07T07:24:30.902Z [DEBUG] <RTSP-PROXY> [RESPONSE] <-- [200 (OK)] <cseq=1> (session=undefined)
    2019-12-07T07:24:30.903Z [TRACE] <RTSP-PROXY> [RESPONSE] <-- [HEADERS] {
    “cseq”: “1”,
    “date”: “Sat, Dec 07 2019 07:24:30 GMT”
    }

    DIFFERENT CAMERA
    Have also got a UK Cam DS-2CD2142-FWD-i
    tried the above with it also and same issues… no display and same alexa message
    tried with h264 and 102 channel.

    for the other Channel/Streams/xxx - Gateways shows:


    INITIALIZE RTSP STREAM: sidecam2

    • NAME : sidecam2
    • LABEL : PRIMARY
    • URL : rtsp://192.168.0.34:557/Streaming/channels/102
    • UUID : STREAM:83485548-20a8-4c63-8298-5f555c7940e0
    • SESS : af9154ee-8f7f-4c8e-a2ba-fcd7c8bfbe07
    • MODIF : Sat Dec 07 2019 07:12:51 GMT+0000 (GMT Standard Time)
    • TAGS : @noaudio,@tunnel

    Assist appreciated if I am missing something?

    Thanks



  • also tried IP instead of UDP - same issue “camera isnt responding”


    INITIALIZE RTSP STREAM: Front101

    • NAME : Front101
    • LABEL : PRIMARY
    • URL : rtsp://192.168.0.32:555/Streaming/Channels/101
    • UUID : STREAM:a9f6c13d-b345-483a-b02b-fe91c2dd715a
    • SESS : 512c1318-c4b6-4a00-b263-f0fdcb1238bb
    • MODIF : Sat Dec 07 2019 07:35:38 GMT+0000 (GMT Standard Time)
    • TAGS : @noaudio,@proxy-tcp

    2019-12-07T07:38:24.591Z [INFO] [RTSP PROXY] REGISTERING STREAM [Front101/PRIMARY]; (STREAM:a9f6c13d-b345-483a-b02b-fe91c2dd715a)
    2019-12-07T07:38:24.606Z [DEBUG] <RTSP-PROXY> [REQUEST] --> [REGISTER] rtsp://192.168.0.32:555/Streaming/Channels/101
    2019-12-07T07:38:24.607Z [TRACE] <RTSP-PROXY> [REQUEST] --> [HEADERS] {
    “cseq”: “1”,
    “transport”: “reuse_connection=0;preferred_delivery_protocol=interleaved;proxy_url_suffix=STREAM:a9f6c13d-b345-483a-b02b-fe91c2dd715a;username=XXXXX;password=XXXX”
    }
    2019-12-07T07:38:24.613Z [DEBUG] <RTSP-PROXY> [RESPONSE] <-- [200 (OK)] <cseq=1> (session=undefined)
    2019-12-07T07:38:24.613Z [TRACE] <RTSP-PROXY> [RESPONSE] <-- [HEADERS] {
    “cseq”: “1”,
    “date”: “Sat, Dec 07 2019 07:38:24 GMT”
    }



  • @Liaquat

    Following. Same problem. Can view cameras through Alexa spot but just set up echo show 8 and can not view camera.

    Looking for a workaround or app update to fix.



  • @chazzzzz do you mind sharing your spot config so I can review how you have it working? As it may be related to firmware but I have Chinese grey cams - but same issue in UK home purchased one also… so ruled that out…



  • @Liaquat same. Chinese grey cams. Works with the spot… just standard RTSP setup. Thought it would be just as compatible with the echo 8. But it isn’t.



  • I cannot get any of my cameras to work with Monocle on the Echo Show 8 and I have a few different types. Even using the gateway/tunnel. The RTSP feeds all work fine in VLC. For all of them the same thing occurs. The Show 8 never displays the camera. Whats strange is in the logs for the gateway I see “RTSP client playing media stream: Front Door”. From the logs it appears everything is working but nothing actually displays on the Show 8.



  • Grateful if monocle support could advise of anything we may have missed?



  • Try @hangup @noaudio @proxy-tcp



  • Make sure you have a basic password. No symbols.
    If you have audio on your camera, turn it off.
    I have been looking at my hikvision cameras, all mine use @tunnel on the show 8
    Make sure you ask Alexa to find new devices



  • Ok got it working…

    my Notepad log as below, which while long may help others with my step by step process on BASIC v DIGEST, VMWare ports, use of Gateway etc… the answer for me was FIREWALL - kaspersky blocking something so just need to figure out - i suspect 443

    "running gateway
    when starting it identifies gateway as (not sure about the RTSP Server listening set as 0.0.0.0:8555 etc (assuming broadcast listening?) :

    "VERSION = 0.0.4
    OS/ARCH = win32\x64
    PROCESS = monocle-gateway (PID=15164)
    TIMESTAMP = 2019-12-15T10:20:36.394Z


    MONOCLE GATEWAY SERVICE (Version: 0.0.4)

    [Monocle Starting]
    [Monocle Connecting]
    [Monocle Started]
    [RTSP Server Starting]
    [RTSP Server Listening] 0.0.0.0:8555 (RTSP)
    [RTSP Server Listening] 0.0.0.0:443 (RTSP-TLS)
    [RTSP Proxy Started] (PID=18916)
    [RTSP Server Listening] 0.0.0.0:8554 (PROXY)
    [RTSP Server Started]
    [Monocle Connected]
    [RTSP Server Registered]


    MONOCLE RTSP SERVICE - INITIALIZED

    FQDN = 8bba3f78-c3b7-4534-b1d6-fafcdc03e7f1.mproxy.io
    HOST = 192.168.0.14
    PORT = 443"

    ping the FQDN translates to the IP correctly - originally showed IP for a Virtual Ethernet… so disabled virtual ports on laptop
    ipconfig /flushdns
    ipconfg and restarted gateway
    this now showed the laptops correct IP of x.x.x.14 as above

    on DS-2CD2532F-IS Camera

    the video configuration on the physical camera is set as :
    main stream only for video (not video and audi)
    substrem only for video (not video and audio)

    substream set to :352x288, variable, highest quality, h.264
    mainstream same but higher res.

    on Monocole web config

    have configured multiple configs
    @noaudio, @tunnel/@no proxy, @proxy-tcp and trying all variants on ALEXA Show and monocole - still same - “not responding”

    strings as below with settings which I have attempted - using varity of BASIC vs DIGEST, proxy TCP in lieu of UDP and also stream channels - password is long but simple using alpha and numerics:

    MAIN channel ok on VLC - not working on SHOW8
    rtsp://192.168.0.32:555/video.h264
    BASICH264NONE192*192@noaudio@tunnel

    MAIN channel ok on VLC - not working on SHOW8
    rtsp://192.168.0.32:555/Streaming/Channels/101
    BASICH264NONE192*192@noaudio@proxy-tcp

    Sub channel ok on VLC - not working on SHOW8
    rtsp://192.168.0.32:555/Streaming/channels/102
    BASICH264NONE192*192@noaudio@proxy

    Sub channel with DIGEST - not working anywhere.
    rtsp://192.168.0.32:555/Streaming/channels/102
    DIGESTH264NONE192*192@noaudio@proxy-tcp

    lost for ideas…
    disabled kaspersky also and Thought id try the other cameras - (UK ones not the grey cam)
    which was configured as:

    SideCam
    Manufacturer:HikvisionModel:DS-2CD2142-FWD-i
    rtsp://192.168.0.34:557/Streaming/channels/102)
    BASICH264NONE192*192@noaudio@tunnel

    this wasnt working before… it started showing up on the SHOW8!! (takes a few seconds to start)

    Issue therefore isnt the frmware or grey v UK
    you NEED the gateway
    you NEED to disable firewall (will figure out if 443 or the cam ports n a bit)

    I now have cams working ok as:

    Manufacturer:HikvisionModel:DS-2CD2532F-IS
    rtsp://192.168.0.32:555/Streaming/channels/102
    BASICH264NONE192*192@noaudio@tunnel

    Manufacturer:HikvisionModel:DS-2CD2532F-IS
    rtsp://192.168.0.33:556/Streaming/channels/102
    BASICH264NONE192*192@noaudio@tunnel

    Manufacturer:HikvisionModel:DS-2CD2142-FWD-i
    rtsp://192.168.0.34:557/Streaming/channels/102
    BASICH264NONE192*192@noaudio@tunnel

    will try to up the sub stream resolution as main stream displays black (prob cos resolution too high)
    re-enabled the VM network cards and fushed DNS -the cams still work…

    therefore all along it was firewall… sigh!
    now to try and get my DANMINI doorbell to work… see if ti generates a RTSP stream to capture…

    Hope this helps someone!"



  • This post is deleted!

Log in to reply