Wyze Cam



  • I have a Wyze Cam and need help to make it work with Monocle. I am using Echo Show and would like to stream video using RTSP. I have the camera with RTSP firmware. I have verified the stream on VLC. But Echo Show does not play the stream. However, in the Monocle Log, I do see last view activity timestamps. Please help!



  • Wyze has its own native app integration that works. Is there a reason you are using Moncle? Generally curious as I’ve had a lot of trouble trying to get Monocle to work for various cameras that I ended up just using the manufacturers app / skill on the Show.



  • Hola, hace un par de dias compre el echo show 5 y además un par de cámaras wyze cam V2, al buscar el skill como wyze me arrojo únicamente el skill de monocle, intente configurar y descargue el monocle gataway, sin embargo al enviar el comando a alexa me indica que la cámara no responde.

    Sera la configuración en lo que he fallado?



  • This is a limitation of newer Amazon devices like the Show, which now require camera RSTP feeds to be encrypted and digitally signed.

    I got it working using Monocle Gateway with tag ‘@proxy-tcp’. Its a bit of a pain to set up and configure though. I was hoping it was faster than bringing up with the Wyze integration, but it seems to take just as long.



  • @tylechri any chance of posting your config?

    I’ve tried all the authentication methods.
    Set the resolution at 1920 x 1080.
    Set the video codec at H264
    Set the audio codec at AAC
    Set tags to @proxy-tcp

    But still no luck. Any help at this point would be appreciated.

    Thanks,

    Mike



  • @mjd239 I have: BASIC H264 AAC 1920*1080 @proxy-tcp

    Make sure you can ping your monocle fqdn that gets generated when the gateway starts and that it resolves to the internal Monocle gateway’s IP. I had to disable dns-rebind checking on my router for it to work. I think a more secure solution is to add a static DNS entry on your router for the gateway and keep rebind checking enabled, but I haven’t done that yet.



  • @tylechri Thanks for the info. I have to admit that the DNS stuff went over my head but I’ll look into it. Hopefully Google will provide…



  • I am trying to view the feed in Amazon Echo and want to overcome 10 minute time limit.



  • @s-archit

    We do not impose any timeout by default. As long as the “TIMEOUT” field for the camera settings is empty or zero in the Monocle web portal under your account, then in theory there should be no timeout. However, we have seen various camera makes and models behave differently. Its possible some cameras implement their own timeout in the stream or perhaps expecting some form of keep alive packet that Alexa is not implementing?



  • @tylechri I am still not having luck with what you mentioned. I have Wyze Cam. Below are the settings:

    URL: rtsp://192.168.x.x/live
    Authentication: Basic/Digest (tried both)
    Username and Password

    Resolution: 1920*1080 (16:9) [FHD] (1080p)
    Video Codec: H264
    Audio Codec: AAC
    Tag: @proxy-tcp

    Please help fix the issue.



  • @s-archit You settings there look fine. Do you see this in your Monocle Gateway logs?


    MONOCLE RTSP SERVICE - INITIALIZED
    -------------------------------------------------
    FQDN = xxxxxxx-xxxxx-xxxx-xxxx-xxxxxxxxxx.mproxy.io
    HOST = 192.168.1.10
    PORT = 443
    -------------------------------------------------
    

    Can you ping the FQDN listed in your log from a computer within the same network? Does the log show anything when you try to bring up a camera on the show/fire device?

    This goes into more detail on the issue I ran into: https://monoclecam.com/monocle-gateway/troubleshooting/dns-rebinding



  • Wanted to get any information on how Wyze cam integration works. E.g. how long does it take to start showing the feed, and is there any timeout that occurs?

    The long startup time and 10 min timeout in the native Wyze integration are my main reasons for trying Monocle to view my feeds instead.


Log in to reply