Hikvision DS-2CD2142FWD-IS with Show 8



  • Hi

    I have set up a Gateway as I assuming the Show 8 has the same requirements as the show 5? The Gateway initialises as expected.

    I have set up my camera to be 1920x1080 with the following settings:

    Screenshot 2019-12-18 at 02.00.22.png

    And my camera like this in monocle:

    Screenshot 2019-12-18 at 02.04.26.png

    I have tested the feed in VLC which works perfectly. I have also set a simple password

    The Gateway log doesn’t seem to show anything beyond this when trying to view a camera on the Show8:

    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Driveway
    -------------------------------------------------
     - NAME  : Driveway
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.16.16:554/Streaming/Channels/101/
     - UUID  : STREAM:0c92eb62-d3bd-441c-8a12-21805a41a235
     - SESS  : 3f86a696-ecce-4834-9819-5686e14fa866
     - MODIF : Wed Dec 18 2019 01:55:02 GMT+0000 (GMT)
     - TAGS  : @tunnel
    -------------------------------------------------
    

    Its like the stream wont initialise but I have no idea why. I have tried @proxy and @proxy-tcp and tey did not work

    Any ideas where to go next?

    Thanks!



  • @ijhammo

    Are you getting any additional log data after the “INITIALIZE RTSP STREAM” section after asking Alexa to show the camera stream? We would expect to see a lot more data after that where the RTSP stream begins negotiating between the camera and Alexa device via the gateway.

    Thanks, Robert



  • When calling up the camera on the show 8 i just get this in the gateway console:

    -------------------------------------------------
    MONOCLE GATEWAY SERVICE         (Version: 0.0.4)
    -------------------------------------------------
    [Monocle Starting]
    [Monocle Connecting]
    [Monocle Started]
    [RTSP Server Starting]
    [RTSP Server Listening] 0.0.0.0:8555 (RTSP)
    [RTSP Server Listening] 0.0.0.0:443 (RTSP-TLS)
    [RTSP Proxy Started] (PID=19058)
    [RTSP Server Listening] 0.0.0.0:8554 (PROXY)
    [RTSP Server Started]
    [Monocle Connected]
    [RTSP Server Registered]
    
    -------------------------------------------------
    MONOCLE RTSP SERVICE - INITIALIZED
    -------------------------------------------------
    FQDN = 1b010146-b353-4465-bbaa-2dad725ded63.mproxy.io
    HOST = 192.168.16.6
    PORT = 443
    -------------------------------------------------
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Driveway
    -------------------------------------------------
     - NAME  : Driveway
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.16.16:554/Streaming/Channels/101/
     - UUID  : STREAM:0c92eb62-d3bd-441c-8a12-21805a41a235
     - SESS  : 94a67e29-a9c1-46d3-a90a-50a568360b8f
     - MODIF : Wed Dec 18 2019 01:55:02 GMT+0000 (GMT)
     - TAGS  : @tunnel
    -------------------------------------------------
    
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Driveway
    -------------------------------------------------
     - NAME  : Driveway
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.16.16:554/Streaming/Channels/101/
     - UUID  : STREAM:0c92eb62-d3bd-441c-8a12-21805a41a235
     - SESS  : eb76d5f9-3bbc-43c7-ab04-26a966634a56
     - MODIF : Wed Dec 18 2019 01:55:02 GMT+0000 (GMT)
     - TAGS  : @tunnel
    -------------------------------------------------
    
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Driveway
    -------------------------------------------------
     - NAME  : Driveway
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.16.16:554/Streaming/Channels/101/
     - UUID  : STREAM:0c92eb62-d3bd-441c-8a12-21805a41a235
     - SESS  : 3f86a696-ecce-4834-9819-5686e14fa866
     - MODIF : Wed Dec 18 2019 01:55:02 GMT+0000 (GMT)
     - TAGS  : @tunnel
    -------------------------------------------------
    


  • If I try it with Proxy I get this:

    -------------------------------------------------
    RTSP STREAM MODIFIED:  Driveway
      Any existing RTSP steams will be shut down     
      and a new stream instance will be registered.  
    -------------------------------------------------
    
    2019-12-19T23:38:58.590Z [DEBUG] <RTSP-PROXY> [REQUEST]  --> [DEREGISTER] rtsp://192.168.16.16:554/Streaming/Channels/101/
    2019-12-19T23:38:58.590Z [TRACE] <RTSP-PROXY> [REQUEST]  --> [HEADERS] {
      "cseq": "1",
      "transport": "reuse_connection=0;preferred_delivery_protocol=udp;proxy_url_suffix=STREAM:0c92eb62-d3bd-441c-8a12-21805a41a235"
    }
    2019-12-19T23:38:58.591Z [DEBUG] <RTSP-PROXY> [RESPONSE] <-- [451 (Invalid parameter)] <cseq=1> (session=undefined)
    2019-12-19T23:38:58.591Z [TRACE] <RTSP-PROXY> [RESPONSE] <-- [HEADERS] {
      "cseq": "1",
      "date": "Thu, Dec 19 2019 23:38:58 GMT"
    }
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Driveway
    -------------------------------------------------
     - NAME  : Driveway
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.16.16:554/Streaming/Channels/101/
     - UUID  : STREAM:0c92eb62-d3bd-441c-8a12-21805a41a235
     - SESS  : 4191e24e-8ec3-41fb-81eb-539fbf7418b7
     - MODIF : Thu Dec 19 2019 23:38:46 GMT+0000 (GMT)
     - TAGS  : @proxy,@tunnel
    -------------------------------------------------
    
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Driveway
    -------------------------------------------------
     - NAME  : Driveway
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.16.16:554/Streaming/Channels/101/
     - UUID  : STREAM:0c92eb62-d3bd-441c-8a12-21805a41a235
     - SESS  : ee5c3123-272d-4ee9-89ee-cb8754b50b1f
     - MODIF : Thu Dec 19 2019 23:38:46 GMT+0000 (GMT)
     - TAGS  : @proxy,@tunnel
    -------------------------------------------------
    
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Driveway
    -------------------------------------------------
     - NAME  : Driveway
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.16.16:554/Streaming/Channels/101/
     - UUID  : STREAM:0c92eb62-d3bd-441c-8a12-21805a41a235
     - SESS  : 5ab58460-ee9c-4058-a21d-41180bc878ae
     - MODIF : Thu Dec 19 2019 23:40:11 GMT+0000 (GMT)
     - TAGS  : @proxy-tcp,@tunnel
    -------------------------------------------------
    


  • Are there any other log files I can look at for more clues?



  • I have tried running the gateway on a different laptop and get the same result. When making the request I get three copies of the “INITIALIZE RTSP STREAM:” message in the gateway log but nothing else.

    Are there any switches for more verbose logging?



  • Yep this is exactly the same issue that I’m having



  • I dont think this is a camera issue but a gateway<->Show 8 issue @Monocle ?



  • @ijhammo Did you get anywhere at all with this ? just picking this up again after the Christmas madness ive not managed any progress at all



  • Had similar issue. Gateway with @tunnel tag, substream 2, Digest, DNS setting (Fritzbox), simple password, fixing port 443 worked for me with Hikvision and Trendnet cameras.
    Do you use Fritzbox? Did you consider the DNS seeting (allow "mproxy.io”.)
    Try substream 2 .
    Any issue with port 443 blocked by other application?



  • Hi, I have a Mikrotik router and dont have any other problems with 443 (that I am aware of) Is that DNS setting specific to Fritzbox?

    I tried substream 2 and still get nothing 😞

    I am at the point now where I am looking at getting rid of the Hikvision cameras for ones that work natively (like the imou ones)



  • @ijhammo said in Hikvision DS-2CD2142FWD-IS with Show 8:

    Fritzbox

    By default Fritz-box does block something called DNS REBINDING. This will prevent devices on your local network from resolving the unique DNS hostname that is assigned to your monocle gateway instance. Other routers such as PFSense/DDWRT/etc also can implement this protection as well. It’s trying to prevent DNS hostnames from resolving to local/private IP address inside your network. However in the case of Monocle, we are trying to allow the Alexa devices to resolve to your running instance of Monocle Gateway running inside your network to allow you to keep all your audio/video streaming data entirely inside your network.

    More details here:
    https://monoclecam.com/monocle-gateway/troubleshooting/dns-rebinding

    Thanks, Robert



  • @ijhammo

    Based on the log snippets you posted, it does look like the Alexa devices are not able to connect to the Monocle Gateway instance. We should see additional lines of log data showing TCP connections and RTSP negotiations between the Alexa devices and the Monocle Gateway and then out to the IP cameras.

    So the typical problems for these symptoms are :

    • DNS REBINDING - the network is not allowing the unique hostname (FQDN) to be resolved to your local/private IP address running the gateway instance
    • Alexa device and Monocle Gateway are not on the same network or one is on a Guest network or isolated VLAN.
    • Something is already using port 443 or port 443 is getting blocked by a firewall on the machine running the Monocle Gateway software.

    Thanks, Robert


Log in to reply