Alexa "Camera Not Responding"



  • Hi - I have had 3 FDT indoor cameras (FD7901). As well as 1 FDT outdoor (FD7903W).

    I have tested all of the URLs in VLC. And they work. Theybare all h264 codec. The audio codecs do not work, so i have tried No Audio in the portal as well as when I ran the gateway with the @noaudio tag.

    The logs in both gateway and the recent xonnection history in the portal look ok, but my Echo Show 5 days it cannot connext to any otlf the cameras.

    I appreciate any guidance. Please let me know id more info is needed.



  • Bump - Can anyone help me?



  • @dmoney517 said in Alexa "Camera Not Responding":

    i have the same problem with the N810 (chinese cam) model: Ra50x20…



  • @dmoney517

    Sorry just now seeing this thread …

    Feel free to post the log output from monocle gateway that captures the connection attempt after you ask Alexa to view your camera feed.

    Thanks, Robert



  • Thank you - Please see below.

     ******************************************************************
     *             __  __  ___  _  _  ___   ___ _    ___              *
     *            |  \/  |/ _ \| \| |/ _ \ / __| |  | __|             *
     *            | |\/| | (_) | .` | (_) | (__| |__| _|              *
     *            |_|  |_|\___/|_|\_|\___/ \___|____|___|             *
     *                                                                *
     ******************************************************************
    
    
    -------------------------------------------------
    MONOCLE RUNTIME ENVIRONMENT
    -------------------------------------------------
    VERSION   = 0.0.4
    OS/ARCH   = win32\x64
    PROCESS   = monocle-gateway (PID=7600)
    TIMESTAMP = 2020-01-25T22:10:24.169Z
    
    -------------------------------------------------
    MONOCLE GATEWAY SERVICE         (Version: 0.0.4)
    -------------------------------------------------
    [Monocle Starting]
    [Monocle Connecting]
    [Monocle Started]
    [RTSP Server Starting]
    [RTSP Server Listening] 0.0.0.0:8555 (RTSP)
    [RTSP Server Listening] 0.0.0.0:443 (RTSP-TLS)
    [RTSP Proxy Started] (PID=6712)
    [RTSP Server Listening] 0.0.0.0:8554 (PROXY)
    [RTSP Server Started]
    [Monocle Connected]
    [RTSP Server Registered]
    
    -------------------------------------------------
    MONOCLE RTSP SERVICE - INITIALIZED
    -------------------------------------------------
    FQDN = d3c2cdba-fe00-458e-a06e-e19886dc814c.mproxy.io
    HOST = redacted
    PORT = 443
    -------------------------------------------------
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Driveway
    -------------------------------------------------
     - NAME  : Driveway
     - LABEL : PRIMARY
     - URL   : rtsp://192.168.0.120:554/12
     - UUID  : STREAM:d251bc22-1a12-423c-888c-8d8e77848699
     - SESS  : 61c14015-63b1-44dc-82bb-e1590318467a
     - MODIF : Wed Jan 01 2020 23:24:25 GMT-0500 (Eastern Standard Time)
     - TAGS  : @noaudio,@tunnel
    -------------------------------------------------
    


  • @dmoney517

    It looks like the Alexa device is making the request for the camera stream and Monocle is getting the request and sending down the stream info to the gateway, but the Alexa device is never connecting to the gateway to play the camera stream. After the “INITIALIZE RTSP STREAM” block in the log you should see RTSP /TCP connections coming in from the Alexa device.

    So this is most likely a networking issue.

    • 1.) Make sure the Alexa device and Monocle Gateway are on the same network. (Not on a Guest Wifi or on separate VLANs).
    • 2.) Make sure the computer running the Monocle Gateway does not have a firewall blocking port 443 or another service already running on the computer using (listening on) port 443.
    • 3.) It could be a case of your router protecting against “DNS REBINDING”. Please see: https://monoclecam.com/monocle-gateway/troubleshooting/dns-rebinding


  • @Monocle
    Thank you for the reply. I have both the PC running the Gateway as well as the Show 5 on the same network.

    Note - I have Google Wifi - and confirmed both devices are on the same AP.

    I opened 443 and the device running the Gateway.

    Confirmed firewall is allowing the monocle apps (even temporarily turned if off just to test).

    I was able to ping the dns assignment and it responded with the proper IP for the device running the Gateway.

    Still unable to connect.

    Please let me kbow of there is anything I can check.


Log in to reply