Synology Surveillance Station [SOLVED]



  • Trying to set up a RTSP feed through Monocle so I can access my camera with Alexa. I get the RSTP feed from the camera but when I insert it into the Monocle Feed is states “Username and password should not be included in the URL, see Authentication settings below.”

    I can cut and past the RSTP over HTTP. I do not get an error message. Alexa recognizes it but says the camera is not responding.

    Has anyone successfully linked Surveillance Station to Alexa? What am I doing wrong…





  • You need to select ‘Digest’ for your authentication settings then take the data from your rtsp:// line after the slashes and before the colon and put it into username, then after the colon and before the @ and put it as your password. Then delete everything between the // and the @ that you just copy-pasted. This should hopefully solve your problem and get you one step closer to making the secure connection.



  • @Auspician

    Thanks for posting your answer. This is correct, the USERNAME and PASSWORD need to be removed from the URL and placed in the separate fields in the Monocle web portal.

    rtsp://USERNAME:PASSWORD@HOST_ADDRESS:HOST_PORT/STREAM_PATH

    Thanks, Robert



  • @Monocle I tried it still no sucess. My feed is:

    rtsp://XXX.XXX.XXX.XXX:554/Sms=12.unicast

    The x’s are my outside ip address.

    I cut and pasted the username and password as noted…

    Not sure what i am doing wrong.


Log in to reply