Ding! The camera isn't responding. [SOLVED]



  • I had been using Monocle without any problems for a while with all 10 of my cameras with all devices - my Echo Spot, Echo 5 and Echo 8.

    However, now when I ask for any camera via any device, I get the above (subject heading) response. All cameras are working fine, with BlueIris and accessible via RTSP using VLC.

    Watching the information given by monocle-gateway on my cmd terminal window there are no errors and indeed, it appears to show that the camera is being streamed as it usually has done before.

    The only changes I’ve had are the usual Win10 updates, Alexa device automatic updates and a change of ISP. I have checked Monocle is in the Firewall list and have even turned off Firewall to test, to no avail.

    Anyone else with any problems? Or any ideas where to go from here?



  • There was an issue earlier in the week, SSL cert had expired, same result for many people.
    Since has been fixed, but I had to restart my monocle gateway afterwards to get my cameras back to working with Alexa.
    Alexa had recommended, before I know about the SSL cert had expired, to disable and re-enable the Skill.



  • bk has it right, it was an ssl error. Unfortunately I had the same issue while trying to get my camera’s setup, and I’m still running into the same difficulty. My cameras all work via VLC and I have the monocle-gateway setup on my Synology server, but no matter what settings I try I am unable to get alexa to ever connect and she always plays the “Ding! The camera isn’t responding” message.

    I’d love to know what settings you are using and what tips/tricks you have used to make this work correctly. Thanks!



  • here’s a screen grab from my monocle console…
    monocle-Capture.JPG
    I’m using unifi protect with a CKGen2.
    The two variables I had to sort out after getting the monocle gateway running was the authentication and the tag… turns out don’t need the authentication with the unifi stuff, it’s in the hash of the url… and needed the @tunnel.
    I’ve run the gateway on two different machines, no problem on either.
    I have not yet installed it as a service, just running from an elevated batch file.



  • Thanks for the replies and the info re the SSL.

    I have restarted Monocle no end of times rebooting the server PC it’s running on. No change.
    I just now tried deleting the cameras out of Alexa by going to Devices in the app and deleting them.
    I then asked Alexa to Discover my devices.
    To my excitement, Alexa discovered all 10 cameras.

    Sadly, my excitement was short lived because I still have the familiar Ding… etc. when I ask her to show me any camera.
    I don’t get it. So the cameras can be seen, they were discovered. But they’re “not responding”?

    I’m at a loss what else to try at the moment. <scratches head>

    Auspician - I didn’t really do anything special. Just installed Monocle as instructed. Set up the cameras (with a little help on a couple of the camera settings here on the forum in the early days) and asked Alexa to discover the devices then show me the cameras. They - just worked. Maybe if I ever discover the reason why they no longer work, we’ll fix your problem too.



  • Are you running it as a service or just from CMD like me?
    Have you tried the different tags to see which one might work for you?
    Check the port?
    They have a trouble shoot guide on the website… have you been through that?



  • @Legsmaniac

    Post your Monocle gateway log from a fresh restart up until you ask Alexa for a single camera and it fails.
    I can review the log and see if there is anything obvious going wrong.

    Thanks, Robert



  • @bk said in Ding! The camera isn't responding.:

    There was an issue earlier in the week, SSL cert had expired, same result for many people.
    Since has been fixed, but I had to restart my monocle gateway afterwards to get my cameras back to working with Alexa.
    Alexa had recommended, before I know about the SSL cert had expired, to disable and re-enable the Skill.

    I think that is just Amazon’s blanket support response to any Alexa skill issue. Similar to IT telling you to reboot your computer 🙂
    The SSL certificate issue (which has been resolved) only affected the ability to LINK your Monocle account from the Alexa app. All other aspects of Monocle were and still are working fine to our knowledge.

    Thanks, Robert



  • @Monocle said in Ding! The camera isn't responding.:

    @Legsmaniac

    Post your Monocle gateway log from a fresh restart up until you ask Alexa for a single camera and it fails.
    I can review the log and see if there is anything obvious going wrong.

    Thanks, Robert

    OK, log as follows…

    
     ******************************************************************
     *             __  __  ___  _  _  ___   ___ _    ___              *
     *            |  \/  |/ _ \| \| |/ _ \ / __| |  | __|             *
     *            | |\/| | (_) | .` | (_) | (__| |__| _|              *
     *            |_|  |_|\___/|_|\_|\___/ \___|____|___|             *
     *                                                                *
     ******************************************************************
    
    
    -------------------------------------------------
    MONOCLE RUNTIME ENVIRONMENT
    -------------------------------------------------
    VERSION   = 0.0.4
    OS/ARCH   = win32\ia32
    PROCESS   = monocle-gateway (PID=1628)
    TIMESTAMP = 2020-02-28T22:19:17.814Z
    
    -------------------------------------------------
    MONOCLE GATEWAY SERVICE         (Version: 0.0.4)
    -------------------------------------------------
    [Monocle Starting]
    [Monocle Connecting]
    [Monocle Started]
    [RTSP Server Starting]
    [RTSP Server Listening] 0.0.0.0:8555 (RTSP)
    [RTSP Server Listening] 0.0.0.0:443 (RTSP-TLS)
    [RTSP Proxy Started] (PID=5504)
    [RTSP Server Listening] 0.0.0.0:8554 (PROXY)
    [RTSP Server Started]
    [Monocle Connected]
    [RTSP Server Registered]
    
    -------------------------------------------------
    MONOCLE RTSP SERVICE - INITIALIZED
    -------------------------------------------------
    FQDN = 49f15227-0a11-41b4-a8c4-xxxxxxxxxxx.mproxy.io
    HOST = xxx.xxx.x.xxx
    PORT = 443
    -------------------------------------------------
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Door Camera
    -------------------------------------------------
     - NAME  : Door Camera
     - LABEL : PRIMARY
     - URL   : rtsp://xxx.xxx.x.xxx:554/onvif1
     - UUID  : STREAM:a62bb3b5xxxxxxxxxxxxxxxxxxxxxx
     - SESS  : 99489339-8a80-46ad-9824-xxxxxxxxxxxxxxx
     - MODIF : Fri Feb 28 2020 08:09:01 GMT+0000 (GMT Standard Time)
     - TAGS  : @proxy
    -------------------------------------------------
    
    2020-02-28T22:19:25.604Z [INFO]  [RTSP PROXY] REGISTERING STREAM [Door Camera/PRIMARY]; (STREAM:a62bb3b5-d534-4a68-9e0e-xxxxxxxxxxxxxxxx)
    2020-02-28T22:19:25.609Z [DEBUG] <RTSP-PROXY> [REQUEST]  --> [REGISTER] rtsp://xxx.xxx.x.xxx:554/onvif1
    2020-02-28T22:19:25.609Z [TRACE] <RTSP-PROXY> [REQUEST]  --> [HEADERS] {
      "cseq": "1",
      "transport": "reuse_connection=0;preferred_delivery_protocol=udp;proxy_url_suffix=STREAM:a62bb3b5-d534-4a68-9e0e-xxxxxxxxxxxxx"
    }
    2020-02-28T22:19:25.610Z [DEBUG] <RTSP-PROXY> [RESPONSE] <-- [200 (OK)] <cseq=1> (session=undefined)
    2020-02-28T22:19:25.610Z [TRACE] <RTSP-PROXY> [RESPONSE] <-- [HEADERS] {
      "cseq": "1",
      "date": "Fri, Feb 28 2020 22:19:25 GMT"
    }
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Door Camera
    -------------------------------------------------
     - NAME  : Door Camera
     - LABEL : PRIMARY
     - URL   : rtsp://xxx.xxx.x.xxx:554/onvif1
     - UUID  : STREAM:a62bb3b5-d534-4a68-9e0e-xxxxxxxxxxxxx
     - SESS  : 26a81072-58dd-4e78-b762-xxxxxxxxxxxxx
     - MODIF : Fri Feb 28 2020 08:09:01 GMT+0000 (GMT Standard Time)
     - TAGS  : @proxy
    -------------------------------------------------
    
    
    -------------------------------------------------
    INITIALIZE RTSP STREAM:  Door Camera
    -------------------------------------------------
     - NAME  : Door Camera
     - LABEL : PRIMARY
     - URL   : rtsp://xxx.xxx.x.xxx:554/onvif1
     - UUID  : STREAM:a62bb3b5-d534-4a68-9e0e-xxxxxxxxxxxx
     - SESS  : 110ac7aa-9e1e-44ae-b76a-xxxxxxxxxxxxxx
     - MODIF : Fri Feb 28 2020 08:09:01 GMT+0000 (GMT Standard Time)
     - TAGS  : @proxy
    -------------------------------------------------
    
    2020-02-28T22:20:17.818Z [INFO]  [RTSP PROXY] STREAM [Door Camera/PRIMARY] WILL BE DE-REGISTERED IN 4 MINUTES
    2020-02-28T22:21:17.820Z [INFO]  [RTSP PROXY] STREAM [Door Camera/PRIMARY] WILL BE DE-REGISTERED IN 3 MINUTES
    2020-02-28T22:22:17.821Z [INFO]  [RTSP PROXY] STREAM [Door Camera/PRIMARY] WILL BE DE-REGISTERED IN 2 MINUTES
    2020-02-28T22:23:17.821Z [INFO]  [RTSP PROXY] STREAM [Door Camera/PRIMARY] WILL BE DE-REGISTERED IN 1 MINUTES
    

    Hmmmmm, I’ve noticed it shows twice? I don’t remember that before?
    I have now tried it on another PC. I have checked C++ Redists all present and correct (Repaired in fact). I have downloaded and tried both x86 and x64.
    Always the same problem.



  • @Legsmaniac said in Ding! The camera isn't responding.:

    Hmmmmm, I’ve noticed it shows twice? I don’t remember that before?

    It will show up to 3 times per request when it’s failing to stream – Alexa will make up to three attempts to get the stream.

    It looks like the problem is that the Alexa device cannot access the Monocle Gateway. After the “INITIALIZE RTSP STREAM” messages we would expect to see connection attempts from the Alexa device.

    Can you ping your host (FQDN) address “49f15227-0a11-41b4-a8c4-xxxxxxxxxxx.mproxy.io” from another computer and make sure it is getting resolved to the correct private IP address where the Monocle Gateway is running?

    Also make sure the Alexa devices are on the same network and not on a Guest WiFi or alternate VLAN.
    Check Windows firewall to make sure it will allow access inbound on port 443.

    Thanks, Robert



  • Thanks for your reply.

    I tried as you suggest, pinging the FQDN address from another PC with the result “Ping request could not find host f58fca0d-d9dd-4f9d-b76d-xxxxxxxxxxxx.mproxy.io. Please check the name and try again.”
    I tried pinging the same address on the same computer Monocle Gateway is running, with the same result.

    Everything is on the same network.
    Not sure I’d need bother checking the Firewall because I already mentioned I turned the Firewall off temporarily and still no go.

    Arrrgghhhhhhh!!!

    Remember also I said I’d changed ISP. With that change came a new router. That said, I have set up the new router with exactly the same settings as I’d had in the router before. As far as I’m aware. Everything else is working, including Home Assistant, Node Red, Configurator, FTP Server, all which are running fine of the server PC. Sadly, I can’t swap the old router back to test as it doesn’t work at the moment. I’d need to find the new ISP log in details first which means contacting them. I should still get it working on this router anyhow.



  • A few more thoughts…

    You say it looks like the Alexa device cannot access the Monocle Gateway.
    If that’s the case, how come when I check online at my cameras set up on Monocle via my Monocle log in does it say underneath the camera listing “Last viewed…” and it gives the date and time I just attempted to access the camera? So for example, if I say Alexa, show me the door camera, Alexa responds with OK and the screen changes to a fuzzy image of the door camera view (presumably cached from when it used to work?), it says “Waiting for camera…” in text across the image and the 4 blue dots riding across the bottom. After about 3 seconds I get the Ding… The camera isn’t responding. Then I check online on my log in and it says the camera has just been viewed. (Oh No It Hasn’t!)

    I don’t know how your system works but I’m hoping that with this new information, you may be able to shed some light on this. Thanks for your continued help in this.



  • And a final conclusion…

    Yep, that’s right. Final. This means I’ve sorted it. Well, no, not quite “sorted” but sussed anyhow.
    It WAS the new ISP supplied router. Even with the router’s internal Firewall turned off, it was blocking mproxy.io
    I discovered the logs in the new router which showed “possible attack by…” and gave the mproxy.io URL as the incoming address. It did say it was only “data” though, as in (I assumed) only information so I had to contact the ISP this morning and ask them for my user/pass VDSL2 log in details which they promptly supplied. I then popped my reliable and faithful Asus router on, typed in the new log in details, got online and tested Monocle Gateway. Worked straight away.

    I rather suspect this could be the problem for a good many other users trying to get Monocle working too, especially those who stick with their ISP supplied routers, most of which are generally cr*p hence why I prefer my own. Unless there’s a way you can change anything to prevent the URL being blocked?

    Anyway, thanks for your help and suggestions and sorry, it was kinda my fault in the end. My fault for changing ISPs and using their rubbish router! LOL As long as I use my own router, I’m sorted. There was a reason why I needed to use their router though but hey ho. We can’t have everything, I guess. 😀



  • @Legsmaniac said in Ding! The camera isn't responding.:

    You say it looks like the Alexa device cannot access the Monocle Gateway.
    If that’s the case, how come when I check online at my cameras set up on Monocle via my Monocle log in does it say underneath the camera listing “Last viewed…” and it gives the date and time I just attempted to access the camera?

    When you make the voice request via an Alexa device, she turns around and calls into some Amazon Alexa cloud service to have the request fulfilled. The Alexa cloud service determined which skill to route the request to, Monocle in this case and then forward the request from Alexa cloud servers to Monocle cloud servers. Monocle (cloud servers) then return the correct IP camera connectivity details to the Alexa cloud service and she then sends that information back down to the requesting Alexa device. So as you can see, the Monocle cloud servers are successfully getting the initial request and handling it just fine.

    However, and here is where it was breaking down, the IP camera connectivity information that we send back to the Alexa system contains information on how to connect to your local instance of the Monocle Gateway running inside your network. The Alexa device where you initiated the voice request will use this connection information to attempt to connect to the camera stream. At the same time we also send an instruction to your Monocle Gateway instance directly from our servers to notify and prepare the gateway for the requested IP camera stream. (this is where you see “INITIALIZE RTSP STREAM” log messages). So based on the logs everything is working perfectly except the final step — your local Alexa device making a connection to your local Monocle Gateway instance.

    And based on your subsequent comments it looks like it was a DNS REBINDING issue where the new router was blocking DNS requests to “*.mproxy.io”. Alexa devices will only connect to real DNS hostnames with valid SSL certificates – hence the need for a real domain name like “*.mproxy.io”.

    Thanks, Robert



  • @Legsmaniac said in Ding! The camera isn't responding.:

    And a final conclusion…

    Yep, that’s right. Final. This means I’ve sorted it. Well, no, not quite “sorted” but sussed anyhow.
    It WAS the new ISP supplied router. Even with the router’s internal Firewall turned off, it was blocking mproxy.io
    I discovered the logs in the new router which showed “possible attack by…” and gave the mproxy.io URL as the incoming address. It did say it was only “data” though, as in (I assumed) only information so I had to contact the ISP this morning and ask them for my user/pass VDSL2 log in details which they promptly supplied. I then popped my reliable and faithful Asus router on, typed in the new log in details, got online and tested Monocle Gateway. Worked straight away.

    I rather suspect this could be the problem for a good many other users trying to get Monocle working too, especially those who stick with their ISP supplied routers, most of which are generally cr*p hence why I prefer my own. Unless there’s a way you can change anything to prevent the URL being blocked?

    Anyway, thanks for your help and suggestions and sorry, it was kinda my fault in the end. My fault for changing ISPs and using their rubbish router! LOL As long as I use my own router, I’m sorted. There was a reason why I needed to use their router though but hey ho. We can’t have everything, I guess. 😀

    Well fault is not really the right term – this is a complicated issue where Amazon is forcing us to use DNS hostnames and SSL certificates for any type of camera stream for Alexa. But we want users to be able to maintain the streams locally and not route audio/video to a cloud server which could involve privacy concerns, latency issues and wasted bandwidth. So in the end its sort of a Catch-22 situation where we have to provide resolvable DNS records with valid SSL certificates but we want it to resolve to a private/internal endpoint (your Monocle gateway instance) – but some ISPs and many routers consider resolving DNS records to a private/internal IP address a threat and they block these requests (a.k.a. DNS REBINDING).

    You might check on your new router to see if there is a way to disable this or better yet define exceptions only allowing “*.mproxy.io” DNS resolutions through. In the case of some ISP’s they are blocking it further up the chain in their own DNS servers – so you could try changing the DNS servers that your router uses to some other DNS provider (Like Google or OpenDNS) instead of using the details DNS servers from the ISP.

    Thanks, Robert



  • Thank you for the informative explanation of the process of Monocle Gateway and Alexa. I can understand it better now.

    Alas, as yet I have been unable to find any settings to change within the router itself to allow mproxy.io through or prevent it’s blocking. It’s definitely being blocked in/at the router as the router’s own internal logs state as such. And it’s certainly not being blocked “further up the chain” as you say, as I have turned off completely the “safe mode” on my online account. In any case, if it was being blocked in this manner, it would also be blocked for my Asus router. I have been chatting to the Tech team at the ISP to see if there’s any way around it. Not holding my breath but we’ll see. For now, I’ll stick to using my own Asus router, at least it works.

    Again, many thanks for all the help and info.


Log in to reply