Cannot view channel zero using RTSP



  • Hi,

    First can I say that your site is excellent. Monocle allows me to view my 4 IP cameras on all of the Amazon Alexa devices around my home. Brilliant.

    I am now trying to view the channel zero feed from my Hikvision NVR Model DS-7608NI-E2 / 8P/A. As you might know, some NVR’s have a channel-zero feed that shows multiple camera images on the same image.

    I have tested the RTSP URL below in VLC Player and I can see my channel-zero feed no problem. The IP address of my actual NVR is .57. The link below works in VLC player as a Network Stream, but it doesnt work when I create a new camera in Monocle.

    rtsp://192.168.1.57:554/Streaming/Channels/001/ - This doesn’t work in Monocle but does work in VLC player

    In the example below, .101 is the IP address of a Hikvision IP cam which is on the same NVR (I only have one NVR). This works fine in Monocle and I can see the camera on my Alexa’s.
    rtsp://192.168.1.101:554/Streaming/Channels/101/ - This DOES work in Monocle and does work in VLC player

    When I try and view the channel zero on Alexa she says “Hmm - the camera isnt responding”.

    I have the correct password in the Monocle camera settings. I’ve tried everything. I have added the new camera to my Alexa. It appears in the camera devices on the Alexa App. I added the channel zero to Alexa exactly the same as I added the other 4 cams which all work fine with Alexa.

    I understand the channel zero on my NVR isn’t actually a camera, but it does have a valid RTSP address and the channel zero RTSP feed does work in VLC player.

    Is this something that Monocle support are aware of? Is there any reason why the RTSP address for my channel zero doesnt work with Monocle?

    Like I say, I think the Monocle website and service is great. I’m impressed I can view my four IP cams on my Alexa’s. It would be a bonus if I could view my channel zero feed too.

    Thank you for your time.



  • Hi,

    I still havent managed to get my Hikvision channel zero feed to work on my Alexa shows.

    For info, all 3 URL’s below show my channel zero with VLC Player but not on Alexa.

    My main camera feeds still work fine on Alexa Shows .e.g rtsp://192.168.1.101:554/Streaming/Channels/101/ works fine (.101 is actual camera).

    The resolution of my channel zero is 704 x 576 so not very high resolution (my Alexa shows should be able to hande this resolution easily).

    These work on VLC Player but not on Alexa.
    rtsp://192.168.1.57:554/Streaming/Channels/001/
    rtsp://192.168.1.57:554/Streaming/Channels/001?videocodec=jpeg&Transport=HTTP
    rtsp://192.168.1.57:554/Streaming/Channels/001?videocodec=jpeg&Transport=multicast

    I tried adding some additional parameters to the rtsp URL to see if that made any difference (it didn’t).

    Would still appreciate some tips please.


Log in to reply