Ubiquiti G3 cameras with Echo Show 8



  • Hi,

    I have tried every single step and guide still to no avail, I have successfully got the video streams working from cameras and can confirm that the Gateway was installed and running successfully on my MacBook, relevant API tags added too

    Perhaps wrongly I assumed that the Echo Show 8 would be supported as are the rest but could this be the problem of an unsupported device?

    The only response I can get from Alexa is “Hmmm the device isn’t responding” it’s so frustrating as for the last year we have used a cheap Neos cam which has worked flawlessly, I naively thought investing in Ubiquiti would mean unparalleled features, wrong!

    Hopefully someone can help before the wife loses her mind as we use the camera in question as a baby monitor whilst downstairs at night,

    Regards



  • @AndyAbbott

    The Echo Show 8 does work, but is limited to 1080P resolution streams. Any higher and it just fails. I don’t have a Ubiquiti camera, but many IP cameras provide a secondary lower resolution stream – you might try that or try lowering the resolution to see if you can get it working.

    Also fee free to post the output from your Monocle Gateway log and we can see if there are any other obvious errors.

    Thanks, Robert



  • Thank you so much for you speedy reply, thoroughly impressed with the service levels for a free app, which is certainly more than can be said for the thousands of pounds worth of Ubiquiti products I’ve bought to have my support tickets all ignored!

    The camera in question is a G3, the max resolution supported is 1080p so I don’t think this is the issue, I have the camera set to 30fps and 6000 bitrate, would this affect things at all?

    I’ve uninstalled absolutely everything to see if doing things fresh makes a difference, as soo as I get the gateway back up and running I’ll post it to see if you can make any sense of what is happening,

    Thanks again



  • Are you able to open the stream from another computer in your network via VLC? Is the camera and Echo on the same subnet? I have 5 different Ubiquiti cameras with a gateway running on an old Linux box with no issues.



  • @LosBoricua

    All on the same subnet, I’m able to view the stream on VLC on my MacBook Pro no problems, I’m wondering if it’s something to do with the hardware, just upgraded to the UDM pro



  • Weird, I have a UDMP Pro with a G3 Bullet, 2 G3 Dome, G4 Beta and a G4 Pro. I actually have a different subnet for all my IoT including cameras. I only had issues with the G4 camera because the highest setting is 2k and 4k so I had to turn them down to 720p since the Echo show 8 can’t process more than that. On your gateway, can you see the request coming(in the log files)?



  • @LosBoricua

    Aha, that might be an oversight on my part! I’ve been trying to output 1080p from the RTSP feed to the Show, I didn’t think that the resolution on that would be lower 🤦🏻♂

    I’ll try taking it down to 720p and see if that clears the issue, the gateway seems to be getting the information just fine. Out of interest what do you do for the username and password? I’ve set up a ‘view only’ user on the UDM called MonAlx with a basic password but not sure if that’s confusing things on the Monocle side?



  • Well I put them down to 720p on the 2k and 4k because I don’t have the option in UDM for 1080p. My G3 Bullet and Dome does allow me to set them to 1080p since it is the Max resolution.



  • These are my setting:
    MonoClecam
    Monosettings.png

    UDMPro
    Ubiquiti.png



  • @LosBoricua

    That’s great, you have no authentication which I was hoping to try to make things simpler, thanks so much for posting these,

    Just on something else at the moment but I’ll try again in a couple of hours,

    What I don’t understand is how the RTSP feed is outputting at 1080p but the Alexa show 8 is only 720p resolution? I thought that could have been the issue, what are you running the gateway on? Did you have to input any special port forwarding on the UDM as I have IPS turned on?



  • The Eco Show 8 Screen output is only 720p but is able to process a max of 1080p stream but it is downgraded to 720p because of the screen. My G4 camera I have to set them at 720p because UDM Pro does not give you the option for 1080P
    Ubiquiti2.png

    Yes, you have to run authentication off. I’m not bothered by it since I have everything on its own subnet pretty locked down and using the VPN gateway. I had a Dell 3020 Micro that I put a cheap SSD in it, installed Ubuntu, loaded up the gateway, and also loaded Pihole for my DNS Adblocking.



  • @LosBoricua

    Still not working, I have copied the exact settings now, it’s a G3 not the pro but I have set the feed to 1080 like you said, Gateway iOS working but when run I get the following back through terminal but Alexa just says “Hmmm the camera isn’t responding”


    INITIALIZE RTSP STREAM: Nursery

    • NAME : Nursery
    • LABEL : PRIMARY
    • URL : rtsp://:7447/dD*lnB
    • UUID : STREAM:45a90211-736b-4969-87e5-ff6ecbbeb2b2
    • SESS : 1617e1b1-40e4-43ae-bf08-2484af39739e
    • MODIF : Tue Apr 28 2020 20:06:47 GMT+0100 (BST)
    • TAGS : @tunnel

    The only other thing I can think is it’s something to do with the security of the UDM but I’m unsure how to set up the relevant rules for that port with me being so new to the platform. Gateway is currently running on my MBP but once I can get it successfully working I will get a Raspberry Pi to run it on



  • Have you had any success with this? Im having the same problem on my Echo Show 5, Ubiquiti cameras, and the UDM Pro.



  • Sorry just saw your last response. to rule out the UDM Pro. Have you tried to Open the RTSP stream from your laptop using VLC?



  • @LosBoricua

    To let you all know, I have been successful, in the end I didn’t have to play with firewall rules at all. Turns out the gateway on OS X was the problem, I’m now running the gateway on a Raspberry Pi and everything is working fine. The only thing I’m concerned about is there’s no login credentials required to look at the stream



  • @LosBoricua Yes, VLC plays the RTSP stream just fine.



  • @spalmisano

    What OS are you tuning the gateway on?



  • Yes, if you can VLC stream it then it is the gateway. Maybe firewall rules on the device you installed the gateway is the issue.



  • @AndyAbbott it’s a Ubuntu 20.04 VM.



  • @LosBoricua

    I forgot to say thank you for all your help with the issue!

    Does ubuntu run a firewall as default? Not familiar with that OS sorry, I was originally running gateway on OS X which when disabling firewall ran correctly but took a lot of fiddling. Now running on Pi behind a very secure network so don’t encounter any issues


Log in to reply