Can't start monocle Gateway in Docker [ANSWERED]



  • Hi,

    I can’t start the docker container for the gateway on my Raspberry Pi 3:

    standard_init_linux.go:211: exec user process caused "exec format error"
    
    pi@hyper:~ $ docker version�
    Client: Docker Engine - Community
     Version:           19.03.8
     API version:       1.40
     Go version:        go1.12.17
     Git commit:        afacb8b
     Built:             Wed Mar 11 01:35:24 2020
     OS/Arch:           linux/arm
     Experimental:      false
    
    pi@hyper:~ $ uname -a
    Linux hyper 4.19.97-v7+ #1294 SMP Thu Jan 30 13:15:58 GMT 2020 armv7l GNU/Linux
    

    Greets, pattyland



  • @pattyland

    The current Docker image does not contain a build for ARM-based platforms like the RaspberryPi.
    (It’s currently only available for Intel x64/amd64 based systems: https://hub.docker.com/r/monoclecam/monocle-gateway/tags)

    This is something we started working on a while back before the whole COVID crisis but was put on hold.
    If this is something you are interested in, let me know and we can resurrect this effort in the coming weeks.

    You can however, install Monocle Gateway directly on your Raspberry Pi as a service/daemon. Instructions are here:
    https://monoclecam.com/monocle-gateway/install/linux-raspi

    Thanks, Robert



  • If this is something you are interested in, let me know and we can resurrect this effort in the coming weeks.

    Please progress this. I was about to work out how to build myself but if you could release a supported version that we can pull from docker hub that would be best.

    Regards,

    BenC



  • @Monocle Yes, I’m interested! I think the Raspberry Pi is a very common platform for the Monocle Gateway. I have run on my BalenaOS and can only start containers, not install services.



  • Another one interested on this! o/


Log in to reply