Hikvision DS-KD8003 Camera not working



  • Hello,

    I’ve tried to connect a DS-KD8003 camera but it didn’t work with the echo show 2nd gen. (I don’t use the monocle server, all my dahua cameras work find with the echo show 2nd gen. without the server :)). The stream is working without any problems in VLC or other security software.)

    These were my settings:
    rtsp://192.168.1.74:554/Streaming/Channels/101
    DIGEST
    correct username & password
    720p Resolution (1080p didn’t work either)
    H264
    no audio codec (G711 didn’t work)

    Does anybody know what to do?

    Thank you in advance,
    Max



  • @Max01

    Have you tried using VLC player on the same LAN to see if the stream works with that?

    Your IP looks okay.

    rtsp://192.168.1.74:554/Streaming/Channels/101



  • Thank you for your response. Yes, the stream works with VLC.



  • @Esso

    My IP has the forward slash on the end (my cam is on .57)

    rtsp://192.168.1.57:554/Streaming/Channels/101/

    Try using the / on the end.

    If that doesn’t work try VLC as a test.



  • @Esso said in Hikvision DS-KD8003 Camera not working:

    Try using the / on the end.

    I’ve tried using the / on the end but it didn’t work with the Amazon Echo, it worked with VLC. In VLC the stream works with the / and without.



  • Does anyone know why the rtsp stream is working with vlc but not with the echo show, the picture on the show is only flickering for some seconds and after that I get a “camera is not responding” message from alexa. Very strange… Is there something I could try to make it work?

    Thank you in advance,
    Max



  • @Max01

    Are you using the Monocle Gateway with this camera?

    Thanks, Robert



  • @Max01 said in Hikvision DS-KD8003 Camera not working:

    Hello Robert,

    no I’m not using the Monocle Gateway because all other cameras are working with the echo show (2nd Gen) without the gateway. (I’ve read here in the forums that you don’t need the Gateway if you are using the echo show 2nd gen.)

    greetings,
    Max



  • @Monocle

    Nevermind, I see you mentioned you are not using Monocle server, which I think you mean Monocle Gateway (server).

    It’s most likely some incompatibility with the video codec. You can try to play with the video settings on the camera such as enabling/disabling H.264+ and trying the various H.264 profiles. At the end of the day, the Alexa is a black box and we don’t know exactly why she fails on certain streams that we would expect to be compatible per the documented requirements. Alexa seems to be very picky about the video streams. Dahua/Amcrest firmware seems to provide the most compatible streams.

    If you are not able to find a working combination of settings on the camera, then your last option would be to try using the Monocle Gateway and attempting the various tags (@tunnel or @proxy and optionally @noaudio, @fake-fmtp). The Monocle Gateway can sometimes transform the stream into something Alexa will accept. The Monocle Gateway does not re-encode the stream or transcode the stream as this would add too much latency but it can attempt to play other tricks on the stream descriptor to try to get it working with Alexa devices.

    Thanks, Robert



  • @Monocle said in Hikvision DS-KD8003 Camera not working:

    combination of settings on the camera

    Thank you for your help!! I’ve already tried all combination of settings on the camera. The camera doesn’t have many combination of settings because it is an intercom camera ( https://www.hikvision.com/en/products/Video-Intercom-Products/IP-Series/Pro-Series/ds-kd8003-surface/ ).
    I’ve also tried different firmwares for the camera but it didn’t work (the screen of the echo show is always flickering and after some seconds alexa tells me she cannot connect).
    I’ll try the Monocle Gateway.

    greetings,
    Max



  • @Max01

    Some of the specialty Hikvision cameras are very limited.
    I have an older the Hikvision doorbell camera (DS-KB6403-WIP) and it simply won’t work with any stability at all with Alexa. However, a newer Amcrest (a re-branded Hikvision) https://amzn.to/3dpvdXM camera works fine. So Hikvision does seem to be hit and miss with Alexa.

    With Monocle Gateway, please try the tags in this order:

    • @tunnel
    • @proxy
    • @tunnel, @noaudio
    • @proxy, @noaudio
    • @tunnel, @noaudio, @fake-fmtp
    • @proxy, @noaudio, @fake-fmtp

    @fake-fmtp lies to Alexa about the stream format and gives her a known compatible descriptor. This lie works in some case to get the stream playing. However, it may not be stable.

    Thanks, Robert



  • Thank you very much for your help, I much appreciate it!! 🙂


Log in to reply